Buongiorno ragazzi, qualcuno mi potrebbe aiutare a capire come montare due hdd esterni all'avvio della macchina, sempre nella stessa posizione? Mi spiego: in fstab ho creato due righe per montarli in due directory (chiamate rispettivamente /ftp/250 e /ftp/750) all'avvio ma spesso il sistema li scambia di ordine seguendo una logica che mi sfugge. Esiste un identificativo per montarli sempre nella stessa posizione? Grazie sin d'ora. Andrea

chiesto 07 Mag '15, 12:37

ttg159's gravatar image

ttg159
452712

modificato 07 Mag '15, 12:38


Sì, devi usare l'UUID al posto del nome e numero della partizione (che possono cambiare all'avvio del sistema).

coll. permanente

ha risposto 09 Mag '15, 23:02

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161

Grazie mille. Seguendo le numerose info trovate in rete ho sostituito l'UUID all'identificazione tramite /dev/sd..... Sudo mount -a mi restituisce però errori alle due righe (13 e 15). La causa può essere il fatto che i drives siano in ntfs? Riporto la sintassi adottata: UUID=53B7683915F9C759 /ftp/750 ntfs-3g silent,umask=000,locale=it_IT.utf8 rw,defaults 0 0

UUID=5EAC9498AC946BF1 /ftp/250 ntfs-3g silent,umask=000,locale=it_IT.utf8 rw,defaults 0 0. Grazie, ciao. p.s. chiedo scusa ma ho cercato nel regolamento e nel manuale (markdown) il modo per identificare il codice ma non l'ho trovato

(10 Mag '15, 11:14) ttg159 ttg159's gravatar image

In teoria non dovrebbe cambiare nulla il fatto che siano NTFS.

Vedo che li monti in una cartella che chiami /ftp. Sono HD locali o remoti?

Posta (su pastebin) esattamente tutto l'output con che ti dà quando provi a montarli.

Il markdown è con gli apici inversi questo è un codice per il codice in linea o con riga vuota + 4 spazi a inizio riga per il codice fuori linea.

(11 Mag '15, 08:51) dadexix86 ♦♦ dadexix86's gravatar image

La directory /ftp è nel disco locale del "server". Gli hdd sono esterni, usb. Al comando sudo mount -a il risultato è: Last login: Sun May 10 10:48:13 2015 from 192.168.1.6 andrea@server-TravelMate-4150:~$ sudo mount -a [sudo] password for andrea: [mntent]: riga 13 in /etc/fstab non valida [mntent]: riga 15 in /etc/fstab non valida andrea@server-TravelMate-4150:~$

(11 Mag '15, 09:39) ttg159 ttg159's gravatar image

Posta su pastebin il file /etc/fstab completo per favore.
E l'output completo di

sudo blkid
(11 Mag '15, 15:38) dadexix86 ♦♦ dadexix86's gravatar image

Non ho mai utilizzato pastebin, spero di aver fatto correttamente. http://pastebin.com/sD3hK4TR (fstab) e http://pastebin.com/xsLAPGux (blkid). Ti ringrazio intanto per la disponibilità.

(11 Mag '15, 16:05) ttg159 ttg159's gravatar image

Trovato il problema :)

Hai messo uno spazio al posto di una virgola tra locale=it_IT.utf8 e rw. Togli lo spazio, metti una virgola e sei a posto.

(11 Mag '15, 16:24) dadexix86 ♦♦ dadexix86's gravatar image

attenzione attenzione: sono uno sprovveduto e me ne vergogno :)) (diamo la colpa al fatto che non ho mai la macchina davanti ma ci lavoro in ssh, dai!). Funziona tutto correttamente. I dischi sono montati come da tue indicazioni. Immagino che se sono già montati (perchè ho riavviato il mio amato serverino) l'errore in mount -a sia inevitabile. Grazie ancora per la pazienza e la grande disponibilità. Ti mando una birra virtuale. Ciao! ;) ps. segno come risposta

(11 Mag '15, 16:48) ttg159 ttg159's gravatar image

adesso vado a modificare anche la questione spazio/virgola. grazie ancora. ciao

(11 Mag '15, 16:51) ttg159 ttg159's gravatar image

Ok, alla prossima! Fammi sapere :)

(11 Mag '15, 17:18) dadexix86 ♦♦ dadexix86's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×167
×27
×9

domanda posta: 07 Mag '15, 12:37

domanda visualizzata: 790 volte

ultimo aggiornamento: 11 Mag '15, 17:18

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.