Ho installato Lubuntu sul MacBook (usando rEFIt e facendo partire live CD in modalità NOMODESET). Ho scoperto un piacevolissimo aumento delle prestazioni ma devo sestemare ancora qualche piccolo aspetto. Il portatile MacBook è equipaggiato con il chipset grafico Intel GMA 950 che supporta la risoluzione 1280x800. Purtroppo il sistema va in automatico su 1024x768 e tutto appare sfuocato e di difficile lettura. Inoltre quando collego il monitor esterno questo non viene riconosciuto e non si vede nulla.

Cercando nel web ho trovato molto materiale sull'argomento ma forse è un po' datato e trovo difficoltà a capire cosa devo fare... Spero che qualche esperto possa indicarmi il giusto approccio.

chiesto 19 Mag '15, 10:49

Mariomao's gravatar image

Mariomao
49238

modificato 22 Giu '15, 20:37

enzotib's gravatar image

enzotib ♦♦
14.0k112186

ciao @Mariomao, nell'attesa che qualche esperto si faccia vivo hai provato a vedere in Impostazioni di sistema → Monitor se puoi cambiare la risoluzione dello schermo?

Nella stessa finestra trovi anche la dicitura Scala per menù e barre dei titoli, tramite la quale puoi diminuire la scala per rendere il tutto più piccolo e ridurre lo sfuocamento.

(19 Mag '15, 18:15) alevipri alevipri's gravatar image

La sola risoluzione permessa dal menu di gestione del monitor è quella 1224x768. Non è presenta nessuna opzione per scalare.

(20 Mag '15, 16:17) Mariomao Mariomao's gravatar image

Ti chiederei di cambiare il nome della domanda inserendo Lubuntu invece di Ubuntu. Grazie mille

(20 Mag '15, 18:44) corti-nico corti-nico's gravatar image

Fatto. Avevo messo ubuntu perché così riporta il system profiler

(21 Mag '15, 10:10) Mariomao Mariomao's gravatar image

Aggiungo questi dati, forse possono essere utili: Dalle preferenze di sistema MacOSX il System Profiler riporta: Intel GMA 950:

Modello Chipset: GMA 950 Tipo: GPU Bus: Integrato VRAM (totale): 64 MB di memoria di sistema condivisa Fornitore: Intel (0x8086) ID dispositivo: 0x27a2 ID revisione: 0x0003 Monitor: LCD colori: Risoluzione: 1280 x 800 Profondità pixel: Colore 32 bit (ARGB8888) Monitor principale: Sì Mirror: Spento Online: Sì Integrato: Sì Mostra connettore: Stato: Nessun monitor collegato

(21 Mag '15, 11:30) Mariomao Mariomao's gravatar image

Ho provato così:

mao@mao-lubuntu:~$ xrandr

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
1024x768       76.0* 
1280x800_60.00 (0x19a)   83.5MHz
        h: width  1280 start 1352 end 1480 total 1680 skew    0 clock   49.7KHz
        v: height  800 start  803 end  809 total  831           clock   59.8Hz

Ho pensato quindi che il monitor in uso sia "default" quindi sono andato avanti con:

mao@mao-lubuntu:~$ cvt 1280 800 60

# 1280x800 59.81 Hz (CVT 1.02MA) hsync: 49.70 kHz; pclk: 83.50 MHz
Modeline "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync

A questo punto ho inserito la nuova modeline

mao@mao-lubuntu:~$ xrandr --newmode "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync

xrandr: Failed to get size of gamma for output default
X Error of failed request:  BadName (named color or font does not exist)
Major opcode of failed request:  140 (RANDR)
Minor opcode of failed request:  16 (RRCreateMode)
Serial number of failed request:  19
Current serial number in output stream:  19

Ho provato comunque ad andare avanti:

mao@mao-lubuntu:~$  xrandr --addmode default-0 1280x800_60.00

xrandr: Failed to get size of gamma for output default
xrandr: cannot find output "default-0"

mao@mao-lubuntu:~$ xrandr --newmode default-0 1280x800_60.00

xrandr: failed to parse 'default-0' as a mode specification
Try 'xrandr --help' for more information.

mao@mao-lubuntu:~$ xrandr --auto --output default-0 --mode 1280x800

xrandr: Failed to get size of gamma for output default
warning: output default-0 not found; ignoring

Non è che il problema è legato ai driver? Spero di aver migliorato la formattazione.

(21 Mag '15, 13:06) Mariomao Mariomao's gravatar image

Sono riuscito a risolvere: Il problema stava in un bug del Kernel 3.19 rilasciato nelle distribuzioni di Ubuntu 15.04 (e tutte le derivate Lubuntu inclusa) Il bug causava il blocco su alcune macchine del live CD all'avvio e per l'istallazione si doveva procedere selezionando l'opzione NOMODESET(premendo F6 all'avvio della live) che permette l'avvio utilizzando driver video generici.

Il bug è stato risolto con le versioni Kernel successive, quindi ho caricato la 4.0.5, ho provato il funzionamento quindi ho modificato GRUB2 per eliminare il comando Nomodeset che rimane all'avvio anche dopo l'installazione. Al riavvio ho ritrovato tutte le risoluzioni e scoperto con piacere il funzionamento dello schermo aggiuntivo.

INSTALLARE KERNEL (scegliete l'architettura corretta e fate le dovute variazioni nel mio caso 4.0.5 i836) aprite il terminale e...

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.5-wily/linux-headers-4.0.5-040005_4.0.5-040005.201506061639_all.deb�

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.5-wily/linux-headers-4.0.5-040005-generic_4.0.5-040005.201506061639_i386.deb�

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.5-wily/linux-image-4.0.5-040005-generic_4.0.5-040005.201506061639_i386.deb�

sudo dpkg -i linux-headers-4.0.5*.deb linux-image-4.0.5*.deb�

sudo reboot

A questo punto il mac si riavvia. Aprite quindi il terminale

sudo nano /etc/default/grub

eliminate tutta la riga (la mia era la riga 11) che contiene

GRUB_CMDLINE_LINUX="nomodeset"

A questo punto salvate quindi digitate nel terminale

sudo update-grub

FATTO! A questo punto riavviate normalmente ed il gioco è fatto. Enjoy!

coll. permanente

ha risposto 22 Giu '15, 19:00

Mariomao's gravatar image

Mariomao
49238

@Mariomao: allora accetta la tua risposta, invece di mettere risolto.

(22 Giu '15, 20:36) enzotib ♦♦ enzotib's gravatar image

Ciao Mariomao,

Per risolvere il tuo problema è necessario impostare la risoluzione in modo manuale.


Provare la nuova risoluzione

Per prima cosa apri un terminale (la combinazione è ctrl+alt+t per aprirlo) e digita il comando xrandr

Questo comando ti darà informazioni sulla risoluzione disponibile per il monitor attualmente configurato. L'output dovrebbe essere simile al seguente:

Screen 0: minimum 8 x 8, current 1600 x 900, maximum 16384 x 16384
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS-0 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 360mm x 200mm 1600x900 59.9*+ 50.0 
HDMI-0 disconnected (normal left inverted right x axis y axis)

Individua il nome del monitor che vuoi configurare (nell'esempio sopra è LVDS-0 ma il tuo potrebbe chiamarsi in modo diverso).

Successivamente prova a dare nel terminale il comando

 xrandr --auto --output LVDS-0 --mode 1280x800

Se la risoluzione funziona correttamente, bene, vai al paragrafo successivo. Se invece ottieni l'errore xrandr: cannot find mode 1280x800 devi aggiungere una nuova modalità.

Trovi spiegato tutto nel dettaglo in questa pagina di wiki - Xrandr che ti consiglio di leggere. Nel tuo caso comunque dovresti dare questi comandi:

 cvt 1280 800 60

Copiare la Modeline che ti da in output e dare i comandi

 xrandr --newmode [Modeline]

Dove con [Modeline] sostituisci l'output di cvt in modo da avere un comando simile a

 xrandr --newmode xrandr --newmode "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync

Infine invochi il comando per aggiungere la nuova modalità:

 xrandr --addmode LVDS-0 1280x800_60.00

Adesso invocando nuovamente il comando

 xrandr --auto --output LVDS-0 --mode 1280x800

Dovresti riuscire ad impostare la risoluzione desiderata.


Rendere le modifiche permanenti

Per far sì che le modifiche siano permanenti su Lubuntu devi andare a modificare il file di default di lxsession con il seguente comando:

 sudo leafpad /etc/xdg/lxsession/LXDE/autostart

Modifica il file includendo nell'ultima riga il comando di xrandr che vuoi eseguire ad ogni accesso:

@xscreensaver -no-splash
@lxpanel --profile LXDE
@pcmanfm --desktop --profile LXDE
@/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
@xrandr --auto --output LVDS-0 --mode 1280x800
coll. permanente

ha risposto 20 Mag '15, 17:18

corti-nico's gravatar image

corti-nico
891319

modificato 20 Mag '15, 20:01

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161

Avevo già provato con quella wiki ma non sono riuscito. Comunque riprovo, con i tuoi consigli, magari non ho capito bene qualche passaggio.

Intanto ho già un primo errore:

xrandr --output --auto LVDS-0 --mode1280x800
xrandr: unrecognized option 'LVDS-0'
Try 'xrandr --help' for more information.

e di seguito:

xrandr --newmode "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync
xrandr: Failed to get size of gamma for output default
(21 Mag '15, 10:30) Mariomao Mariomao's gravatar image

@Mariomao cito @corti-nico per evidenziare meglio

Individua il nome del monitor che vuoi configurare (nell'esempio sopra è LVDS-0 ma il tuo potrebbe chiamarsi in modo diverso).

e aggiungo che in caso di errore conviene riportare su pastebin gli input dati e gli output ricevuti, e poi mettere qui il link in modo da farci vedere cosa hai fatto e quali sono stati gli output fino a quel punto.

Concludo ricordandoti che è meglio utilizzare il markdown adeguato per formattare ciò che si scrive, così da renderlo più leggibile (specialmente il codice).

(21 Mag '15, 12:13) dadexix86 ♦♦ dadexix86's gravatar image

Scusatemi, ancora non ho molta familiarità con la netiquette di chiedi.

(21 Mag '15, 12:30) Mariomao Mariomao's gravatar image

monitor presenti:

mao@mao-lubuntu:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
1024x768       76.0* 
1280x800_60.00 (0x19a)   83.5MHz
    h: width  1280 start 1352 end 1480 total 1680 skew    0 clock   49.7KHz
    v: height  800 start  803 end  809 total  831           clock   59.8Hz

Ho provato tutta la procedura utilizzando "default" come nome dello schermo ma non ottengo risultati

(21 Mag '15, 13:10) Mariomao Mariomao's gravatar image

Ciao @Mariomao, puoi provare a dare questi comandi e a vedere se funziona?

xrandr --addmode default 1280x800_60.00
xrandr --auto --output default --mode 1280x800

Posta l'output dei comandi su pastebin e copia il link qui

(21 Mag '15, 14:56) corti-nico corti-nico's gravatar image

Non so se può essere utile l'output dell'hardware montato sul macBook. http://pastebin.com/E7x6m9Rp

mi preoccupa il fatto che i display risultino "unclaimed"

(21 Mag '15, 17:03) Mariomao Mariomao's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×44
×23

domanda posta: 19 Mag '15, 10:49

domanda visualizzata: 1,740 volte

ultimo aggiornamento: 22 Giu '15, 20:37

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.