Buonasera. Sono fierissimo del mio Sony Vaio (con windows veramente scarso...quasi inutilizzabile) trasformato da Ubuntu 15.04 e tutto in veste material design (che a me piace un sacco). Sono molto soddisfatto.

Vorrei che qualcuno mi aiutasse a risolvere un aspetto fastidioso (ma puramente "estetico") di Ubuntu. All'accensione, prima di arrivare alla schermata di login, lo schermo cambia dal grigio al viola (il colore Ubuntu per intenderci) un paio di volte ...poi compare una volta anche la scritta Vaio. E' possibile fare che all'avvio la macchina eviti tutto cio', e arrivi direttamente alla schermata di login?? Grazie per la vostra attenzione.

chiesto 20 Mag '15, 00:20

LorenzoCH's gravatar image

LorenzoCH
15123

Buongiorno :) Marca e modello della scheda video? Driver installati?

In genere la scritta "Vaio" deve comparire all'inizio del processo di boot, non dopo.

Posta anche su pastebin il contenuto del file /etc/default/grub

(20 Mag '15, 09:01) dadexix86 ♦♦ dadexix86's gravatar image

OK. Stasera recupero tutte le info. Una domanda. Cosa vuol dire "posta su pastebin"?

(20 Mag '15, 09:04) LorenzoCH LorenzoCH's gravatar image

Wiki su Pastebin, serve ad evitare lunghi output qui e su altri servizi, migliorando l'usabilità del sito.

(20 Mag '15, 09:07) dadexix86 ♦♦ dadexix86's gravatar image

ciao. inizio con il darti i dati che mi chiedevi stamane: notebook sony vaio SVE1512J6EW PROCESSORE Intel® Core™ i3-3110M CPU @ 2.40GHz × 4 SCHEDA GRAFICA Intel® Ivybridge Mobile 3.7 GB RAM 64 BIT ora cerco di andare su pastebin....

(20 Mag '15, 21:51) LorenzoCH LorenzoCH's gravatar image

ecco! ho postato il grub su pastebin...

(20 Mag '15, 21:55) LorenzoCH LorenzoCH's gravatar image

@LorenzoCH una volta che l'hai postato metti qui il link, così che possiamo vederlo noi :)

(20 Mag '15, 22:09) dadexix86 ♦♦ dadexix86's gravatar image

Te lo faccio modificare, così da vedere cosa succede. Dai

sudo cp /etc/default/grub /etc/default/grub.bak
sudo gedit /etc/default/grub

cancella tutto e incollaci dentro questo, salva, chiudi gedit e aggiorna grub

sudo update-grub

(posta l'output) e riavvia. Dovrebbe apparirti il GRUB e il processo di caricamento. C'è ancora il problema?

Se sì, riesci a fare e postare un video del fenomeno?

(20 Mag '15, 22:37) dadexix86 ♦♦ dadexix86's gravatar image

innanzitutto grazie. Non ho capito cosa devo postare... ti dico intanto quello che succede all-avvio. Appare la scritta Vaio. Parte un contatore che da 3 arriva fino a 0. Appaiono tre righe di testo...(pausa piuttosto lunga) schermo nero riappaiono le stesse (mi sembra) tre righe di prima (altra pausa) parte il processo di caricamento appare la schermata di login.

(20 Mag '15, 23:10) LorenzoCH LorenzoCH's gravatar image

scusa...mi dici come faccio a postare il video?

(20 Mag '15, 23:25) LorenzoCH LorenzoCH's gravatar image

Quindi non sfarfalla più come prima?

Caricalo da qualche parte (tinyupload, gdrive,bropbox,mega) e metti qui il link.

(21 Mag '15, 08:25) dadexix86 ♦♦ dadexix86's gravatar image

buongiorno. no..non sfarfalla ma cmq l'avvio mi sembra sempre un po' macchinoso ma cmq guarda tu stesso. ecco il link:

https://drive.google.com/file/d/0B7_pWhUQIUnaYVM3RDNNM1NNb1U/view?usp=sharing

(21 Mag '15, 08:32) LorenzoCH LorenzoCH's gravatar image

Mi posti per favore l'output di

sudo update-grub

come ti ho chiesto sopra? :)

(21 Mag '15, 08:45) dadexix86 ♦♦ dadexix86's gravatar image

ecco cosa mi risponde il terminale:

Generating grub configuration file ... Attenzione: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported. Trovata immagine linux: /boot/vmlinuz-3.19.0-17-generic Trovata immagine initrd: /boot/initrd.img-3.19.0-17-generic Trovata immagine linux: /boot/vmlinuz-3.19.0-16-generic Trovata immagine initrd: /boot/initrd.img-3.19.0-16-generic Trovata immagine linux: /boot/vmlinuz-3.19.0-15-generic Trovata immagine initrd: /boot/initrd.img-3.19.0-15-generic Adding boot menu entry for EFI firmware configuration fatto

(21 Mag '15, 08:49) LorenzoCH LorenzoCH's gravatar image

Per postare gli output usa Pastebin per favore :)

Modifica di nuovo il file come prima, mettendoci dentro questo questa volta, poi aggiorna di nuovo il grub

sudo update-grub

e posta l'output su pastebin.

(21 Mag '15, 08:53) dadexix86 ♦♦ dadexix86's gravatar image

scusa ma mi succede una cosa strana...faccio la modifica ma non mi fa salvare dicendo che il grub è in sola lettura. ma ieri sera lo avevo fatto senza problemi..

(21 Mag '15, 09:00) LorenzoCH LorenzoCH's gravatar image

Hai aperto gedit con sudo? Posta su pastebin input e output (copia-incolla dal terminale).

(21 Mag '15, 09:06) dadexix86 ♦♦ dadexix86's gravatar image
(21 Mag '15, 09:29) LorenzoCH LorenzoCH's gravatar image

Riavvia e posta un eventuale video :)

(21 Mag '15, 09:37) dadexix86 ♦♦ dadexix86's gravatar image

Sembra tutto a posto, che dici?

Usa questo come file di grub, aggiorna con sudo update-grub e poi riavvia (e fai un video se ti va).

(21 Mag '15, 19:59) dadexix86 ♦♦ dadexix86's gravatar image

Ciao. Scusa se rispondo invece di commentare ma il iPad non mi permette di aprire un nuovo commento. È successo un casino. Solo colpa mia. Ho preparato una chiavetta per provare la live di chromixium ....beh ho fatto come al solito ed ora ill Vaio è diventato inutilizzabile. Come puoi immaginare non posso caricare una immagine ma quello che appare all'avvio è un rettangolo rosso con scritto Secure boot failed operating system is invalid.

Spero ci sia la possibilità di riparare a questo errore. Grazie.

(21 Mag '15, 21:09) LorenzoCH LorenzoCH's gravatar image

Devi accettare i cookies a fondo pagina e aggiornare la pagina.

Non so cosa sia questo "chromixium", hai provato a chiedere al loro supporto direttamente?

(21 Mag '15, 21:24) dadexix86 ♦♦ dadexix86's gravatar image

http://chromixium.org/

credo di aver capito l'errore. questa distribuzione è per pc 32 bit. ed ora che faccio? c'é la possibilità di resettare tutto e reinstallare ubuntu da zero?

(21 Mag '15, 22:24) LorenzoCH LorenzoCH's gravatar image

Mah, se hai la live di Ubuntu la metti su e riparti...
Se non hai la live di Ubuntu puoi crearne una da un altro computer Linux, Mac o Windows, seguendo le guide.

Se non puoi fare nemmeno quello, prova a chiedere al supporto di quella distro cosa devi fare per disfare quello che ha fatto, purtroppo non so essere più specifico...

Comunque mi sembra strano che tu abbia solo fatto avviare la live e ti si sia incasinato così il boot!

(21 Mag '15, 22:27) dadexix86 ♦♦ dadexix86's gravatar image

Ho risolto!! Ho scoperto che il Vaio ha un tasto che si chiama Assist che avvia il pc e conduce alle impostazioni bios. ho disattivato il secure boot ed il partito è ripartito come prima. Comunque no..ho provato con la live di Ubuntu ma il sisitema si bloccava un secondo dopo l'avvio. Il vaio ora me lo tengo cois' che va benissimo. Grazie di tutto!!

(21 Mag '15, 22:40) LorenzoCH LorenzoCH's gravatar image

Ottimo, quindi hai risolto il problema della domanda?

(21 Mag '15, 22:44) dadexix86 ♦♦ dadexix86's gravatar image

si. dimmi cosa devo fare?

(21 Mag '15, 22:50) LorenzoCH LorenzoCH's gravatar image

Scrivo una risposta in cui riassumo i passaggi che ti ho fatto fare e poi accettala, grazie :)

(21 Mag '15, 23:07) dadexix86 ♦♦ dadexix86's gravatar image

  1. Fai una copia di backup del file di configurazione di GRUB

    sudo cp /etc/default/grub /etc/default/grub.bak
    
  2. Modifica il file di configurazione di GRUB

    sudo gedit /etc/default/grub
    
  3. Sostituiscilo con questo

  4. Salva, chiudi Gedit e aggiorna il GRUB

    sudo update-grub
    
  5. Riavvia et voilà!

coll. permanente

ha risposto 21 Mag '15, 23:09

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×161
×22

domanda posta: 20 Mag '15, 00:20

domanda visualizzata: 979 volte

ultimo aggiornamento: 21 Mag '15, 23:09

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.