0
2

Sono diversi giorni che provo a montare 2 dischi da 3TB su ubuntu (in seguito al passaggio da 10.04 Gnome a 14.04 Mate).
Ho creato le cartelle in cui montarli, dentro a /media/
Ho modificato fstab utilizzando gli UUID dei 2 dischi.
non posso usare fdisk perchè non è in grado di gestire GPT.
Così utilizzo gdisk:

sudo gdisk -l /dev/sdb

e lui mi fornisce il Disk identifier (GUID).
Ma se lo uso nel fstab non lo riconosce. Idem se uso UUID, non me li riconosce più.
Eppure con

sudo lshw

vedo dischi e volumi.
Ma qui la cosa strana: se apro il programma Dischi (che altri non è che Gparted) non mi permette di fare NULLA. Rileva il disco come spazio vuoto, e mi da la possibilità di creare una partizione.
Eppure se lo collego in esterno, su windows7, con una applicazione per vedere ext4, vedo tutto il contenuto con successo.
Ribadisco, tutto funzionava, prima che cambiassi sistema operativo.

Cosa sta succedendo?

chiesto 25 Mag '15, 14:20

Enrico's gravatar image

Enrico
-1122

modificato 25 Mag '15, 15:16

corti-nico's gravatar image

corti-nico
891319

Ciao, Ubuntu Mate 14.04 non è una derivata ufficiale, Mate è supportato ufficialmente solo dalla 15.04, non escluderei che il problema possa trovarsi lì.

Se usi una derivata ufficiale (Per la 14.04LTS sono Xubuntu, Lubuntu, Kubuntu, Ubuntu Gnome, Ubuntu Studio, Edubuntu, ecc) hai lo stesso problema?
Se no, abbiamo trovato il problema.
Se sì, modifica la domanda riportando il tutto a questa derivata ufficiale.

Inoltre, sarebbe opportuno che ce li dicessi gli output dei comandi che hai dato, in modo che possiamo avere un quadro completo della cosa.

(25 Mag '15, 14:27) dadexix86 ♦♦ dadexix86's gravatar image

Aggiungo che sarebbe molto comodo avere l'output completo del tuo fstab

(25 Mag '15, 14:31) corti-nico corti-nico's gravatar image

Non usare le risposte ma usa i commenti. Inoltre visto che l'output è abbasta grosso copialo su pastebin e metti il link ;)

(25 Mag '15, 15:12) corti-nico corti-nico's gravatar image

Come sopra: Non usare le risposte ma usa i commenti. Inoltre visto che l'output è abbasta grosso copialo su pastebin e metti il link ;)

(25 Mag '15, 15:15) corti-nico corti-nico's gravatar image

@Enrico a meno di rispondere alla (tua) domanda principale utilizza i commenti, grazie. E per i lunghi output utilizza Pastebin.

Infine, Ubuntu Mate 14.04 non è ufficialmente supportata da questo sito di supporto, per avere supporto qui devi passare alla 15.04 o a un'altra derivata che sia ufficiale.

(25 Mag '15, 15:15) dadexix86 ♦♦ dadexix86's gravatar image

Purtroppo no, queste sono sempre risposte. Trovi il bottone commenta vicino alla tua prima domanda.

(25 Mag '15, 15:22) corti-nico corti-nico's gravatar image

sudo lshw (solo parte dischi): http://pastebin.com/RdvQEqqv

Posso installare ubuntu lts in pochi minuti ma tornerà il medesimo problema...

sudo nano /etc/fstab: http://pastebin.com/bRPEVKBJ

Credo di esser riuscito a usare commenti e PasteBin

(25 Mag '15, 15:24) Enrico Enrico's gravatar image

Ti pregherei di fare attenzione quando posti in quanto il tuo output di lshw è presente 5 volte in questa discussione. Puoi ridare un'occhiata ai commenti che hai messo e togliere quelli duplicati?

Inoltre come ti ha già detto @dadexix86 Mate 14.04 non è ufficialmente supportata quindi qui avremo difficoltà ad aiutarti

(25 Mag '15, 15:29) corti-nico corti-nico's gravatar image

Ce l'abbiam fatta, bravissimo!

Installa Ubuntu 14.04 LTS, con i dischi collegati, e specifica il punto di mount al momento dell'installazione.

(25 Mag '15, 15:30) dadexix86 ♦♦ dadexix86's gravatar image

Ho fatto pulizia. Ora reinstallerò ubuntu come chiedete, ma sappiate che ci sono già passato 3 settimane fa... ci sentiamo tra un ora

(25 Mag '15, 15:36) Enrico Enrico's gravatar image

Perfetto ;) Attendiamo news

(25 Mag '15, 15:37) corti-nico corti-nico's gravatar image

@Enrico posta una schermata della procedura di installazione in cui setti di montare le partizioni nelle cartelle che preferisci.

(25 Mag '15, 15:43) dadexix86 ♦♦ dadexix86's gravatar image

Allora ho installato la 15.04 LTS 64bit sul nuovo HD (SSD Samsung 850 da 120GB) ed ho collegato entrambi i dischi GPT da 3TB. Ovviamente ubuntu in fase di installazione non li ha visti. Ora, come abitudine, procedo nel creare le cartelle dentro a media, su cui montare i dischi:

cd /media
sudo mkdir film1
sudo mkdir film2

Fatto ciò vado a scoprire quali sono gli UUID dei 2 dischi con il comando:

sudo lshw

Infine apro e modifico fstab inserendo i due dischi:

sudo nano /etc/fstab
(25 Mag '15, 16:34) Enrico Enrico's gravatar image

E...va o non va? Inoltre ti ricordo che dovresti usare i commenti, le risposte servono solo per le vere Risposte al tuo problema e non per aggiungere ulteriori dettagli

(25 Mag '15, 16:38) corti-nico corti-nico's gravatar image

Non è ovvio che non li veda, anzi!

Accedi da live e posta

sudo parted -l
(25 Mag '15, 16:39) dadexix86 ♦♦ dadexix86's gravatar image

ecco lshw: http://pastebin.com/iHpXAPdc

ho provato a sostituire gli UUID con il GUID o PTUUID che sata fuori da blkid.. niente

(25 Mag '15, 19:17) Enrico Enrico's gravatar image

dulcis in fundo non parte più il pc. Ora mi arriva un ata2 softreset failed (dopo aver lasciato che 15.04 si aggiornasse) Il problema non mi è nuovo. Questa è la principale ragione per cui avevo preferito migrare su una più stabile Mate14.04 anzichè Ubuntu15.04

(25 Mag '15, 19:19) Enrico Enrico's gravatar image

Ok lshw, ma io vorrei l'output del comando che ti ho chiesto prima...

(25 Mag '15, 19:23) dadexix86 ♦♦ dadexix86's gravatar image

parted -l http://pastebin.com/2wu3itmT

non vede gli altri 2 dschi

(25 Mag '15, 19:47) Enrico Enrico's gravatar image

Da live gparted li vede?
E il BIOS li vede?

(25 Mag '15, 19:51) dadexix86 ♦♦ dadexix86's gravatar image

Bios si certo, ho appena installato gparted, vede i dischi ma non trova partizioni. sto forzando il recupero filesystem...

(25 Mag '15, 20:05) Enrico Enrico's gravatar image

A me questo "ata2 softreset failed" puzza di incompatibilità hardware.

Fammi sapere come va.

(25 Mag '15, 20:06) dadexix86 ♦♦ dadexix86's gravatar image

ho comunque degli errori che ritornano indipendentemente dalla versione di ubuntu utilizzata: "/dev/sdc etichetta del disco non riconosciuta" e "impossibile avere una partizione al di fuori del disco". Ho visto che per risolvere il softreset failed si può modificare il kernel. Ma quello che non mi spiego è perchè con la 9.04 e 10.04 è andato bene per anni e poi improvvisamente si è inchiodato tutto... e ribadisco che i dischi sono integri e li vedo da windows (con software dedicato)

(25 Mag '15, 20:11) Enrico Enrico's gravatar image

Sul fatto che i dischi siano integri perché li vedi da Windows non ci metterei la mano sul fuoco. I driver per Windows non sono nativi e potrebbero aver creato loro i problemi che riscontri.

I dischi si rompono anche senza apparente ragione.

Sull'etichetta, crea un label da Gparted e dovresti risolvere. Purtroppo senza sapere esattamente a quale versione di kernel hanno smesso di funzionarti è impossibile andare a spulciare i commitlog per capire cosa è cambiato.

L'applicazione Dischi, da live, quali dati SMART ti riporta?

(25 Mag '15, 20:17) dadexix86 ♦♦ dadexix86's gravatar image

dati S.M.A.R.T PERFETTI. Nessuna anomalia o rottura. Però non vede le partizioni. Il problema è nato su Ubuntu, tant'è che ho provato e riprovato a farglieli vedere con una nuova versione. Il passaggio su windows è stato solo un test per verificare l'effettiva funzionalità dei dischi e l'esistenza dei dati. Ho usato Diskinterinals Linux Reader, in sola lettura, per preservare l'integrità dei dati...

(25 Mag '15, 20:22) Enrico Enrico's gravatar image

Ricapitolando, quindi, con 10.04 funzionava, ma non con le versioni 14.04 e 15.04 no. Per le versioni intermedie non sai. Corretto?

Puoi provare con la 12.04, cominciando dalla 12.04.1 e avanzando pian piano fino all'ultima?

(25 Mag '15, 20:25) dadexix86 ♦♦ dadexix86's gravatar image

Mmm durante uno degli aggiornamenti della 10.04 ha cominciato ad andarmi tutto a monte. Un po' il passaggio dal MBR al GPT... un po' gli aggiornamenti di versione... Prima un disco poi l'altro... A questo punto sto preparando dei dischi di backup, provo a svuotare un GPT (2200GB) e a formattarlo direttamente da ubuntu e vedere se lo gestisce bene... vediamo se ricreando la partizione ex novo funziona. Ci vorranno giorni per trasferire tutti i dati.

(25 Mag '15, 20:50) Enrico Enrico's gravatar image

Mah, adesso mi è venuto un dubbio.

La 10.04 non supportava GPT. Quindi i dischi erano MBR.
Però ora dici che sono diventati GPT. Come è possibile questa cosa?

Li hai formattati nel frattempo?

(25 Mag '15, 21:01) dadexix86 ♦♦ dadexix86's gravatar image

Esatto. Infatti avevo 2 dischi da 2TB MBR con partizioni NTFS. Poi con l'aggiornamento sono riuscito a fargli riconoscere i nuovi dischi da 3TB (ext4 su GPT) e i vecchi da 2TB. La cosa è stata semplice perchè sono stati formattati direttamente dentro linux. I problemi ho cominciato ad averli quando ho dovuto staccare e ri-attaccare gli stessi dischi e in seguito all'ennesimo aggiornamento verso la 12.04... Ubuntu ha smesso di riconoscerli, prima uno poi l'altro. Forse un altro problema è che il mio bios non è UEFI.

(25 Mag '15, 21:07) Enrico Enrico's gravatar image

Mai formattati... solo spostati quando ho installato i rack per dischi....

(25 Mag '15, 21:08) Enrico Enrico's gravatar image

Potrebbe essere che il tuo BIOS non supporti GPT.

Se mi dai più info (marca e modello della scheda video, numero del bios) ti cerco più informazioni.

Puoi recuperarle con

sudo dmidecode
(25 Mag '15, 21:11) dadexix86 ♦♦ dadexix86's gravatar image

Scusa ma ho usato i dischi da 3TB per circa 2 anni su questo stesso pc!!! Li supporta, a patto che il sistema sia a 64bit.

(25 Mag '15, 21:13) Enrico Enrico's gravatar image

Scusami, questo non era chiaro da quanto sopra :)

(25 Mag '15, 21:27) dadexix86 ♦♦ dadexix86's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×32
×12
×11
×7
×4

domanda posta: 25 Mag '15, 14:20

domanda visualizzata: 907 volte

ultimo aggiornamento: 25 Mag '15, 21:27

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.