Ciao a tutti sul mio portatile ho Lubuntu 14.04 in dual boot con windows 7. Dato che spesso quando ero su youtube con chromium il pc si sforzava molto e a volte si spegneva ho provato a cambiare i driver della scheda video da quelli open a quelli proprietari ma avendo poi un problema di luminosita ho provato a rimettere quelli open. Al riavvio del pc mi compare un login testuale in alto c'è scritto che si tratta di tty1 appena provo ad avviare qualcosa mi dice Gtk-WARNING **: cannot open display. non conosco molto bene linux ma ho comunque provato tramite console a installare uno dei 2 driver ma al riavvio mi da sempre la stessa schermata. La scheda video è una radeon hd 6400m/7400m Ci sono gia alcune domande su questa scheda video ma non sono comunque riuscito a risolvere

chiesto 11 Lug '15, 15:44

sambuccid's gravatar image

sambuccid
30125

modificato 12 Lug '15, 20:11

Ciao, i driver proprietari li hai installati da Driver aggiuntivi o li hai scaricati dal sito AMD?

(11 Lug '15, 15:59) alevipri alevipri's gravatar image

da driver aggiuntivi inizialmente ma poi quando non caricava piu la parte grafica ho provato un'installazione da terminale

comunque anche ad altre persone i driver proprietari davano lo stesso problema allora reinstallando sempre da driver aggiuntivi quelli open è successo il tutto

(11 Lug '15, 17:06) sambuccid sambuccid's gravatar image

Se operi da terminale, per dare quei comandi prima di tutto:

  • digita: Ctrl + Alt + F2
  • inserisci nome utente e password dell'amministratore
  • ora inserisci i comandi precedenti (uno alla volta)
(11 Lug '15, 17:23) alevipri alevipri's gravatar image

Allora opero soltanto da terminale e non mi carica la modalità grafica(avevo provato lxsession o altro ma sempre "gtk-warning" per quanto riguarda il comando ho digitato, confermato con y, e da un errore(vi scrivo le ultime righe che riesco a vedere):

cp: creazione dell'extent di "/tmp/mkinitramfs_FdGRjI//sbin/blkid" non riuscita:
 Spazio esaurito sul device
cp: errore scrivendo "/tmp/mkinitramfs_FdGRjI//lib/x86_64-linux-gnu/libblkid.so.
1": Spazio esaurito sul device
cp: creazione dell'extent di "/tmp/mkinitramfs_FdGRjI//lib/x86_64-linux-gnu/libb
lkid.so.1" non riuscita: Spazio esaurito sul device
cp: errore scrivendo "/tmp/mkinitramfs_FdGRjI//lib/x86_64-linux-gnu/libuuid.so.1
": Spazio esaurito sul device
cp: creazione dell'extent di "/tmp/mkinitramfs_FdGRjI//lib/x86_64-linux-gnu/libu
uid.so.1" non riuscita: Spazio esaurito sul device
cp: errore scrivendo "/tmp/mkinitramfs_FdGRjI//bin/date": Spazio esaurito sul de
vice
cp: creazione dell'extent di "/tmp/mkinitramfs_FdGRjI//bin/date" non riuscita: S
pazio esaurito sul device
E: /usr/share/initramfs-tools/hooks/fixrtc failed with return 1.
update-intramfs: failed for /boot/initrd.img-3.13.0-57-generic whit 1.
dpkg: errore nell'elaborare il pacchetto initramfs-tools (--purge):
 il sottoprocesso installato script di post-installation ha restituito lo stato 
di errore 1
Si sono verificati degli errori nell'elaborazione:
 fglrx
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)

Grazie a tutti della disponibilità e scusate dei vari ritardi a connettermi (non speravo in una risposta cosi veloce)

Edit: Allora non avevo dato il reboot per il problema ma quando poi ho riavviato mi si è caricata la grafica e mi da un errore: Si è verificato un problema a un programma di sistema nei dettagli c'è ExecutablePath /usr/bin/Xorg inoltre segnalando il problema poi mi da un'altro problema: Si è verificato un problema durante l'installazione del software. Pacchetto:initramfs-tools 0.103ubuntu4.2 altri problemi a: /usr/share/apport/apport-gtk package apport-gtk 2.14.1-0ubuntu3.11 problemtype crash traceback File "/usr/share/apport/apport-gtk", line 594, in <module> app.run_argv() e poi al file "/usr/lib/pyton3/dist-packages/apport/ui.py, le linee 681(run_argv, return self.run_crashes()), 238(run_crashes, self.run_crash(f), 317(run.crash, self.file_report()), 1253(file_report, self.open_url(url)), 1153(open_url, pid=out.splitlines()[0].split()[0]) indexerror:list index out of range UnreportableReason Sono presenti delle versioni di pacchetti obsolete. Esegiure l'avanzamento di versione dei seguenti pacchetti e verificare se il problema è ancora presente: anacron, base-passwd, gdb, gir1.2-javascriptcoregtk-3.0,gir1.2-webkit-3.0, libcups2, libgnutls26, libjavascriptcoregtk-3.0.0, liblocale-gettext-perl, libpam-systemd, libpython3-stdlib, libsystem-login0, libtext-charwidth-perl, libtext-iconv-perl, libudev1, libwebkitgtk-3.0.0, perl-base, procps, python3, python3-apt, python3-dbus, python3-gi, python3-minimal, python3-pkg-resources, python3-software-proprieties, rsyslog, software-proprieties-common, software-proprieties-gtk, systemd-sevices, udev

credo che il tutto sia dato da un problema di browser altro problema con /sbin/init

scusate il disordine ma era tutto in fila e allora ho copiato cosi

(12 Lug '15, 19:11) sambuccid sambuccid's gravatar image

@sambuccid: non usare le risposte, usa i commenti

(12 Lug '15, 20:32) enzotib ♦♦ enzotib's gravatar image

Spazio esaurito sul device

Proviamo a risolvere il problema liberando un po' di spazio:

sudo apt-get clean

Una volta fatto, dai i comandi che ti avevo segnalato in precedenza:

sudo apt-get remove --purge fglrx*

sudo reboot

Facci sapere

(13 Lug '15, 10:19) alevipri alevipri's gravatar image

Allora il clean non mi ha dato risultati a schermo, ma nessun errore per gli altri 2 comandi, ora si carica perfettamente ma all'avvio prima di caricare succede una strana cosa per pochissimo tempo, quasi come un effetto neve delle vecchie tv ma poi si carica tutto benissimo. non so se possa indicare un problema che poi potrebbe uscire fuori piu avanti oppure no.

(13 Lug '15, 10:50) sambuccid sambuccid's gravatar image

È normale che non ti abbia dato risultati a schermo. In pratica ha eliminato un po' di pacchetti .deb che non ti servivano più, di fatto liberando spazio sul tuo pc.

Ora se i comandi che ti ho scritto non hanno dato ulteriori problemi, carica su Pastebin il risultato del comando:

sudo apt-get update

Se questo comando non segnala errori, puoi fare gli aggiornamenti richiesti.

(13 Lug '15, 10:59) alevipri alevipri's gravatar image

http://paste.ubuntu.com/11871501/ comunque si segnala degli errori

(13 Lug '15, 11:11) sambuccid sambuccid's gravatar image

Ok, si direbbe che tu abbia fatto un avanzamento di versione da Lubuntu 13.10 a Lubuntu 14.04, ma che questo non sia andato completamente a buon fine. Difatti hai alcuni repository della 13.10 che non funzionano più (la 13.10 non è più supportata), da cui deriva l'errore.

Dato che il problema della grafica è risolto, direi che questa domanda la possiamo considerare risolta. Quindi per favore accetta la risposta (simbolo di spunta "v" a sinistra della risposta) e apri una nuova domanda con questo problema.

(13 Lug '15, 11:21) alevipri alevipri's gravatar image

e per quella specie di effetto neve va bene cosi? oppure potrebbe sfociare in problemi futuri? grazie

(13 Lug '15, 11:24) sambuccid sambuccid's gravatar image

Giusto, non lo ricordavo. Compare prima di arrivare alla schermata di login o è presente anche dopo? Potresti allegare un'immagine?

Su un pc fisso utilizzo i driver open Radeon, anche se il modello di scheda video è differente non ho mai riscontrato questo "problema".

Potrebbe dipendere dal fatto che l'avanzamento di versione non è stato completato, oppure potrebbe essere solamente uno sfarfallio della grafica iniziale (nulla di preoccupante in questo caso).

(13 Lug '15, 11:30) alevipri alevipri's gravatar image

Per problemi futuri: molto più probabile che vengano dall'avanzamento non completato, piuttosto che dai driver che stai utilizzando.

(13 Lug '15, 11:31) alevipri alevipri's gravatar image

neanche a me quando poco tempo fa utilizzavo i driver open mi appariva in pratica carica lubuntu(con i puntini) poi si vede un'immagine dell'ultima volta prima di spegnere(non piu quell'effetto) e poi il login

(13 Lug '15, 11:40) sambuccid sambuccid's gravatar image

Credo che adesso la cosa più importante sia correggere i problemi di aggiornamento, quindi sarebbe meglio che tu aprissi una nuova domanda inserendo l'output di Pastebin.
Potrebbe essere che, risolto questo problema e installati correttamente gli aggiornamenti, il problema si risolva da sè.

Oppure il problema potrebbe essere differente. Da quel che so, alcuni file utilizzati dal driver open Radeon vengono sostituiti quando si installa il driver proprietario. Il processo tuttavia non è reversibile: se rimangono i file "proprietari", potrebbero non essere correttamente gestiti dal driver open

(13 Lug '15, 11:51) alevipri alevipri's gravatar image

ok, grazie di tutto

(13 Lug '15, 11:53) sambuccid sambuccid's gravatar image

Dato che hai sempre usato i driver presenti nei repository di Ubuntu (non hai installato driver dal sito AMD), procedi in questo modo.

A. Da schermata nera:

  • digita: Ctrl + Alt + F2;
  • inserisci nome utente e password dell'amministratore;
  • ora inserisci i comandi seguenti (uno alla volta).

B. Liberare spazio: dato che non hai spazio disco a sufficienza (vedere i commenti alla domanda), digita il comando seguente:

sudo apt-get clean

C. Inserisci i seguenti comandi nel terminale:

sudo apt-get remove --purge fglrx*

per verificare che tutte le componenti dei driver proprietari siano state rimosse, quindi riavvia con:

sudo reboot

I driver open Radeon non vanno reinstallati (non vengono rimossi, nemmeno se installi i driver Catalyst), dovrebbero funzionare nuovamente una volta rimossi quelli proprietari.

coll. permanente

ha risposto 11 Lug '15, 17:19

alevipri's gravatar image

alevipri
5.5k2479

modificato 13 Lug '15, 11:08

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×255
×129
×12

domanda posta: 11 Lug '15, 15:44

domanda visualizzata: 1,158 volte

ultimo aggiornamento: 13 Lug '15, 11:53

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.