Buongiorno alla Comunità Chiedi Ubuntu. Di recente ho scaricato ed installato il nuovo Ubuntu 15.04 e dopo l'aggiornamento di tutti i pacchetti, il mio Ubuntu Software Center non funziona! Ovvero si avvia e, rimanendo grigio, dopo pochi secondi si chiude. Ho digitato da terminale "sudo software-center" e la risposta e:

giuseppe@giuseppe-HP-530-Notebook-PC-GH637AA-ABZ:~$ sudo software-center
[sudo] password for giuseppe: 
2015-08-20 17:55:03,145 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2015-08-20 17:55:04,958 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.Geoclue.Error.notAvailable: Geoclue master client has no usable Address providers'
2015-08-20 17:55:05,182 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2015-08-20 17:55:05,193 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2015-08-20 17:55:05,384 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/aptcache.py", line 261, in open
    self._cache = apt.Cache(progress)
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 107, in __init__
    self.open(progress)
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 155, in open
    self._list.read_main_list()
SystemError: E:Tipo "sudo" non riconosciuto alla riga 1 nel file delle sorgenti /etc/apt/sources.list.d/spotify.list
2015-08-20 17:55:08,497 - softwarecenter.db.enquire - ERROR - _get_estimate_nr_apps_and_nr_pkgs failed
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/enquire.py", line 115, in _get_estimate_nr_apps_and_nr_pkgs
    tmp_matches = enquire.get_mset(0, len(self.db), None, xfilter)
  File "/usr/share/software-center/softwarecenter/db/appfilter.py", line 89, in __call__
    if (not pkgname in self.cache and
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/aptcache.py", line 281, in __contains__
    return self._cache.__contains__(k)
AttributeError: 'NoneType' object has no attribute '__contains__'
Traceback (most recent call last):
  File "/usr/bin/software-center", line 183, in <module>
    app.run(args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 1378, in run
    self.show_available_packages(args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 1316, in show_available_packages
    self.view_manager.set_active_view(ViewPages.AVAILABLE)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/viewmanager.py", line 150, in set_active_view
    view_widget.init_view()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/availablepane.py", line 227, in init_view
    self.cache, self.db, self.icons, self.apps_filter)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/lobbyview.py", line 80, in __init__
    self.build()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/lobbyview.py", line 326, in build
    self._build_homepage_view()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/lobbyview.py", line 121, in _build_homepage_view
    self._append_whats_new()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/lobbyview.py", line 255, in _append_whats_new
    whats_new_cat = self._update_whats_new_content()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/lobbyview.py", line 240, in _update_whats_new_content
    docs = whats_new_cat.get_documents(self.db)
  File "/usr/share/software-center/softwarecenter/db/categories.py", line 131, in get_documents
    nonblocking_load=False)
  File "/usr/share/software-center/softwarecenter/db/enquire.py", line 330, in set_query
    self._blocking_perform_search()
  File "/usr/share/software-center/softwarecenter/db/enquire.py", line 225, in _blocking_perform_search
    matches = enquire.get_mset(0, self.limit, None, xfilter)
  File "/usr/share/software-center/softwarecenter/db/appfilter.py", line 89, in __call__
    if (not pkgname in self.cache and
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/aptcache.py", line 281, in __contains__
    return self._cache.__contains__(k)
AttributeError: 'NoneType' object has no attribute '__contains__'
giuseppe@giuseppe-HP-530-Notebook-PC-GH637AA-ABZ:~$

Certo di un Vostro aiuto, attendo per risolvere...Grazie

chiesto 20 Ago '15, 18:26

GiuseppeF's gravatar image

GiuseppeF
19223

modificato 21 Ago '15, 12:12

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161


Utilizza il markdown per favore la prossima volta.

Cito dagli errori:

SystemError: E:Tipo "sudo" non riconosciuto alla riga 1 nel file delle sorgenti /etc/apt/sources.list.d/spotify.list

Se usi ppa esterni è frequente che qualcosa si rompa. Elimina i ppa che hai aggiunto e riprova.

coll. permanente

ha risposto 21 Ago '15, 12:13

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161

Grazie! Risolto!

(21 Ago '15, 20:52) GiuseppeF GiuseppeF's gravatar image

@GiuseppeF: accetta la risposta di @dadexix86, please.

(22 Ago '15, 09:20) enzotib ♦♦ enzotib's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×271

domanda posta: 20 Ago '15, 18:26

domanda visualizzata: 1,291 volte

ultimo aggiornamento: 22 Ago '15, 09:20

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.