Su Ubuntu 15.04 dopo aver cambiato un driver nvidia non riesco più ad accedere perché comprare una schermata nera con la frase in oggetto.

Ho provato, come suggerito in vari forum, la seguente istruzione:

sudo systemctl enable gdm.service -f

Ma ricevo un messaggio di errore. Tra l'altro a me risulta di avere lightdm ma se sostituisco gdm con light dm mi dice che non lo trova. Infine da recovery non riesco ad arrivare la connessione sia da wifi che da eternet.

Non so più come procedere

Grazie Stefano

chiesto 30 Ago '15, 12:57

stefanominguzzi's gravatar image

stefanominguzzi
2012

modificato 23 Set '15, 15:35

corti-nico's gravatar image

corti-nico
891319

@stefanominguzzi: non so dove hai preso queste istruzioni, che non sono certo per ubuntu, dato che ubuntu non usa più gdm da tempo, inoltre non è chiaro se ti si presenta un prompt dei comandi oppure no.
Io proverei ad andare sul primo terminale virtual (premendo contemporaneamente Cltr-Alt-F1), se ti permette di fare login, lo farei e poi scrivere

sudo service lightdm restart

per vedere se si avvia la grafica, e non è detto.

(30 Ago '15, 13:30) enzotib ♦♦ enzotib's gravatar image

Con shift in avvio riesco ad andare in recovery mode.

Ho provato ma ricevo questo messaggio di errore:

Error getting authority: error inizializing authority: could not connect: no such file or directory (g-io-error-quark, 1) Fail to restart lightdm.service: sysinit.target is queued, ignori restart request for unit lightdm.service

Grazie Stefano

(30 Ago '15, 16:18) stefanominguzzi stefanominguzzi's gravatar image

@stefanominguzzi: non usare le risposte, usa i commenti.
Come hai "cambiato un driver nvidia"? Spiega un po'.

(30 Ago '15, 18:42) enzotib ♦♦ enzotib's gravatar image

Da dentro Ubuntu (allora si avviava) ho cambiato la versione del driver di NVIDIA perché continuava a dirmi che non riusciva ad aggiorare LIGHTDM-GOBJECT perché il repository non era affidabile. Era un tentativo un po' a casa, mi rendo conto. Risultato? Da quel momento al riavvio mi compare la schermata nera con la frase in questione.

Grazie Stefano

(31 Ago '15, 16:42) stefanominguzzi stefanominguzzi's gravatar image

Nessuna idea? E se riuscissi a connettermi così da aggiornare i pacchetti? Potrebbe essere risolutivo? Al momento mi dà l'errore getting authority... riportato su.

(02 Set '15, 22:51) stefanominguzzi stefanominguzzi's gravatar image

Ho avuto anche io problemi simili con i driver nvidia, quando li installavo manualmente, una volta risolsi entranto con ctrl-alt-f1 e disinstallando i driver (il pc tornò ai driver open), purtroppo più di così non ti posso aiutare, se non riesci a sistemarlo, l'ultima spiaggia è lanciare una live usb, copiare tutti i documenti importanti e reinstallare ubuntu, se non hai necessità particolari la 14.04.3 è più che sufficiente, ed è più stabile della 15.04.

(03 Set '15, 02:06) alphandomega alphandomega's gravatar image

Alla fine ho creato un livecd e ho aggiornato la 15.04 esistente. Ora il problema nuovo è che qualsiasi password metto durante l'installazione o da recovery al login me la accetta, mi fa vedere il terminal per 1 secondo e mi riporta al login (senza alcun messaggio di errore). In modalità ospite entro senza problemi.

Mi verrebbe da radere al suolo tutto e ricominciare con la 14.04 ma così perdere alcuni dati non ancora backuppati. Suggerimenti?

(12 Set '15, 12:16) stefanominguzzi stefanominguzzi's gravatar image

Il problema è che hai dei file nella tua home che non sono tuoi, probabilmente hai aperto qualcosa con sudo che non avresti dovuto aprire così.

Fai login testuale (Ctrl+Alt+F1), poi dai

sudo rm -r ~/.Xauthority
sudo chown -R TUOUTENTE:TUOUTENTE ~

dove al posto di TUOUTENTE metti il nome del tuo utente.

(12 Set '15, 13:41) dadexix86 ♦♦ dadexix86's gravatar image

ho provato sia da terminal (da live cd) che da recovery nel primo caso la prima istruzione passa e alla seconda mi dice che l'utente non è valido. Nel secondo caso mi dice:

impossibile rimuovere /root/.Xauthority file o directory inesistente

(15 Set '15, 18:44) stefanominguzzi stefanominguzzi's gravatar image

Qual è il nome del tuo utente?

Comunque non devi farlo da live, ma da Ctrl+Alt+F1, dopo aver fatto il login col tuo utente (non recovery!)

(15 Set '15, 21:31) dadexix86 ♦♦ dadexix86's gravatar image

il problema all'origine è che non riesco a fare login, o meglio inserisco username e password, non mi dà alcun messaggio di errore e mi riporta alla pagina di login.

(18 Set '15, 16:03) stefanominguzzi stefanominguzzi's gravatar image

Ma anche da tty1 (che raggiungi con Ctrl+Alt+F1)?

(18 Set '15, 17:46) dadexix86 ♦♦ dadexix86's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×31

domanda posta: 30 Ago '15, 12:57

domanda visualizzata: 728 volte

ultimo aggiornamento: 23 Set '15, 15:35

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.