Ciao a tutti,
è da poco che ho deciso di passare a Linux e purtroppo ho già un problemino.

In questo momento nel mio PC è montato Linux Mint 15 Olivia Cinnamon, che pone le proprie radici in Ubuntu (o almeno per quanto ne ho capito). Sebbene per adesso possiedo Olivia, c'è da dire anche che ho provato innumerevoli OS, tra cui anche Ubuntu 12.04.3, e ho riscontrato lo stesso problema.

Veniamo al punto: gli speaker non funzionano, mentre se inserisco le cuffie riesco a sentire perfettamente tutti i suoni. Se inserisco il comando

cat /proc/asound/card0/codec#* | grep Codec**

il risultato è questo:

Codec: IDT 92HD88B3    
Codec: LSI ID 1040
Codec: Intel Cantiga HDMI

Non so se possa servire, ma io lo posto lo stesso :)
Come faccio a risolvere questo problema?

chiesto 02 Set '13, 01:33

Schneizel's gravatar image

Schneizel
10112

modificato 02 Set '13, 07:55

enzotib's gravatar image

enzotib ♦♦
14.0k112186

Ti suggerisco se non risolvi qui, un altro sentiero. Segui questa guida per il sound troubleshooting https://help.ubuntu.com/community/SoundTroubleshootingProcedure al passo 3 e' previsto l'invio di una domanda a https://answers.launchpad.net/ubuntu/ Invia la domanda li' e se risolvi dai cenno su questa lista

Ciao

(06 Set '13, 00:03) marcobra marcobra's gravatar image

da terminale: alsamixer e, con le freccettine, alzi tutti i valori a 100. Altro workaround è:

sudo gedit /etc/modprobe.d/alsa-base.conf

aggiungi al file la seguente riga

options snd-hda-intel model=generic

salva, chiudi e riavvia. Oppure

sudo apt-get remove --purge alsa-base
sudo apt-get remove --purge pulseaudio
sudo apt-get install alsa-base
sudo apt-get install pulseaudio
sudo alsa force-reload
sudo apt-get purge pulseaudio gstreamer0.10-pulseaudio
sudo apt-get install pulseaudio gstreamer0.10-pulseaudio indicator-sound

Riavviare il p.c.

coll. permanente

ha risposto 02 Set '13, 09:15

Beppe's gravatar image

Beppe
68718

grazie 1000 per la risposta e la disponibilità ma ho provato le tue soluzioni e niente... ho notato una cosa : su alsamixer nella barra speaker è impostato su muto qnd clicco m va a 00 ed è normale perchè l'audio dovrebbe essere attivo però quando riavvio il pc alsamixer si resetta e torna su mm in giro su internet ho trovato degli articoli che parlavano di un bug riguardante hp620 però essendo in inglese non ci ho capito molto qualcuno potrebbe dirmi come fare per aggirare questo bug?

(02 Set '13, 10:28) Schneizel Schneizel's gravatar image

@Schneizel : non usare le risposte per qualcosa di diverso da una proposta di soluzione.

(02 Set '13, 10:34) enzotib ♦♦ enzotib's gravatar image

@Beppe : ho trasformato in risposta, se non hai obiezioni

(02 Set '13, 10:35) enzotib ♦♦ enzotib's gravatar image

scusami enzo ma sono nuovo :)

(02 Set '13, 11:53) Schneizel Schneizel's gravatar image

aplay -l postami solo le prime 5 righe che ti restituisce il terminale

(02 Set '13, 12:21) Beppe Beppe's gravatar image

per non sbagliare ho incollato tutto

**** Lista di PLAYBACK dispositivi hardware ****
scheda 0: Intel [HDA Intel], dispositivo 0: STAC92xx Analog [STAC92xx Analog]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
scheda 0: Intel [HDA Intel], dispositivo 3: HDMI 0 [HDMI 0]
  Sottoperiferiche: 1/1
  Sottoperiferica #0: subdevice #0
(02 Set '13, 14:07) Schneizel Schneizel's gravatar image

vai in /usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz. e cerca STAC92xx. Nella lista sottostante deve esserci il nome o la marca del tuo pc. Segnateli che potranno servire come opzioni sudo gedit /etc/modprobe.d/alsa-base.conf modifica la riga come segue: options snd-hda-intel model=hp-dv5 salvi esci, riavvi e provi. Altra opzione: options snd-hda-intel model=hp-m4 enable_msi=1 salva e riavvia Prova anche le opzioni che ti sei segnato (mi raccomando alsamixer, tutti i valori a 100) spero ti possa aiutare

(02 Set '13, 17:54) Beppe Beppe's gravatar image

scusami, dimenticavo sudo gedit /etc/modules e alla fine aggiungi snd-hda-intel ci sono anche queste opzioni, confrontale con ciò che vedi in /usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz. dell-m4-1 dell-m4-2 dell-m4-3 dell-m6 dell-m6-amic dell-m6-dmic dell-eq dell-s14

(02 Set '13, 18:06) Beppe Beppe's gravatar image

STAC92xx non c'è dentro il file alsa-configuration.txt

(02 Set '13, 18:08) Schneizel Schneizel's gravatar image

...peccato!!...(pensavo fosse la volta buona!)...ho trovato questa guida http://forum.ubuntu-it.org/viewtopic.php?t=447352 provala, a sto punto ormai, e se non risolvi vale la pena di cambiare distro, un desktop Mate forse...ciao!

(02 Set '13, 18:36) Beppe Beppe's gravatar image

grazie mille lo stesso beppe :)

(02 Set '13, 18:54) Schneizel Schneizel's gravatar image

Da terminale dai

sudo gedit /etc/modprobe.d/alsa-base.conf

Aggiungi

options snd-hda-intel model=3stack-dig

Salva,chiudi,riavvia

coll. permanente

ha risposto 05 Set '13, 00:28

Webber's gravatar image

Webber
3.0k1536

modificato 05 Set '13, 00:52

grazie webber per aver risposto ho fatto come dici ma dopo il riavvio non è successo niente

(05 Set '13, 21:32) Schneizel Schneizel's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×202
×23

domanda posta: 02 Set '13, 01:33

domanda visualizzata: 1,638 volte

ultimo aggiornamento: 06 Set '13, 00:03

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.