Ciao a tutti.
Ho creato un nuovo utente "normale" (non amministratore) senza password per mia figlia. Il PC ha due dischi e all'avvio con il nuovo utente non esegue il mount del disco secondario.
Ho provato dal mio account (amministratore) ad abilitare tutti i file, ma, non è efficace.
Vorrei che eseguisse con entrambi gli utenti il mount del disco per poter poi limitare l'accesso ad alcune cartelle

Grazie mille in anticipo

chiesto 01 Ott '15, 00:11

ealbamb's gravatar image

ealbamb
30114

modificato 01 Ott '15, 06:11

enzotib's gravatar image

enzotib ♦♦
14.0k112186

1

Con

all'avvio con il nuovo utente non esegue il mount del disco secondario."

intendi che il disco secondario dovrebbe essere montato automaticamente tramite modifica di fstab?
Se sì, la soluzione proposta da enzotib non è la risposta, ma ci servirebbero più informazioni sul tipo di partizione (ext3, ext4, btrfs, ecc) e almeno il contenuto del file /etc/fstab.

(01 Ott '15, 08:24) dadexix86 ♦♦ dadexix86's gravatar image

Puoi risolvere creando una configurazione Polkit apposita.
Crea un file con

sudo gedit /etc/polkit-1/localauthority/50-mount.pkla

ed al suo interno inserisci le seguenti righe:

[Mount Permission]
Identity=unix-user:pippo
Action=org.freedesktop.udisks2.filesystem-mount-system
ResultActive=yes

dove al posto di "pippo" metti il nome dell'utente non amministratore che deve poter montare la partizione, poi ovviamente salva e chiudi. La nuova configurazione dovrebbe immediatamente essere attiva.

Se non funzionasse potrebbe essere la riga "action" sbagliata. Per essere sicuro del valore, quando viene chiesta la password clicca su "dettagli" e ti verrà mostrata l'azione che si sta eseguendo.

coll. permanente

ha risposto 01 Ott '15, 06:10

enzotib's gravatar image

enzotib ♦♦
14.0k112186

Grazie enzotib grazie dadexix86

In effetti era più banale di quello che credevo: non c'era in fstab!! .. non so perchè con l'utenza admin risultava montato (lo capirò) ma non c'era ..

quindi ho studiato un po', ho creato il suo mountpoint e l'ho aggiunto e ora è raggiungibile

di seguito il mio attuale fstab

> # <file system> <mount point>   <type>  <options>       <dump>  <pass>
> # / was on /dev/sda6 during installation
> UUID=87b511bb-0c80-46aa-b66b-fd5fd2bb989e / ext4  errors=remount-ro    0       1
> # swap was on /dev/sda5 during installation
> UUID=53ffec48-e9df-405d-b472-d937f0c8b944 none  swap    sw  0       0
> UUID=0ACE13CC5A936B99 /media/PCClaudia320GB ntfs user,defaults 0       0
> /dev/fd0        /media/floppy0  auto rw,user,noauto,exec,utf8 0       0

Grazie ancora per la vostra disponibilità

coll. permanente

ha risposto 03 Ott '15, 00:25

ealbamb's gravatar image

ealbamb
30114

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×436
×51
×37

domanda posta: 01 Ott '15, 00:11

domanda visualizzata: 1,695 volte

ultimo aggiornamento: 03 Ott '15, 00:25

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.