Salve a tutti, e scusate se non mi sono già presentato nell'apposita sezione, sono nuovo di ubuntu, ma già follemente innamorato. dopo il mio felice approccio con la 32-bit ho deciso di mettere la 64, visto che tanto, dovevo fare un format. ora, dopo aver letto TUTTE LE GUIDE che mi sono capitate sotto mano, non riesco ancora a risolvere il mio problema: steam non parte. mancano delle librerie che da terminale non mi fa installare. non riesco a venirne a capo. aiutatemi.. accetto anche chi vuole provare a cimentarsi nel capire la fonte del problema, non ho problemi a sparare comandi da terminale a profusione.. inoltre ho scoperto di avere praticamente lo stesso problema con mezzo software center, a partire da playonlinux e così via, sembra sia tutto danneggiato, e ho fatto l'installazione pulita prima di digitare sudo apt-get install steam (senza successo, nemmeno lo trovata)

chiesto 05 Nov '15, 23:15

SudoIsNotACrime's gravatar image

SudoIsNotACrime
44114

modificato 05 Nov '15, 23:51

Mi sembra che steam vada acquistato, ovvero, chiedono le proprie credenziali. Credo che non sia possibile installarlo con il comando di installazione da terminale, se non hai ancore provato, guarda se ti riesce dal software center.

(06 Nov '15, 06:55) enzoge enzoge's gravatar image

mancano delle librerie che da terminale non mi fa installare. Esattamente quali sono queste librerie? E quale errore ricevi quando provi ad installarle?

Inoltre, quali guide hai seguito esattamente? (seguirne troppe spesso fa solo incasinare il sistema...)

In teoria l'unica guida necessaria è quella ufficiale dell'help di Ubuntu.

(06 Nov '15, 09:45) dadexix86 ♦♦ dadexix86's gravatar image

allora, innanzitutto grazie per l'aiuto, ora do comando da terminale e posto il sudo apt-get install visto che ho rimosso steam con synaptic; per quanto riguarda ilgallinetta, sulla 32-bit basta "sudo apt-get install steam" senza nulla, sulla 64 ti chiede di acquistare steam-launcher, che rimane comunque gratuito, ma da lo stesso problema quando gli mancano le librerie

(06 Nov '15, 15:19) SudoIsNotACrime SudoIsNotACrime's gravatar image
-1
gesoo@Gesoo-Ubuntu:~$ sudo apt-get install steam
[sudo] password for gesoo: 
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 steam:i386 : Dipende: libgl1-mesa-glx:i386
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati

ecco cosa mi da con sudo apt-get, volendo ho il file.deb già scaricato direttamente da casa Valve

(06 Nov '15, 15:21) SudoIsNotACrime SudoIsNotACrime's gravatar image

@sudoIsNotACrime a meno di rispondere alla (tua) domanda principale usa i commenti e non le risposte, grazie. Per i codici lunghi, inoltre, conviene utilizzare pastebin.

Per installare software a 32bit su una distro a 64bit è necessario che il multiarch sia abilitato.

Se hai aggiornato alla 14.04 è possibile che non sia abilitato. Postami l'output di

dpkg --print-foreign-architectures
(06 Nov '15, 15:25) dadexix86 ♦♦ dadexix86's gravatar image

non so usare il pastebin, e in commento non me lo faceva incollare (vergogna per essere un nabbone) ahahahahahaha provo subito e ti dico

(06 Nov '15, 15:30) SudoIsNotACrime SudoIsNotACrime's gravatar image

gesoo@Gesoo-Ubuntu:~$ sudo dpkg --print-foreign-architectures i386 ecco a te (ho abilitato io l'architettura i386 da riga di comando ieri smanettando P.s. come uso pastebin? >_>

(06 Nov '15, 15:31) SudoIsNotACrime SudoIsNotACrime's gravatar image

Come per quasi tutto, c'è un'ottima guida per pastebin.

Posta su pastebin (e metti qui il link) l'output di

sudo apt-get update && sudo apt-get install -s steam
(06 Nov '15, 15:33) dadexix86 ♦♦ dadexix86's gravatar image

http://paste.ubuntu.com/13124519/ premetto inoltre che ho dovuto cambiare appena installato l'OS il server da "in italia" a "principale" sennò ottenevo problemi col sudo apt-get update. grazie ancora.

(06 Nov '15, 15:39) SudoIsNotACrime SudoIsNotACrime's gravatar image

Dai

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys F24AEA9FB05498B7

e poi riprova (posta di nuovo l'output su pastebin ecc)

(06 Nov '15, 15:46) dadexix86 ♦♦ dadexix86's gravatar image
(06 Nov '15, 15:49) SudoIsNotACrime SudoIsNotACrime's gravatar image

Mi interessava l'output del comando di prima (poi riprova) :)

(06 Nov '15, 15:59) dadexix86 ♦♦ dadexix86's gravatar image

http://paste.ubuntu.com/13124795/ ecco a te, non avevo capito ahahah

(06 Nov '15, 16:12) SudoIsNotACrime SudoIsNotACrime's gravatar image

Postami (sempre su pastebin)

sudo apt-get install -s libgl1-mesa-glx:i386
(06 Nov '15, 16:15) dadexix86 ♦♦ dadexix86's gravatar image

http://paste.ubuntu.com/13124851/ ed eccoci al punto cruciale da cui non vengo a capo.. ahahah

(06 Nov '15, 16:16) SudoIsNotACrime SudoIsNotACrime's gravatar image

Postami

apt-cache policy steam
apt-cache depends steam
(06 Nov '15, 16:18) dadexix86 ♦♦ dadexix86's gravatar image

http://paste.ubuntu.com/13124888/ sono tutti e due qui distanziati tra loro :D grazie ancora!

(06 Nov '15, 16:21) SudoIsNotACrime SudoIsNotACrime's gravatar image

Allora... Il problema secondo me è che hai abilitato i repository proposed, che sono per software ancora in testing (fase di Pre-Release) e spesso creano problemi come questo.

Per essere certi che il problema sia quello, postami

apt-cache policy libgl1-mesa-glx:i386 libudev1:i386 libudev0:i386 libglapi-mesa:i386 libgl1-mesa-dri:i386 libcheese-gtk23 libcheese7

Se così fosse secondo me a questo punto la cosa migliore è che reinstalli, evitando sia i proposed che il repository di steam.

(06 Nov '15, 16:34) dadexix86 ♦♦ dadexix86's gravatar image

http://paste.ubuntu.com/13125015/ ecco qua, io ho il cd sotto mano col SO, stasera saresti disponibile per aiutarmi un attimo ed evitare questi problemi? sul 32-bit andavo liscio come l'olio..

(06 Nov '15, 16:37) SudoIsNotACrime SudoIsNotACrime's gravatar image

Nessuno di questi viene dai proposed, quindi direi che il problema non sta lì. Interessante!

È chiaro che sul 32 non dà problemi, essendo un'applicazione a 32bit (i386) e non sviluppata per il 64bit (scelte aziendali di Valve) :)

(06 Nov '15, 16:45) dadexix86 ♦♦ dadexix86's gravatar image

vorrei aggiungere che l'app è per 32 bit, e i giochi contenuti per linux girano a 64 perchè Valve ritiene la 32 obsoleta.. DEI GENI ahahaha (esempio Dota2 Left 4 Dead 2 e così via. tutti quelli di casa valve girano a 64 e col 32 non potevo far nulla tranne usare la chat allegra e felice :D)

(06 Nov '15, 16:46) SudoIsNotACrime SudoIsNotACrime's gravatar image

Fossi in te comunque farei una prova senza aver abilitato i proposed...

(06 Nov '15, 16:52) dadexix86 ♦♦ dadexix86's gravatar image

quindi mi consigli di reinstallare il sistema? i proposed li disabilito nel processo di installazione? anche perchè così ho un pc inutilizzabile.. playonlinux no, steam no, mezzo ubuntu software center no.. e che ca...

(06 Nov '15, 20:48) SudoIsNotACrime SudoIsNotACrime's gravatar image

posso farti perdere qualche minuto dopo che ho reinstallato il sistema per settarlo a dovere e attivare il multiarchitecture?

(06 Nov '15, 20:49) SudoIsNotACrime SudoIsNotACrime's gravatar image

Di default sono disabilitati. A meno che tu non stia installando una derivata non ufficiale o una versione modificata, se non li abiliti tu essi restano disabilitati.

(06 Nov '15, 20:50) dadexix86 ♦♦ dadexix86's gravatar image

Dalla 12.04 in poi il multiarch è già abilitato di default, ergo non devi toccare nulla.

L'unica cosa che devi fare è dare

sudo apt-get install steam

senza fare null'altro prima (non aggiungere repo, non modificare impostazioni, nulla).

(06 Nov '15, 20:52) dadexix86 ♦♦ dadexix86's gravatar image

non penso di averli attivati.. comunque provo!

(06 Nov '15, 20:54) SudoIsNotACrime SudoIsNotACrime's gravatar image

Fai una installazione pulita mi raccomando, così che non vengano mantenute impostazioni precedenti! :)

(06 Nov '15, 21:22) dadexix86 ♦♦ dadexix86's gravatar image

ok eccomi, formattato e tutto. nel processo di installazione ho tolto le spunte da "scaricare aggiornamenti durante l'installazione" e "installare software di terze parti", inoltre ho partizionato personalmente l'hdd (4 gb /boot in ext4, 4 gb swap, 62gb / ext4, 50gb /home ext4 tutti col journaling, l'hdd è momentaneo) ora.. ho l'icona degli aggioramenti che mi stressa.. aggiorno o lancio subito sudo apt-get? non ho toccato NULLA

(06 Nov '15, 21:28) SudoIsNotACrime SudoIsNotACrime's gravatar image

Dai subito

sudo apt-get update && sudo apt-get install steam

e posta l'output ;)

(06 Nov '15, 21:43) dadexix86 ♦♦ dadexix86's gravatar image

intanto ci tengo a precisare che non ho nemmeno i pacchetti flash :D ora do il comando!

(06 Nov '15, 21:47) SudoIsNotACrime SudoIsNotACrime's gravatar image

Io ora devo uscire, fammi sapere come va!

(06 Nov '15, 21:50) dadexix86 ♦♦ dadexix86's gravatar image

http://paste.ubuntu.com/13129620/ ecco qua.. comunque dopo avrei domande anche su come aggiornare il sistema (via grafica installando quei 200 mb o via apt-get upgrade.. se flash basta il plugin o devo proprio scaricarlo.. etc..

(06 Nov '15, 21:51) SudoIsNotACrime SudoIsNotACrime's gravatar image

ovviamente il plugin con comando da terminale come sempre

(06 Nov '15, 21:52) SudoIsNotACrime SudoIsNotACrime's gravatar image

sono tornato ora, ho avviato steam, che ora sembra andare.. ora rimane solo da testare le altre apps.. ma.. quegli aggiornamenti li installo? o evito?

(07 Nov '15, 01:08) SudoIsNotACrime SudoIsNotACrime's gravatar image

Ottimo, quindi problema risolto! :)

Installa sempre gli aggiornamenti, ma evita i repo proposed se non ti senti pronto per testare ;)

(07 Nov '15, 01:47) dadexix86 ♦♦ dadexix86's gravatar image

Il problema erano i repository proposed.

Una reinstallazione del sistema senza abilitarli ha risolto il problema.

coll. permanente

ha risposto 07 Nov '15, 01:48

dadexix86's gravatar image

dadexix86 ♦♦
16.9k716161

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×20

domanda posta: 05 Nov '15, 23:15

domanda visualizzata: 867 volte

ultimo aggiornamento: 07 Nov '15, 01:48

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.