Ciao a tutte e tutti,

ho Ubuntu 14.04 LTS ed ho disinstallato Bitmask (VPN) e cercando di installare la nuova versione da terminale mi dà i seguenti errori:

W: Duplicate sources.list entry http://deb.bitmask.net/debian/ trusty/main amd64 Packages (/var/lib/apt/lists/deb.bitmask.net_debian_dists_trusty_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://deb.bitmask.net/debian/ trusty/main i386 Packages (/var/lib/apt/lists/deb.bitmask.net_debian_dists_trusty_main_binary-i386_Packages)
W: È consigliato eseguire "apt-get update" per correggere questi problemi
tommaso@Tommaso-PC:~$ sudo apt-get install bitmask leap-keyring
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.

Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 bitmask : Dipende: python-txzmq (>= 0.7.3) ma non sta per essere installato
           Dipende: soledad-client (>= 0.6.0) ma non sta per essere installato
           Dipende: leap-mail (>= 0.4.0) ma non sta per essere installato
           Dipende: python-logbook (>= 0.7.0-1) ma non sta per essere installato
           Dipende: python-leap-common (>= 0.4.0) ma non sta per essere installato
           Dipende: leap-keymanager ma non sta per essere installato
           Raccomanda: xul-ext-bitmask ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati."

Ecco la guida che ho seguito: https://help.riseup.net/it/vpn/how-to/linux

Nemmeno dall'USC me lo vede più, devo aver fatto del pasticcio con i PPA anche se ora me lo ha nuovamente aggiunto.

Grazie mille a tutti.
Tommaso

chiesto 07 Nov '15, 19:19

Tommi87's gravatar image

Tommi87
306111723

modificato 08 Nov '15, 10:25

enzotib's gravatar image

enzotib ♦♦
14.0k112186

1

Posta su pastebin l'output di

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d
(08 Nov '15, 10:41) dadexix86 ♦♦ dadexix86's gravatar image

grazie della risposta.

Il primo comando restituisce: http://pastebin.com/embed_js.php?i=88kRrps9

il secondo comando restituisce: http://pastebin.com/embed_js.php?i=zT0bpkpQ

Tom

(08 Nov '15, 16:51) Tommi87 Tommi87's gravatar image
1

Woah che lista di ppa esterni (la seconda)! È un mezzo miracolo che il sistema parta ancora!

Postami

cat /etc/apt/sources.list.d/bitmask.list
(08 Nov '15, 16:58) dadexix86 ♦♦ dadexix86's gravatar image

Il sistema parte e funge benone, ma alcuni pensavo di averli eliminati perchè li avevo rimossi da "software e aggiornamenti" (chiederò in separata sede delucidazioni).

deb http://deb.bitmask.net/debian trusty main

(08 Nov '15, 17:18) Tommi87 Tommi87's gravatar image
1

Se li hai solo de-selezionati non vengono rimossi i files, ma solo commentate le liste.

Per rimuovere completamente un repository devi anche manualmente rimuovere o downgradare il software che fornisce.
Oppure puoi usare add-apt-repository -r ppa:.../... che si preoccupa di fare tutto questo (se possibile).

Postami l'output completo di

sudo apt-get update
cat /etc/apt/sources.list.d/*
(08 Nov '15, 17:25) dadexix86 ♦♦ dadexix86's gravatar image
(08 Nov '15, 17:32) Tommi87 Tommi87's gravatar image

Il secondo comando non ti dà output?

(08 Nov '15, 18:07) dadexix86 ♦♦ dadexix86's gravatar image
(08 Nov '15, 18:11) Tommi87 Tommi87's gravatar image

Postami

apt-get install -s bitmask
(08 Nov '15, 18:16) dadexix86 ♦♦ dadexix86's gravatar image

ho dato il comando senza sudo:

http://pastebin.com/embed_js.php?i=jGpLcchA

(08 Nov '15, 18:19) Tommi87 Tommi87's gravatar image

Sì, come ti avevo detto :)
Sto cercando di capire quale sia effettivamente il pacchetto bloccato che non ti fa procedere e da dove proviene.

Dai

apt-get install -s python-txzmq soledad-client leap-mail python-logbook python-leap-common leap-keymanager
(08 Nov '15, 18:25) dadexix86 ♦♦ dadexix86's gravatar image
(08 Nov '15, 18:28) Tommi87 Tommi87's gravatar image
1

Metti sempre anche l'input che dai per favore :)

Abbiamo trovato il problema comunque. C'è un pacchetto (python-leap-common) che richiede una versione di una dipendenza (python-txzmq) più alta di quella che puoi installare.
Ora cerchiamo di capire da dove viene.

apt-cache policy python-leap-common python-txzmq
(08 Nov '15, 18:43) dadexix86 ♦♦ dadexix86's gravatar image

E già questo è un ottima notizia. Ecco: http://pastebin.com/embed_js.php?i=bdV8BX1f

PS: ora devo uscire, quindi cercherò di risponderti domani sera. Grazie molte :)

(08 Nov '15, 19:01) Tommi87 Tommi87's gravatar image
1

Manca un pezzo del comando sopra ;)

Comuqnue sembra un problema del loro repository. Dovresti provare a contattarli facendogli vedere gli output fin qui.

(08 Nov '15, 19:06) dadexix86 ♦♦ dadexix86's gravatar image

Ecco l'ultimo comando che mi avevi detto: http://pastebin.com/embed_js.php?i=1V78SR2t

Gli devo far vedere tutte le interrogazioni ai comandi che mi hai indicato? A loro gli avevo aperto un ticket dandogli solo i risultati che ho riportato alla mia domanda. Se desidere puoi mettere il tuo ultimo commento come risposta.

Ti ringrazio per la gentile disponibilità! :)

PS: per quanto riguarda, invece, alcuni dei ppa esterni che ho eliminato dovrei aver rimosso anche il relativo programma.

(09 Nov '15, 22:15) Tommi87 Tommi87's gravatar image
1

Sì, il problema è decisamente loro. Il pacchetto che usano per compilare come dipendenza è a una versione più recente di quella presente in Ubuntu 14.04.

Sulla 15.10 il tutto dovrebbe funzionare, ma non sulla 14.04...

(09 Nov '15, 22:32) dadexix86 ♦♦ dadexix86's gravatar image

Si infatti sul loro sito https://bitmask.net/en/install/linux hanno aggiornato alle nuove versioni di ubuntu. Alla fine ho messo il bundle e funziona, ma mi sarebbe piaciuto avere l'installazione come prima (che improvvisamente aveva smesso di funzionare).

Da lo stesso errore iniziale anche provando anche con: Packages Wily Werewolf (15.10) To install

sudo -s add-apt-repository "deb http://deb.bitmask.net/debian wily main" wget -O- https://dl.bitmask.net/apt.key | apt-key add - apt-get update apt-get install bitmask leap-keyring

(09 Nov '15, 22:39) Tommi87 Tommi87's gravatar image

Quel comando ovviamente devi darlo sulla 15.10, è chiaro che un comando per la 15.10 non funzioni sulla 14.04 :)

(10 Nov '15, 11:46) dadexix86 ♦♦ dadexix86's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×434
×165
×32
×14
×1

domanda posta: 07 Nov '15, 19:19

domanda visualizzata: 581 volte

ultimo aggiornamento: 10 Nov '15, 11:46

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.