Buongiorno a tutti il mio problema è il seguente: Non appena mi collego in remoto alla macchina linux (ubuntu 14.04.3 LTS), indifferentemente dal O.S. client, il server su linux su cui ho avviato il vnc-server (ho testato anche con x11vnc ed altri ma il problema persiste) mi presenta la seguente finestra: http://farm3.staticflickr.com/2810/8809743838_dc873911f9.jpg Cio risulta non solo fastidioso poichè richiede la presenza di una persona fisica sul server affinchè dia il grant alla connessione, ma totalmente inusabile un servizio di analisi in telegestione (Remote desktop). Confidando in una rapida soluzione ringrazio chiunque mi sappia aiutare. PS.Una volta premuto sul server allow vnc funziona quindi il protocollo è istallato correttamente.

chiesto 08 Nov '15, 12:05

Andrea%20Massaro's gravatar image

Andrea Massaro
3014


Ciao @Andrea Massaro,

Il tuo problema è dovuto ad un'errata configurazione di Vino, il server VNC di default di Ubuntu.

Per disattivare la conferma di accesso è sufficiente che tu apra un terminale sulla macchina remota ed invochi il comando

vino-preferences

Ti si aprirà una schermata, dovrai disattivare la voce Confermare ogni accesso alla macchina

Vedi l'immagine allegata. Screenshot

coll. permanente

ha risposto 08 Nov '15, 15:43

corti-nico's gravatar image

corti-nico
891319

Non funziona ho già provato... La tua procedura permette solo di non farmi inserire la password durante la richiesta di connessione...ho tentato nel dubbio la tua procedura ma era come dicevo. Il mio problema invece consiste nel non fare aprire il popup di allow/grant da parte del server nella mia connessione...in pratica voglio collegarmi al mio server senza che lui mi chieda tutte le volte di esserci davanti e consentire la connessione. Spero tu o altri sappiate come aiutarmi grazie comunque per il disturbo.

(08 Nov '15, 20:06) Andrea Massaro Andrea%20Massaro's gravatar image

@andrea-massaro: non usare le risposte, usa i commenti.

(08 Nov '15, 20:31) enzotib ♦♦ enzotib's gravatar image

ultravnc su client mentre su server ho impostato tutto con vino, e ho testato sia con vino-server che con x11vnc ma su distro precendenti alla 13 non avevo alcuna richiesta da parte del server di grant della connessione...

(09 Nov '15, 01:30) Andrea Massaro Andrea%20Massaro's gravatar image

Testato con vino come server e vinagre o remmina come client. Funziona come previsto, la voce Confermare ogni accesso alla macchina consente di abilitare/disabilitare il messaggio di autorizzazione accesso alla macchina.

(09 Nov '15, 14:14) corti-nico corti-nico's gravatar image
1

Sisi avevo capito quale è il tuo problema: Sul server ti appare il messaggio di conferma accesso alla macchina.

Per questo motivo devi aprire i setting di vino sul server e non sul client (sul client non hanno alcun effetto).

Se togli la spunta da Confermare ogni accesso alla macchina (sul server) vedrai che quel messaggio non ti appare più. Se lasci la spunta, dovrei confermare (sul server) ogni client che si connette.

EDIT Versione linux server: Ubuntu 14.04.3 LTS Versione linux client: Ubuntu 15.04

(09 Nov '15, 16:55) corti-nico corti-nico's gravatar image

Perfetto come consigliato funziona, tuttavia restano due problemi 1) ora chiunque può accedere senza controllo alcuno?!?!? 2) Chiedo venia ma non mi disabilitava in alcuno modo la voce in questione...Ora risolto questo punto. Se qualcuno ha idee grazie a tutti.

(09 Nov '15, 21:21) Andrea Massaro Andrea%20Massaro's gravatar image
1

Per gestire l'accesso puoi utilizzare la password (la voce sottostante). Attivi la voce Richiedere all'utente di inserire questa password: (sul server ovviamente), e gli utenti potranno connettersi solo se conoscono la password.

La password è unica. Per avere sistemi di autenticazione più soffisticati devi cambiare server, vino non mi pare offra personalizzazioni ulteriori.

(09 Nov '15, 21:23) corti-nico corti-nico's gravatar image

Ho risolto anche il primo punto. Per chiunque avesse i sequenti problemi... Nella immagine qui: http://i63.tinypic.com/2ela8b7.png deselezionare in sicurezza la prima voce ed abilitare la seconda. L'effetto sarà un filtro sul server tramite pass tuttavia nessuna conferma su server.Grazie a tutti in special modo a @corti-nico

(09 Nov '15, 21:24) Andrea Massaro Andrea%20Massaro's gravatar image

Prego. Se la risposta che ti ho dato ha risolto il tuo problema ti ricordo di accettarla, in questo modo Chiedi considera il tuo problema come risolto.

(09 Nov '15, 21:27) corti-nico corti-nico's gravatar image

Massaro ciao sono conti ho dato il comando che mi hai mandato è passato però non ha risolto il problema in più non riesco più ad accedere con il comando sudo mi da accesso negato come faccio a tornare indietro???

(11 Nov '15, 09:55) carloconti carloconti's gravatar image

Ciao @carloconti, le vostre discussioni personali vi pregherei di non farle nei commenti delle risposte di chiedi. Se hai un problema puoi aprire una nuova domanda

(11 Nov '15, 10:26) corti-nico corti-nico's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,598

domanda posta: 08 Nov '15, 12:05

domanda visualizzata: 628 volte

ultimo aggiornamento: 11 Nov '15, 10:26

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.