Quando clicco "Install" ho questo messaggio:

Package dependencies cannot be resolved

This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

The following packages have unmet dependencies:

freecad: Depends: libboost-filesystem1.40.0 (>= 1.40.0-1) but it is not going to be installed
         Depends: libboost-program-options1.40.0 (>= 1.40.0-1) but it is not going to be installed
         Depends: libboost-regex1.40.0 (>= 1.40.0-1) but it is not going to be installed
         Depends: libboost-signals1.40.0 (>= 1.40.0-1) but it is not going to be installed
         Depends: libboost-system1.40.0 (>= 1.40.0-1) but it is not going to be installed
         Depends: libboost-thread1.40.0 (>= 1.40.0-1) but it is not going to be installed
         Depends: libc6 (>= 2.4) but 2.13-0ubuntu13.2 is to be installed
         Depends: libgcc1 (>= 1:4.1.1) but 1:4.5.2-8ubuntu4 is to be installed
         Depends: libgfortran3 (>= 4.3) but 4.5.2-8ubuntu4 is to be installed
         Depends: libgl1-mesa-glx (>= 7.7.1-1) but 7.10.2-0ubuntu2.1 is to be installed
         Depends: libice6 (>= 1:1.0.0) but 2:1.0.7-1ubuntu1 is to be installed
         Depends: libopencascade-ocaf-6.3.0 but it is not going to be installed
         Depends: libopencascade-ocaf-lite-6.3.0 but it is not going to be installed
         Depends: libopencascade-visualization-6.3.0 but it is not going to be installed
         Depends: libpython2.6 (>= 2.6) but 2.6.6-6ubuntu7 is to be installed
         Depends: libqt4-network (>= 4:4.5.3) but 4:4.7.2-0ubuntu6.4 is to be installed
         Depends: libqt4-opengl (>= 4:4.5.3) but 4:4.7.2-0ubuntu6.4 is to be installed
         Depends: libqt4-svg (>= 4:4.5.3) but 4:4.7.2-0ubuntu6.4 is to be installed
         Depends: libqt4-webkit (>= 4:4.5.3) but it is not going to be installed
         Depends: libqt4-xml (>= 4:4.5.3) but 4:4.7.2-0ubuntu6.4 is to be installed
         Depends: libqtcore4 (>= 4:4.6.1) but 4:4.7.2-0ubuntu6.4 is to be installed
         Depends: libqtgui4 (>= 4:4.6.1) but 4:4.7.2-0ubuntu6.4 is to be installed
         Depends: libsoqt4-20 (>= 1.4.2~svn20090224) but 1.4.2~svn20090224-3 is to be installed
         Depends: libstdc++6 (>= 4.4.0) but 4.5.2-8ubuntu4 is to be installed
         Depends: zlib1g (>= 1:1.1.4) but 1:1.2.3.4.dfsg-3ubuntu3 is to be installed
         Depends: gconf2 (>= 2.10.1-2) but 2.32.2-0ubuntu2 is to be installed

Contenuto di /etc/apt/sources.list

# deb cdrom:[Ubuntu 11.04 _Natty Narwhal_ - Release i386 (20110427.1)]/ natty main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://archive.ubuntu.com/ubuntu natty main restricted
deb-src http://archive.ubuntu.com/ubuntu natty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu natty-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu natty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu natty universe
deb-src http://archive.ubuntu.com/ubuntu natty universe
deb http://archive.ubuntu.com/ubuntu natty-updates universe
deb-src http://archive.ubuntu.com/ubuntu natty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://archive.ubuntu.com/ubuntu natty multiverse
deb-src http://archive.ubuntu.com/ubuntu natty multiverse
deb http://archive.ubuntu.com/ubuntu natty-updates multiverse
deb-src http://archive.ubuntu.com/ubuntu natty-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://it.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse
# deb-src http://it.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu natty-security main restricted
deb-src http://archive.ubuntu.com/ubuntu natty-security main restricted
deb http://archive.ubuntu.com/ubuntu natty-security universe
deb-src http://archive.ubuntu.com/ubuntu natty-security universe
deb http://archive.ubuntu.com/ubuntu natty-security multiverse
deb-src http://archive.ubuntu.com/ubuntu natty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu natty partner
deb-src http://archive.canonical.com/ubuntu natty partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu natty main
deb-src http://extras.ubuntu.com/ubuntu natty main
deb http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu lucid main
deb-src http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu lucid main

chiesto 08 Set '13, 22:17

mmatt477's gravatar image

mmatt477
20113

modificato 09 Set '13, 15:37

enzotib's gravatar image

enzotib ♦♦
14.0k112186

Puoi aggiungere alla domanda gli output dei seguenti comandi?
1) lsb_release -ds 2) cat /etc/apt/sources.list

(08 Set '13, 22:38) enzotib ♦♦ enzotib's gravatar image

1)Ubuntu 11.04 2) bash: cat/etc/apt/sources.list: No such file or directory

(09 Set '13, 13:52) mmatt477 mmatt477's gravatar image

La 11.04 è una versione vecchia di 2 anni e mezzo e non più supportata. Inoltre il secondo comanda lo hai sbagliato, in quanto dopo "cat" c'era uno spazio.

(09 Set '13, 14:01) enzotib ♦♦ enzotib's gravatar image

Certo che ce ne vuole d'impegno per non ascoltare il consiglio "aggiungi alla domanda" (vedi il mio primo commento) e invece distribuire a pezzi l'output del comando su n-mila commenti!

(09 Set '13, 15:33) enzotib ♦♦ enzotib's gravatar image

Ora c'è nella domanda.Lo so che la versione 11.04 è vecchia, ma uso ubuntu da pochi giorni e non l'ho ancora aggiornato alla successiva

(09 Set '13, 15:40) mmatt477 mmatt477's gravatar image

La risposta è che, ora come ora, non puoi installare proprio niente, a meno che non cambi il server dei tuoi repository. Questo è dovuto al fatto che la release di Ubuntu che stai utilizzando non è più supportata.

C'è una guida da seguire per fare questa modifica, ed è la seguente: Repository :: SourcesList :: EOL.

coll. permanente

ha risposto 09 Set '13, 15:37

enzotib's gravatar image

enzotib ♦♦
14.0k112186

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×115
×2

domanda posta: 08 Set '13, 22:17

domanda visualizzata: 2,136 volte

ultimo aggiornamento: 09 Set '13, 15:40

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.