Ciao, ho acquistato un Hp 255 e-1 6015 con sistema freedos. Dopo l'installazione di Ubuntu 14.04 LTS, ho riscontrato dei problemi nella connessione Wi-Fi. Il pc si connette ad alcune reti, ma aprendo il browser Firefox la ricerca è bloccata, oppure la pagina si carica in maniera eccessivamente lenta. Non sono un'esperta, un amico mi ha installato Ubuntu e dice che il problema sia a livello di Hardware. Vorrei sapere se potrebbe essere così, o se magari si tratta di un problema coi driver. Ah, la connessione via cavo funziona. Confido in una risposta ragazzi aiutatemi! :)

chiesto 30 Gen '16, 14:04

Giadaa's gravatar image

Giadaa
20112

Qual è marca e modello della scheda di rete?

Apri un terminale, dai

lspci
sudo lshw -C network

incolla l'output su pastebin e metti qui il link in un commento.

(30 Gen '16, 14:49) dadexix86 ♦♦ dadexix86's gravatar image

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 07) Subsystem: Hewlett-Packard Company Device 8137

Questo dovrebbe dirti qualcosa sulla scheda di rete, se non mi sbaglio

(30 Gen '16, 15:10) Giadaa Giadaa's gravatar image

Quella è la scheda Ethernet, quella del cavo. Quella wi-fi è invece RTL8723BE, per cui sembra che sulla 14.04 ci sia bisogno di compilare dei driver appositi.

Purtroppo con Realtek è sempre un terno al lotto capire cosa funziona e cosa no.

Il problema te lo fa con tutte le reti?

(30 Gen '16, 15:14) dadexix86 ♦♦ dadexix86's gravatar image

Grazie. Sì il problema è comune con qualsiasi rete, ne ho provate parecchie

(30 Gen '16, 19:57) Giadaa Giadaa's gravatar image

Prova a seguire la guida che ti ho linkato (se hai dubbi chiedi, prima di fare danni).

(31 Gen '16, 01:27) dadexix86 ♦♦ dadexix86's gravatar image

Difatti, ho seguito il link ed ora non ho più alcuna connessione di rete nel PC... non sono per nulla esperta, forse dovrei chiedere personalmente a qualcuno! Comunque non funziona proprio, a tratti ieri però si era connesso e funzionava anche Firefox... non capisco

(31 Gen '16, 11:43) Giadaa Giadaa's gravatar image

Hai ricevuto degli errori durante la compilazione? Se sì, quali?

(31 Gen '16, 11:51) dadexix86 ♦♦ dadexix86's gravatar image

No non mi sembra!

(31 Gen '16, 14:00) Giadaa Giadaa's gravatar image

"mi sembra" è un po' troppo generico per poterti aiutare.

Prova a rifare i passaggi di sopra e incolla su pastebin tutti gli input che dai e output che ricevi. Poi metti qui il link.

(31 Gen '16, 14:03) dadexix86 ♦♦ dadexix86's gravatar image

Sì scusami, hai ragione. Ecco qui. http://paste.ubuntu.com/14849183/

(01 Feb '16, 13:45) Giadaa Giadaa's gravatar image

Se vado a vedere sulle impostazioni, mi dice che i servizi di rete con sono compatibili con questa versione.

(01 Feb '16, 13:48) Giadaa Giadaa's gravatar image

Prova prima a toglierlo

sudo modprobe -r rtl8723be

e poi rimetterlo

sudo modprobe rtl8723be

Se non funziona prova con

echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

e poi a toglierlo

sudo modprobe -r rtl8723be

e rimetterlo

sudo modprobe rtl8723be

(Posta ovviamente il tutto su pastebin e metti il link :) )

(01 Feb '16, 13:49) dadexix86 ♦♦ dadexix86's gravatar image

Se ti dice che i servizi non son compatibili, è un problema diverso da quello che hai descritto finora! Purtroppo è un problema che si è presentato con gli ultimi aggiornamenti di NetworkManager su schede Realtek (come la tua).

Prova a seguire quanto spiegato in questa risposta

(01 Feb '16, 13:52) dadexix86 ♦♦ dadexix86's gravatar image

Intendi eseguire le azioni di questo pastebin?http://pastebin.com/m4b0BLUx Se si, come faccio se non ho alcuna possibilità di connessione?

(01 Feb '16, 14:23) Giadaa Giadaa's gravatar image

Ehm... se stai scrivendo qui ti stai connettendo da qualche parte :S

Scarica quei file con il dispositivo che stai usando e copiali sulla partizione di Ubuntu :)

(01 Feb '16, 14:27) dadexix86 ♦♦ dadexix86's gravatar image

sì, ho sbagliato a capire haha :) Comunque, scarico per amd64 giusto?

(01 Feb '16, 14:35) Giadaa Giadaa's gravatar image

Lì dipende se hai un sistema a 32 o 64 bit. Puoi guardare in "Dettagli" se ti dice 32 o 64 bit :)

(01 Feb '16, 14:38) dadexix86 ♦♦ dadexix86's gravatar image

Fatto. Dice che è già installata una versione più recente...

(01 Feb '16, 15:03) Giadaa Giadaa's gravatar image

Mh.. ti direi di disinstallare quella vecchia, ma senza sapere di preciso cosa si tirerebbe dietro mi sembra un po' azzardato. Riesci a scrivere l'elenco dei pacchetti che toglierebbe quando provi a disinstallare le vecchie versioni di quei pacchetti?

(01 Feb '16, 15:33) dadexix86 ♦♦ dadexix86's gravatar image

sì eccoli: crda, iw, network-manager, plainbox-provider-resource-generic, wpasupplicant, e i tre pacchetti libnl già installati

(01 Feb '16, 15:54) Giadaa Giadaa's gravatar image

Mh... Sinceramente non me la sento di dirti di continuare, sono pacchetti abbastanza fondamentali, se non sei esperto/a rischi di restare con schermo nero e nient'altro.

(01 Feb '16, 16:10) dadexix86 ♦♦ dadexix86's gravatar image

grazie mille, lascerò il pc nelle mani di un esperto! Gentilissimo comunque, grazie ancora e ti farò sapere se avrò risolto :)

(01 Feb '16, 16:15) Giadaa Giadaa's gravatar image

Io ho risolto con questa guida: http://www.istitutomajorana.it/forum2/Thread-RISOLTO-problemi-wifi-realtek-RTL8723BE-plus-14-04-live

Ho un Lenovo,che aveva un altro problema relativo al Kernel che col tuo HP non c'entra. Per la scheda invece il problema è simile. Qui la storia mia: http://chiedi.ubuntu-it.org/questions/37008/wi-fi-is-disabled-by-hardware-switch

coll. permanente

ha risposto 01 Feb '16, 23:27

essedia1960's gravatar image

essedia1960
7871117

modificato 02 Feb '16, 00:15

Se il Bluetooth è Realtek rtl8723au e non va, prova questo: http://chiedi.ubuntu-it.org/questions/43677/bluetooth-lenovo-g50-30-su-1404

(02 Feb '16, 00:20) essedia1960 essedia1960's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×434
×378
×243
×13

domanda posta: 30 Gen '16, 14:04

domanda visualizzata: 1,409 volte

ultimo aggiornamento: 02 Feb '16, 00:20

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.