Salve, quando cerco di catturare l'istantanea di un filmato col tasto "Stamp", mi appare una schermata blu (come potete vedere nella foto allegata). Lo stesso problema mi accade quando uso la webcam con Skype, il mio video appare di colore blu. E stessa identica cosa accade quando con recordmydesktop cerco di registrare ciò che si vede dalla webcam. Come posso risolvere il problema? La scheda video è una Intel Corporation 82852/82855 Integrated Graphics Device.

alt text

alt text

chiesto 02 Mar '16, 13:00

Anto's gravatar image

Anto
17951823

modificato 03 Mar '16, 13:13

Versione di Ubuntu? Versione di VLC? Hai repository esterni abilitati? Quali? Quale formato video utilizzi? Lancia VLC da terminale con alta verbosità

vlc --file-logging --logfile=VLCLOG --verbose=2

apri il video che ti dà problemi, prova a fare uno screenshot, chiudi VLC, metti su pastebin il contenuto del file VLCLOG e metti qui il link, così che possiamo investigare meglio il problema.

(02 Mar '16, 13:28) dadexix86 ♦♦ dadexix86's gravatar image

Ubuntu 14.04.4 LTS, VLC 2.1.6 Rincewind; per quanto riguarda i repository, non ho modificato nulla rispetto a quanto predefinito; per quanto riguarda il formato dei video, accade con qualsiasi formato. Per quanto riguarda l'ultima operazione, quando lancio da terminale il comando da te suggerito, si apre VLC con questi errori:

Lettura file non riuscita: VLC non è in grado di aprire il file "/home/anto/VLCLOG" (File o directory non esistente). L'ingresso non può essere aperto: VLC non è in grado di aprire il MRL 'file:///home/anto/VLCLOG'. Controlla il registro per i dettagli.

Cosa faccio?

(02 Mar '16, 14:16) Anto Anto's gravatar image

Errore mio, perdonami, ora dovrei aver corretto il comando sopra.

Se anziché Unity usi un altro DE che non preveda l'utilizzo di effetti grafici (magari prova da live Xubuntu o Lubuntu) hai lo stesso problema?

(02 Mar '16, 14:31) dadexix86 ♦♦ dadexix86's gravatar image

Cmq, ho provato a fare come dici, il file vlc-log è qui: http://www.4shared.com/office/dWAGbDA1ce/vlc-log.html

mentre lo screenshot è qui: http://www.4shared.com/photo/1gqRvoDkce/2016-03-02-142150_1024x768_scr.html

(02 Mar '16, 14:36) Anto Anto's gravatar image

Guarda provo da un cd live, e ti faccio sapere...

(02 Mar '16, 14:44) Anto Anto's gravatar image

Potresti mettere il log su pastebin come ti ho indicato prima, anziché costringere chi ti vuole aiutare a scaricare file a caso dalla rete?

(02 Mar '16, 14:45) dadexix86 ♦♦ dadexix86's gravatar image

L'avevo messo in un sito di archiviazione e condivisione files, cmq l'ho messo anche in pastebin, il link è questo: http://pastebin.com/C857sBRY Ho provato con il cd live di lubuntu 14.04, e lo screenshot questa volta viene salvato correttamente...

(02 Mar '16, 15:54) Anto Anto's gravatar image

Ottimo! Allora sappiamo che è un problema della configurazione del tuo computer e non è un bug/problema di Ubuntu (e quindi la soluzione sarà più rapida).

Se provi con un altro utente hai lo stesso problema? (così capiamo se è un problema globale del sistema o specifico del tuo utente)

(02 Mar '16, 16:17) dadexix86 ♦♦ dadexix86's gravatar image

Se provo con altro utente ho lo stesso problema. Una curiosità: se da VLC clicco su "cattura schermata" (invece di cliccare sul tasto "Stamp), lo screenshot è corretto. Poca roba, perché io voglio risolvere il problema con Skype e con Recordmydesktop...

(02 Mar '16, 16:28) Anto Anto's gravatar image

Cmq, per quanto riguarda il codice in pastebin, avevo sbagliato, il link corretto è questo: http://pastebin.com/csdP0uks

(02 Mar '16, 17:42) Anto Anto's gravatar image

Risposte? Cmq, da cd live lo screenshot viene salvato correttamente solo perché utilizzo gnome player; ho provato con VLC, e il problema persiste anche da cd live, quindi è un bug/problema di Ubuntu...

(03 Mar '16, 09:28) Anto Anto's gravatar image

VLC usa dei codec tutti suoi che non fanno parte di quelli di Ubuntu (che vengono invece usati da Gnome Player). Dato che con quelli di Ubuntu funziona, dovresti secondo me provare con l'ultima versione di VLC e, se hai ancora il problema, segnalarlo ai loro sviluppatori in modo che prima o poi lo risolvano.

Dato che il tuo problema è principalmente con Skype e RecordMyDesktop potresti mettere una schermata di questi programmi, anziché di VLC?
E anche lanciarli in modalità "verbose" e postare l'output che ricevi nei file di log.

(03 Mar '16, 12:05) dadexix86 ♦♦ dadexix86's gravatar image

Comunque personalmente non uso questi altri due programmi e quindi non li conosco bene, dovremo aspettare qualcuno che ne sappia più di me in merito per poterti aiutare, così evitiamo di farti fare danni irreparabili...

(03 Mar '16, 12:07) dadexix86 ♦♦ dadexix86's gravatar image

Ho messo le schermate di Skype e RecordMyDesktop. Riguardo al fatto di lanciarli in modalità verbose, non mi salva il file di log con Skype e RecordMyDesktop. Da terminale digito

skype --file-logging --logfile=VLCLOG --verbose=2 e gtk-recordmydesktop --file-logging --logfile=VLCLOG --verbose=2

Mi lancia i programmi ma non mi salva i file di log...

(03 Mar '16, 13:29) Anto Anto's gravatar image

Ah no, ogni programma ha un modo diverso per creare i log e abilitare la modalità verbosa! In particolare per Skype ti consiglio di chiedere a Microsoft come farlo (sempre sia possibile).

Per RecordMyDesktop io vedo solo il problema di VLC di cui sopra, non è tutta la finestra che diventa blu o sbaglio? Se usi un altro programma al posto di VLC (come Gnome Player, che non ti dà questo problema) hai lo stesso problema?

(03 Mar '16, 15:08) dadexix86 ♦♦ dadexix86's gravatar image

Guarda, ho chiesto info tecniche nella chat di ubuntu, mi hanno detto che i driver di ubuntu causano questo problema con questa scheda video (antiquata), e inoltre non è possibile installare i driver originali dal sito della Intel con Ubuntu. Quindi, da quello che ho capito, non si può far nulla...

(03 Mar '16, 18:09) Anto Anto's gravatar image

Perché non è possibile installare i driver Intel? Non supportano la tua scheda?

(04 Mar '16, 10:54) dadexix86 ♦♦ dadexix86's gravatar image

Non lo so, io ho provato ad installarli da qui https://downloadcenter.intel.com/download/6185/Intel-Extreme-Graphics-Linux-20030425-i386-TAR-GZ- ma non ci sono riuscito, ho provato ad installarlo secondo i canoni previsti per installare i files tar.gz, ma non è possibile farlo, o per lo meno io non ci sono riuscito...

(04 Mar '16, 16:15) Anto Anto's gravatar image

Quello è un file del 2003! Ha 13 anni :S I driver Intel per Linux si scaricano da qui https://01.org/linuxgraphics

(04 Mar '16, 16:19) dadexix86 ♦♦ dadexix86's gravatar image

Da lì ho installato intel-linux-graphics-installer_1.1.0-0intel1_i386.deb adatto per ubuntu 14.10, ho spento, ho riacceso, ma niente, i problemi persistono. A questo punto, alzo le mani...

(04 Mar '16, 17:30) Anto Anto's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×63

domanda posta: 02 Mar '16, 13:00

domanda visualizzata: 644 volte

ultimo aggiornamento: 04 Mar '16, 17:30

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.