installado da cd esce "impossibile installare grub su dev/sda. allego la partizione creata.

grazie per le evetuali risposte alt text

chiesto 07 Apr '16, 08:54

pepy6201's gravatar image

pepy6201
1913

Hai una partizione GPT, sicuro di non avere UEFI? Nel qual caso devi installare in modalità UEFI, non MBR.

(07 Apr '16, 09:22) dadexix86 ♦♦ dadexix86's gravatar image

Dal bios ho slezionato la modalità EFI e non LEGACY, inoltre non mi permette di disabilitare secure boot.

(07 Apr '16, 11:59) pepy6201 pepy6201's gravatar image

Hai seguito quindi la procedura apposita per UEFI come spiegato nella guida ufficiale all'installazione?

(07 Apr '16, 12:08) dadexix86 ♦♦ dadexix86's gravatar image

si, però il risultato è quello che ho postato. In questo momento sto riprovando

(07 Apr '16, 14:10) pepy6201 pepy6201's gravatar image

Mah, è strano che ti chieda dove installare GRUB, soprattutto perché prova ad installarlo in /dev/sda, mentre dovrebbe solo mettere dei file nella partizione efi.

Posta l'output di

[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
(07 Apr '16, 15:50) dadexix86 ♦♦ dadexix86's gravatar image

questo è ciò che riporta dopo l'errore impossibile installare grub su dev/sda alt text

(07 Apr '16, 21:22) pepy6201 pepy6201's gravatar image

Usa i commenti se non devi rispondere alla (tua) domanda principale grazie.

Devi creare la partizione di EFI, dato che vuoi installare con UEFI.

(07 Apr '16, 21:28) dadexix86 ♦♦ dadexix86's gravatar image

ma scusa la mia incompetenza la partizione efi non è già presente come boot di windows. devo crearne un'altra prima di /dev/sda7/...ext4, quindi ridimensionare sda5 ecreare una partizione efi da 600 MB?

(07 Apr '16, 21:35) pepy6201 pepy6201's gravatar image

ma se aggiungo un'altra partizione efi mi dovrebbe dare errore

(07 Apr '16, 21:37) pepy6201 pepy6201's gravatar image

Non c'è nessuna partizione EFI, deve chiamarsi "EFI boot partition" come scritto lì.

Sinceramente non sono un esperto di Windows, quindi non so se il fatto che non funzioni sia perché Windows non è realmente installato con UEFI oppure lo è ma in modo non standard...

(07 Apr '16, 21:50) dadexix86 ♦♦ dadexix86's gravatar image

E' possibile che la partizione riservata microsoft in sda3 non faccia installare il grub. alt text

ormai ho provato in tutti i modi, sono riuscito a disabilitare anche il secure boot. ma niente. all'installazione del grub ridà sempre lo stesso errore: alt text

(10 Apr '16, 16:28) pepy6201 pepy6201's gravatar image

Ubuntu na partizione 3 non dovrebbe proprio toccarla.

Sei riuscito a capire qual è la partizione EFI di Windows?

(10 Apr '16, 16:32) dadexix86 ♦♦ dadexix86's gravatar image
-1

scusa dadexix86, l'output del comando è UEFI

(10 Apr '16, 16:32) pepy6201 pepy6201's gravatar image

@pepy6201 a meno di rispondere alla (tua) domanda principale usa i commenti e non le risposte, grazie.

(10 Apr '16, 16:34) dadexix86 ♦♦ dadexix86's gravatar image

LA PARTIZIONE EFI DI WINDOWS È IN /dev/sda2

(10 Apr '16, 16:35) pepy6201 pepy6201's gravatar image

scusa dadexix86

(10 Apr '16, 16:36) pepy6201 pepy6201's gravatar image

Non c'è bisogno di urlare.

(10 Apr '16, 16:37) dadexix86 ♦♦ dadexix86's gravatar image

Mi sta venendo un dubbio. Apri un terminale e dai

uname -a
(10 Apr '16, 16:38) dadexix86 ♦♦ dadexix86's gravatar image

ubuntu-studio@ubuntu-studio:~$ uname -a Linux ubuntu-studio 4.2.0-16-lowlatency #19-Ubuntu SMP PREEMPT Thu Oct 8 16:19:23 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux ubuntu-studio@ubuntu-studio:~$ ^C ubuntu-studio@ubuntu-studio:~$

(10 Apr '16, 16:40) pepy6201 pepy6201's gravatar image

Ok, dubbio risolto.

L'hai rinominata come ti dice l'output sopra?

(10 Apr '16, 16:42) dadexix86 ♦♦ dadexix86's gravatar image

non ho rinominato niente, l'installazione l'ho fatta in automatico installando ububtu a fianco di windows

(10 Apr '16, 16:44) pepy6201 pepy6201's gravatar image

per info il pc è acer travelmate p 252MG

(10 Apr '16, 16:53) pepy6201 pepy6201's gravatar image

L'installare ti dice che vuole una partizione chiamata "EFI boot partition" (è l'immagine che hai postato sopra).
Devi chiamare la partizione di EFI così, altrimenti non può installarlo...

(10 Apr '16, 17:04) dadexix86 ♦♦ dadexix86's gravatar image

Quindi su /dev/sda2 formattata in fat 32 come punto di mount devo nominarlo con EFI boot partition, è corretto?

(10 Apr '16, 17:12) pepy6201 pepy6201's gravatar image

Sì, per installare Lubuntu a quanto pare sì.

NB: non so se Windows poi si lamenta di questo cambio, conviene che prima chiedi al supporto per Windows se puoi farlo e se c'è un modo di farlo con cui Windows non si arrabbia.

(10 Apr '16, 17:14) dadexix86 ♦♦ dadexix86's gravatar image

grazie proverò, anche perchè ubuntu effettivamente mi serve, con xp non avevo avuto nessun problema...

(10 Apr '16, 17:17) pepy6201 pepy6201's gravatar image

Eh, ma XP non usava EFI :)

L'alternativa è che pialli tutto e rimetti tutto con MBR.

(10 Apr '16, 17:28) dadexix86 ♦♦ dadexix86's gravatar image

però anche se poche volte ma uso anche windows, magari provo già a rinominare la partizione e vedo sosa succede, eventualmente potrei usare boot rapair o programmi del genere.

(10 Apr '16, 17:32) pepy6201 pepy6201's gravatar image

Fatti un backup nel caso qualcosa andasse storto! :)

(10 Apr '16, 21:13) dadexix86 ♦♦ dadexix86's gravatar image

Ho chieto ad ACER l'eventuale soluzione, poi ti faccio sapere

(10 Apr '16, 21:16) pepy6201 pepy6201's gravatar image

alt text

(13 Apr '16, 22:30) pepy6201 pepy6201's gravatar image

ciao. una nuova, durante l'installazione del grub, l'errore riportato è questo: grub install: errore: impossibile aprire "/boot/efi/EFI/ubuntu/shimx64.efi": File system in sola lettura. Qualcuno ha qualche info in merito? Come si puo mettere il file system anche in scrittura. grazie molto per l'aiuto.

(13 Apr '16, 22:38) pepy6201 pepy6201's gravatar image

ovviamente è sulla partizione 2 (partizione di sistema EFI. la prima è di riptistino di windows

(13 Apr '16, 22:51) pepy6201 pepy6201's gravatar image

A meno di rispondere alla (tua) domanda principale per favore usa i commenti e non le risposte.

Metti per favore una nuova schermata di Gparted, perché se non può scrivere sulla partizione o c'è un problema con i permessi (ma essendo FAT non dovrebbero essercene) o c'è qualche problema con la partizione stessa (per cui devi farci un check disk da Windows)

(14 Apr '16, 09:38) dadexix86 ♦♦ dadexix86's gravatar image

scusa dadexix86 ma non mi fa inserire il jpeg. mi dice che il caricamento di immagini è limitato agli utenti con reputazione >60

(14 Apr '16, 21:46) pepy6201 pepy6201's gravatar image

Usa imgur e poi metti qui il link.

(19 Apr '16, 11:06) dadexix86 ♦♦ dadexix86's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×24

domanda posta: 07 Apr '16, 08:54

domanda visualizzata: 437 volte

ultimo aggiornamento: 19 Apr '16, 11:06

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.