Ciao a tutti, ho appena installato Ubuntu 13.04 cancellando Windows 8. Ho aggiornato il kernel alla release 3.11(saucy) per far funzionare il wifi. Il notebook monta una nVidia 710m e Intel hd graphics 4000. Volevo sapere passo per passo (non sono troppo esperto :P) come posso installare i driver migliori per entrambi! Ho notato ad esempio che digitando lspci | grep VGA mi viene riconosciuto solo l'intel come mai?

chiesto 13 Set '13, 22:36

Redrum1777's gravatar image

Redrum1777
25334

Cancellare windows 8,forse non è stata una buona idea. Un dualboot con Ubuntu poteva essere la soluzione migliore anche in previsione di dover ancora configurare al meglio Ubuntu Facci anche sapere se il portatile come sembra utilizzava la tecnologia optimus per le schede video

(13 Set '13, 23:53) Webber Webber's gravatar image

Lo so, l'ho cancellato accidentalmente usando da Ubiquity "Elimina Ubuntu e reinstalla"! In ogni caso ho letto molte guide e sono riuscito ad avere i driver per l'Intel HD, ho installato Bumblebee secondo la guida e i relativi driver Nvidia, l'unico problema è che digitando il comando optirun firefox o qualsiasi altra cosa ottengo sempre:
[ERROR]Cannot access secondary GPU - error: Could not load GPU driver [ 72.210978] [ERROR]Aborting because fallback start is disabled.
Grazie in anticipo!

(14 Set '13, 01:40) Redrum1777 Redrum1777's gravatar image

@Redrum1777: non usare le risposte per rispondere ai commenti

(14 Set '13, 07:18) enzotib ♦♦ enzotib's gravatar image

scusami era la prima volta che scrivevo qui (:

(14 Set '13, 12:03) Redrum1777 Redrum1777's gravatar image

C'è un pagina del wiki apposta per i computer con doppia scheda grafica.

In particolare credo che tu sia interessato a Bumblebee.

Comunque alcuni produttori (Asus, tanto per citarne uno che dà molti problemi con Linux) modificano l'hardware che montano sui propri computer, in primis le schede grafiche. È quindi possibile che, nonostante i driver e le guide funzionino per qualcuno (ad esempio io uso Bumblebee senza alcun problema) non funzionino per te.

coll. permanente

ha risposto 14 Set '13, 00:35

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161

Prova .....apri il file di configurazione con

sudo gedit /etc/bumblebee/bumblebee.conf

Ora cerca e modifica le righe

Driver= ....

in

Driver=nvidia

e

KernelDriver=....

in

KernelDriver=nvidia

Poi riavvia

coll. permanente

ha risposto 14 Set '13, 10:19

Webber's gravatar image

Webber
3.0k1536

modificato 14 Set '13, 10:32

enzotib's gravatar image

enzotib ♦♦
14.0k112186

Per configurare Bumblebee c'è anche un programma grafico, su un repository esterno (tra l'altro sviluppato da un italiano, quindi molto comodo per il supporto ;) ).

(14 Set '13, 12:10) dadexix86 ♦♦ dadexix86's gravatar image

Ho provato già a fare questa cosa e il risultato è sempre lo stesso, mettendo invece il numero della versione driver che ho installato(come dice la guida wiki di ubuntu.it) ad esempio KernelDriver=nvidia-304.88 etc. ottengo [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect. [ 1209.125319] [ERROR]Could not connect to bumblebee daemon - is it running? E' normale che tramite lspci | grep VGA mi riconosca solo l'Intel?

(14 Set '13, 12:26) Redrum1777 Redrum1777's gravatar image

Hai riavviato dopo aver apportato le modifiche?

Sì, è normale. Finché non accendi la scheda, con optirun nome_comando, resta spenta e quindi non vista.

(14 Set '13, 12:30) dadexix86 ♦♦ dadexix86's gravatar image

Meno male, un problema in meno! Si ho riavviato, teoricamente quali sono le impostazioni corrette? nvidia,nvidia-current o nvidia-304.88? ma il driver= da modificare è quello sotto le client options vero? perchè c'è ne è anche uno più sopra!

(14 Set '13, 12:39) Redrum1777 Redrum1777's gravatar image

Io uso la GUI per modificarlo, lo trovo più comodo :)

Questo comunque è il mio file /etc/bumblebee/bumblebee.conf.

Il driver da usare, dipende dalle impostazioni che vuoi. Io personalmente uso il 325 (che è sperimentale) quindi dovresti, guardando dove è modificato il mio file, capire dove modificare il tuo con i driver che vuoi :)

(14 Set '13, 13:24) dadexix86 ♦♦ dadexix86's gravatar image

Ho fatto direttamente copia e incolla dal tuo text cambiando i numeri della versione ma niente continua a fare l'errore the bumblebee daemon has not been started etc.. Ho scaricato anche io la GUI, reinstallato tramite essa, quando clicco su controlla stato bumblebee mi esce questo: Controllando lo stato di bumblebeed: [ 335.494891] [INFO]Configured driver: nvidia [ 335.496577] [INFO]Switching method 'bbswitch' is available and will be used. [ 335.499237] [ERROR]Module 'nvidia_304' is not found.

(14 Set '13, 14:28) Redrum1777 Redrum1777's gravatar image

Mi viene il dubbio che tu non l'abbia installato. Posta il risultato di

dpkg --get-selections | grep nvidia
(14 Set '13, 14:40) dadexix86 ♦♦ dadexix86's gravatar image

eccolo qui:
bumblebee-nvidia install nvidia-304 install nvidia-current install nvidia-settings-304 install

(14 Set '13, 14:44) Redrum1777 Redrum1777's gravatar image

Ho scoperto che nella prossima versione 13.10 dovrebbe esserci un tool ufficiale per gestire nvidia optimus dunque aspetterò! Ho reinstallato ubuntu per pulire tutti i casini che avevo fatto. Senza bumblebee la scheda video è accesa? il pc consuma di più? rischio di surriscaldarlo?

(15 Set '13, 19:51) Redrum1777 Redrum1777's gravatar image

"Senza bumblebee la scheda video è accesa?" No.
"Il pc consuma di più?" No.
"Rischio di surriscaldarlo?" Sì, sempre, ma dipende da come/dove lo usi ;)

(15 Set '13, 20:18) dadexix86 ♦♦ dadexix86's gravatar image

Ovviamente! Grazie di tutto (:

(15 Set '13, 20:38) Redrum1777 Redrum1777's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×256
×87
×29

domanda posta: 13 Set '13, 22:36

domanda visualizzata: 2,598 volte

ultimo aggiornamento: 15 Set '13, 20:59

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.