Ho da pochi giorni un nuovo PC e ho installato Ubuntu 16.04. Sulla rete ho un NAS dove risiedono tutti i miei documenti. Apro e modifico tutto tranne i documenti openoffice per i quali ottengo un Errore Generale di I/O al tentativo di apertura dei file. Naturalmente funziona tutto regolarmente con il PC avviato in windows e con il mio vecchio PC su cui ho Ubuntu 14.04.

chiesto 09 Mag '16, 03:35

gtFC's gravatar image

gtFC
3013

Hai lo stesso problema anche con LibreOffice?

Versione del software sulla 16.04 e sulla 14.04?

(09 Mag '16, 11:22) dadexix86 ♦♦ dadexix86's gravatar image

Ciao,

Presumo di avere lo stesso problema anche con libreOffice, anche se si presenta in modo diverso. Apro un file e praticamente non succede nulla, vedo per alcuni istanti il puntatore che assume la forma circolare dell'attesa, poi il nulla. Se per versione del software intendi quella di OOO, allora è l'ultima, la 4.1.2. Se passo a windows, naturalmente tutto funziona, con la medesima versione.

(09 Mag '16, 22:47) gtFC gtFC's gravatar image

A meno di rispondere alla (tua) domanda principale, usa i commenti e non le risposte, grazie.

Hai i permessi di scrittura su quella cartella con la 16.04? Sulla 14.04 che versione di LO hai?

(10 Mag '16, 00:12) dadexix86 ♦♦ dadexix86's gravatar image

Sia sulla versione vecchia che sulla nuova ho sempre disinstallato LO prima dell'installazione di OOO. LO è stato solo un tentativo di qualche ora fa sulla 16.04. ed è stato scaricato dal software center. In generale ho permessi di lettura e scrittura su tutte le cartelle del NAS.

(10 Mag '16, 00:35) gtFC gtFC's gravatar image

Tuttavia ritengo che il problema sia proprio lì. Infatti ho aperto in locale un file e ho provato a salvarlo sul NAS ed il messaggio è Errore nel salvare il documento xxxx: Errore generale di I/O durante l'accesso a /run/user/1000/gvfs/smb-share:server=mioserver.local,share=volume_1/xxxx. In più una serie di altre finestre con contenuto analogo.

Dunque anche in apertura fallisce la creazione del file lock.

(10 Mag '16, 00:35) gtFC gtFC's gravatar image

Dopo i messaggi di errore OOO è andato in crash. Sulla cartella di destinazione del NAS, nonostante tutto, ho trovato il file salvato!

(10 Mag '16, 00:40) gtFC gtFC's gravatar image

Esattamente come pensavo, allora... Questa è un'ottima notizia! :)

Perché significa che non è un problema del programma, ma di come si comporta il NAS.

Come lo monti il NAS?

Che file system usi sulla partizione che monti? (se NTFS o FAT fagli un check disk e defrag da Windows)

(10 Mag '16, 09:12) dadexix86 ♦♦ dadexix86's gravatar image

Il NAS lo ho sempre montato sfogliando la rete dopo aver avviato il PC (anche prima, quando usavo il 14.04. Il file system è NTFS ed ora mi accingo a fare un chkdsk ed un defrag, poi ti faccio sapere.

(10 Mag '16, 09:24) gtFC gtFC's gravatar image

Sì, fammi sapere :)

E poi postami l'output di

mount

dato sia su 16.04 (su cui non funziona) che su 14.04 (su cui funziona)

(10 Mag '16, 09:36) dadexix86 ♦♦ dadexix86's gravatar image

Lo scan disk non ha rivelato errori. Per il defrag non esiste una applicazione sul web server integrato del NAS. Ho prvato a connettere l'unità di rete in windows ma non me la elenca fra i drive su cui esegue il defrag.

(10 Mag '16, 10:02) gtFC gtFC's gravatar image

Ciao, per favore per i codici lunghi usa pastebin, che come sono scritti ora non si capisce nulla :S

(10 Mag '16, 12:04) dadexix86 ♦♦ dadexix86's gravatar image

Per il 16.04 il comando mount genera: http://paste.ubuntu.com/16344412/ Per il 14.04 mando il commento questa sera. Grazie.

(10 Mag '16, 12:14) gtFC gtFC's gravatar image

Mh.. ma il NAS è montato, lì?

(10 Mag '16, 12:30) dadexix86 ♦♦ dadexix86's gravatar image

questo è il risultato di mount sul 14.04: http://paste.ubuntu.com/16346013/

(10 Mag '16, 16:05) gtFC gtFC's gravatar image

A occhio direi che il NAS è l'ultima riga.

(10 Mag '16, 16:08) gtFC gtFC's gravatar image

Entrambi i PC hanno lo stesso account personale, potrebbe essere lì l'inghippo?

(10 Mag '16, 16:13) gtFC gtFC's gravatar image

Posta l'output di

ls /run/user/1000/gvfs

Se quello è davvero il NAS, secondo me l'inghippo sta in user=gabriele sulla 14.04, e user_id=1000 sulla 16.04.

(10 Mag '16, 16:33) dadexix86 ♦♦ dadexix86's gravatar image

http://paste.ubuntu.com/16346505/ Questo è il comando sul 16.04

http://paste.ubuntu.com/16346592/ questo è il comando su 14.04

(10 Mag '16, 17:00) gtFC gtFC's gravatar image

Mh... posta

ls -laR ~/.gvfs
(10 Mag '16, 20:53) dadexix86 ♦♦ dadexix86's gravatar image

http://paste.ubuntu.com/16352805/

ho inserito anche un altro comando

(10 Mag '16, 23:16) gtFC gtFC's gravatar image

Quell'output è sulla 16.04 o sulla 14.04?

(10 Mag '16, 23:21) dadexix86 ♦♦ dadexix86's gravatar image

scusa non ho specificato, è della 16.04. Vuoi vedere anche l'altro?

(10 Mag '16, 23:28) gtFC gtFC's gravatar image

Sì, anche se temo che sia uguale...

(10 Mag '16, 23:30) dadexix86 ♦♦ dadexix86's gravatar image
(10 Mag '16, 23:38) gtFC gtFC's gravatar image

Mh... sempre più misterioso. Domani se riesco mi faccio una cultura di gvfs e ti aggiorno con qualche tentativo che val la pena fare.

(10 Mag '16, 23:50) dadexix86 ♦♦ dadexix86's gravatar image

ok grazie.

(10 Mag '16, 23:51) gtFC gtFC's gravatar image

Ho trovato questo thread, ma non ho verificato se effettivamente risolvo (sono fuori ufficio quindi non posso montare il NAS, e non ho neppure capito il perchè del problema.

https://forum.openoffice.org/it/forum/viewtopic.php?f=5&t=7507&p=39755&hilit=Errore+generale+di+I%2FO#p39755

(12 Mag '16, 08:53) gtFC gtFC's gravatar image

Non c'è una soluzione lì, solo il problema, che sembra essere molto simile al tuo. Sinceramente non saprei che dirti...

Hai provato con un altro utente sulla 16.04, se riesci a farci qualcosa?

(12 Mag '16, 10:35) dadexix86 ♦♦ dadexix86's gravatar image

Avevo frettolosamente visto risolto e mi sono illuso. Ho provato con un altro utente, il comportamento è simile a quello sperimentato con LO, non compare l'errore generale di I/O ma non si apre alcun file. Sono un pò demoralizzato visti i tentativi e il tempo perso. Pensavo di convertire il tutto in un sistema tipo owncloud, ma anche questo non si sposa con 16.04. Dovrò copiare tutto il contenuto del NAS in locale e trovare un sistema di sincronizzazione non troppo invasivo, ma l'idea mi deprime. Grazie comunque per il tempo perso ed i suggerimenti spesi.

(13 Mag '16, 22:18) gtFC gtFC's gravatar image

Si trovano parecchi post su questo argomento con chiave di ricerca nobrl option.

(17 Mag '16, 23:34) gtFC gtFC's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×33
×10

domanda posta: 09 Mag '16, 03:35

domanda visualizzata: 795 volte

ultimo aggiornamento: 17 Mag '16, 23:34

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.