Ciao a tutti,

premetto che il collegamento ethernet mi funziona; ho un problema quando tento di collegare il pc (con su Ubuntu 14.04 LTS) con un dispositivo Ettus (N210). Al collegamento via ethernet, infatti, sulla barra di notifica viene tentata la connessione, ma non va a buon fine.

Il dispositivo ha un indirizzo predefinito che è 168.192.10.2, ho cercato di mettermi nello stesso subnet modificando l'indirizzo di eth0, ma non sono sicuro di esserci riuscito.

Il comando ifconfig mi da come risultato il seguente:

$ ifconfig
eth0      Link encap:Ethernet  IndirizzoHW 54:a0:50:8b:d9:c5  
          indirizzo inet6: fe80::56a0:50ff:fe8b:d9c5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13870 errors:0 dropped:0 overruns:0 frame:0
          TX packets:964 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000 
          Byte RX:2215113 (2.2 MB)  Byte TX:210760 (210.7 KB)

lo        Link encap:Loopback locale  
          indirizzo inet:127.0.0.1  Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3718 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3718 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:0 
          Byte RX:359085 (359.0 KB)  Byte TX:359085 (359.0 KB)

usb0      Link encap:Ethernet  IndirizzoHW 96:15:45:67:43:dd  
          indirizzo inet:192.168.42.109  Bcast:192.168.42.255  Maschera:255.255.255.0
          indirizzo inet6: fe80::9415:45ff:fe67:43dd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14632 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16504 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000 
          Byte RX:7613511 (7.6 MB)  Byte TX:2703324 (2.7 MB)

Ho provato a modificare l'indirizzo col comando:

$ ifconfig eth0 168.192.10.1 netmask 255.255.255.0
SIOCSIFADDR: Operazione non permessa
SIOCSIFFLAGS: Operazione non permessa
SIOCSIFNETMASK: Operazione non permessa

e mi da questo output, con sudo davanti invece sembra prendere il comando, infatti se verifico:

$ ifconfig eth0
eth0      Link encap:Ethernet  IndirizzoHW 54:a0:50:8b:d9:c5  
          indirizzo inet:168.192.10.1  Bcast:168.192.10.255  Maschera:255.255.255.0
          indirizzo inet6: fe80::56a0:50ff:fe8b:d9c5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13870 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1110 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000 
          Byte RX:2215113 (2.2 MB)  Byte TX:240859 (240.8 KB)

Ma ho ancora lo stesso problema con le stesse modalità.

Ho anche provato a modificare i file /etc/NetworkManager/NetworkManager.conf e/o /etc/network/interfaces nei seguenti modi:

$ sudo gedit /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet static
address 192.168.10.1
netmask 255.255.255.0
gateway 192.168.10.1

$ sudo gedit /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

no-auto-default=54:A0:50:8B:D9:C5,

[ifupdown]
managed=true

ma ancora niente.

Tra l'altro, se può essere utile, quando collego pc e dispositivo il led dell'ethernet rimane spento.

Vi ringrazio in anticipo per l'aiuto.

chiesto 01 Giu '16, 17:55

strings's gravatar image

strings
2012

Mischiare le configurazioni di NetworkManager con quelle di /etc/interfaces non è una buona idea.

Quel dispositivo ha un manuale che mi sembra molto ben fatto, in cui sono anche tutta una serie di passaggi legati alla risoluzione dei problemi. L'hai letto e seguito? Quali errori ti danno i vari suggerimenti lì postati?

NB: non ho la più pallida idea di cosa faccia e a cosa serva quel dispositivo.

(01 Giu '16, 20:40) dadexix86 ♦♦ dadexix86's gravatar image

Ciao dadexix, grazie per la risposta.

Sì, seguo il manuale, ma il mio problema è che il pc non "vede" il dispositivo. Secondo me fissando l'indirizzo di eth0 su 168.192.10.1 dovrebbe vederlo, ma le risoluzioni che ho trovato per mettere un indirizzo statico non hanno funzionato o non le ho seguite a dovere.

(06 Giu '16, 16:31) strings strings's gravatar image

Sì che hanno funzionato (vedi l'output nel tuo post...), ma potrebbe essere che quel dispositivo debba essere configurato correttamente prima? Tra l'altro non mi è affatto chiaro cosa dovrebbe fare...

Posta per favore passo-passo cosa succede seguendo quel manuale, cosa ti aspetti che succeda e cosa ricevi invece come risposta errata.

(07 Giu '16, 08:15) dadexix86 ♦♦ dadexix86's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×439
×29

domanda posta: 01 Giu '16, 17:55

domanda visualizzata: 433 volte

ultimo aggiornamento: 07 Giu '16, 08:15

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.