Salve, ho installato libre office su una nuova macchina ubuntu 1604. La release è 5.1.4.2 in italiano scaricata dal repository Canonical. Uso soprattutto il data base da molti anni su altre macchine, mi sembra che l’interfaccia e le funzioni di questa versione siano vecchie rispetto alle altre in inglese che sto usando; soprattutto il generatore dei report appare molto povero. Cosa è che non capisco? Grazie per ogni suggerimento. Pier Luigi Bonucci

chiesto 13 Lug '16, 18:30

plb's gravatar image

plb
024

@plb: qual è la release sulla altre macchine che usi?

(14 Lug '16, 07:43) enzotib ♦♦ enzotib's gravatar image

La macchina che uso comunemente da anni è aggiornata ad ubuntu 1604 ed ha LO con la 5.1.4.2 come le altre, l'unica differenza è la lingua: inglese per questa installazione e italiano nelle altre. Come ho detto interfaccia e funzioni sono profondamente diverse specialmente nel modulo per la generazione di report, ma ci sono anche altri problemi ad esempio nella generazione di view non sopporta nomi di colonne uguali in tabelle diverse sebbene vengano richiamate con la sintassi classica nome tabella.mome colonna. Grazie per ogni aiuto mi potrai dare.

Pier Luigi

(14 Lug '16, 09:59) plb plb's gravatar image

Potresti mettere due immagini delle schermate diverse?

(14 Lug '16, 12:00) dadexix86 ♦♦ dadexix86's gravatar image

Di seguito le schermate del modulo di edit dei report, la prima evoluta, la seconda sembra una release molto datata.

http://chiedi.ubuntu-it.org/upfiles/Screenshot_from_2016-07-14_15-32-58.png
http://chiedi.ubuntu-it.org/upfiles/Schermata_del_2016-07-14_15-40-12.png
(14 Lug '16, 15:48) plb plb's gravatar image

Ho messo le immagini in una risposta alla mia domanda.

(14 Lug '16, 15:49) plb plb's gravatar image

A meno di rispondere alla (tua) domanda principale per favore usa i commenti e non le risposte, grazie.

Inoltre, dovresti postare la differenza quando apri lo stesso file, allo stesso modo (nella seconda schermata manca il titolo, e manca una barra di pulsanti, e sembra più Writer che Base, a parte il tema di icone diverso).

Apri lo stesso file nello stesso programma con le stesse impostazioni (a parte la lingua) e posta le due schermate.

(14 Lug '16, 15:58) dadexix86 ♦♦ dadexix86's gravatar image

Ok, comunque la schermata che vedi è quella che si apre quando vai in edit di un report. Come faccio a mettere una immagine in un commento?

(14 Lug '16, 16:08) plb plb's gravatar image

La cosa migliore è che la metti su imgur e metti semplicemente il link qui :)

(14 Lug '16, 16:46) dadexix86 ♦♦ dadexix86's gravatar image

I report generati dalla versione evoluta non sono apribili da quella meno evoluta, le form si aprono aqnche se con interfaccia diversa ma i report no, ne in editing ne lanciandoli. Ora provo il contrario da meno evoluta ad evoluta.

(14 Lug '16, 17:49) plb plb's gravatar image

I report generati con la versione meno evoluta si aprono sull'altra ma mostrano la stessa interfaccia povera che come hai notato sembra piuttosto quella del writer. In effetti quando un report viene lanciato il motore genera un file writer, è come se nella versione non evoluta mancasse la parte di interfaccia per l'editing. Sono abbastanza confuso, inoltre ci sono anche altri problemi come quello che ti ho descritto per il generatore di view.

(14 Lug '16, 17:59) plb plb's gravatar image

Cosa intendi con "meno evoluta"? Se è la stessa versione, non ce n'è una più e una meno evoluta. Sei sicuro di stare usando LibreOffice su entrambe le piattaforme? Vai in Help>About LibrOffice su entrambi i computer e verifica che sia la stessa versione (magari posta le schermate).

(14 Lug '16, 20:08) dadexix86 ♦♦ dadexix86's gravatar image

E' solo un modo di dire per indicarti le diversità che vedo tra i due sistemi. Sono certo delle release, le ho verificate proprio come dici ma ti manderò comunque le schermate. Ammetto che sembra impossibile quello che sto dicendo, ma è quello che mi accade, il fatto che i report creati con il sistema che uso di solito non siano leggibili dall'altro che ho appena scaricato non sembra avere spiegazioni. Non so cosa provare di diverso.

Pier Luigi

(14 Lug '16, 20:52) plb plb's gravatar image

Forse ti posso inviare il db che avevo cominciato a creare, puoi provarlo su un tuo sistema? Come te lo invio?

Pier Luigi

(14 Lug '16, 20:54) plb plb's gravatar image

Posta su pastebin l'output di

apt policy libreoffice.

(non dimenticare il punto alla fine!), e di

lsb_release -a && uname -a && ls /etc/apt/sources.list.d && cat /etc/apt/sources.list

dati su entrambi i sistemi e metti qui i link.

(14 Lug '16, 20:58) dadexix86 ♦♦ dadexix86's gravatar image

Ho dimenticato di segnalare una cosa importante, la macchina di recente installazione che non funziona bene è a 32 bit mentre l'altra su cui lavoro da anni è 64. chiedo scusa mi era sfuggito.

(15 Lug '16, 10:28) plb plb's gravatar image

Mandami i link con l'output di cui sopra per favore :)

(15 Lug '16, 10:54) dadexix86 ♦♦ dadexix86's gravatar image

Ciao ecco il link al file che contiene gli output delle due macchine considerate. Il file è su drive (mi veniva meglio):) https://docs.google.com/document/d/1wrcXCeS3yPwmy3N20OkHFw4J__voZb2QWieixpBjemU/edit?usp=sharing

(15 Lug '16, 13:43) plb plb's gravatar image

Per favore dai anche l'ultimo comando così come te l'ho dato, non modificarlo :)

(15 Lug '16, 18:43) dadexix86 ♦♦ dadexix86's gravatar image

Lo ho sbagliato in entrambe le macchine?

(15 Lug '16, 19:21) plb plb's gravatar image

Sì, il primo che hai dato è stato

lsb_release -a && uname -a ls /etc/apt/sources.list.d && cat /etc/apt/sources.list

e il secondo è stato

lsb_release -a && ls /etc/apt/sources.list.d && cat /etc/apt/sources.list

Mentre il comando che ti ho dato io è

lsb_release -a && uname -a && ls /etc/apt/sources.list.d && cat /etc/apt/sources.list
(15 Lug '16, 19:33) dadexix86 ♦♦ dadexix86's gravatar image

Scusa, ho fatto tutto in fretta. Ecco il link al file con gli otput spero buoni stavolta. https://docs.google.com/document/d/1aqQVRLB4f9iXQdMSp4dWq4uxpTk2pdx_UHtB1hoDg0I/edit?usp=sharing

(15 Lug '16, 23:48) plb plb's gravatar image

La prossima volta che qualcuno ti chiede di mettere su pastebin dell'output, per favore mettilo su pastebin. Avrebbe reso quello che ho fatto molto più veloce :)

Ci sono delle differenze sostanziali tra le due macchine. A cominciare dal fatto che non hai gli stessi pacchetti installati. Guarda questo pastebin per vedere le differenze.

Poi, uno dei due computer è stato aggiornato da 15.10, l'altro ha una installazione pulita. [...]

(16 Lug '16, 11:38) dadexix86 ♦♦ dadexix86's gravatar image

[...] Potrebbe essere che nella vecchia home ci siano dei residui di configurazione che modificano l'aspetto e le funzionalità di LO, se provi sulla macchina aggiornata con un nuovo utente, ottieni funzionalità uguali a quelle dell'altra?

Per i repository, hai gli stessi di qua e di là, solo i deb-src mancano, ma non dovrebbero interessare il problema.

Prova se installando i pacchetti che mancano il problema di risolve. Se no, fai la prova con una home pulita (nuovo utente) su entrambe le macchine. Se risolve, vediamo di copiare la home corretta su entrambi i sistemi.

Fammi sapere.

(16 Lug '16, 11:44) dadexix86 ♦♦ dadexix86's gravatar image

Visto le differenze, non c'è installato il report builder lo credo che non funziona, quindi: 1 ho installato da canonical libreoffice base perchè non c'è il report buider? 2 da dove lo scarico? 3 il connettore verso mysql penso non sia significativo per il problema. 4 chiedo scusa per pastebin non pensavo fosse un problema, ora lo so.

Pier Luigi

(16 Lug '16, 12:47) plb plb's gravatar image

Perché non l'hai installato, apri il gestore pacchetti e installalo, oppure da terminale. È nei repository Canonical, semplicemente non l'hai installato quando hai installato libreoffice.

Magari era una dipendenza sulla 15.10, e si è installato automaticamente prima dell'upgrade, ma non lo è più sulla 16.04 e ti sei dimenticato di installarlo quando hai installato il tutto.

(16 Lug '16, 12:48) dadexix86 ♦♦ dadexix86's gravatar image

E la luce fu. Ora funziona, approfitto ancora per una domanda: si è trattato della mancata installazione non di un pacchetto, ma di una funzione di un pacchetto, da cosa avrei dovuto capire che il pacchetto non era completo? e non è strano questo comportamento?

A parte ciò, ti ringrazio infinitamente per il tempo che hai perso con me, ti faccio i complimenti per la tua competenza, chiedo scusa per le disattenzioni. devo mettere questa domanda come chiusa, come devo fare? dove esprimo la mia soddisfazione?

Pier Luigi

(16 Lug '16, 15:35) plb plb's gravatar image

Ottimo! :)

Mancavano proprio dei pacchetti che non erano installati (più d'uno), quelli che ti ho detto sopra.

Ti sei dimenticato di installarli quando hai installato il sistema o simili.

Scrivo una risposta, poi tu accettala per favore.

(16 Lug '16, 16:54) dadexix86 ♦♦ dadexix86's gravatar image

Tra i due sistemi c'era una differenza di pacchetti installati, su quello che non funzionava non erano stati installati i pacchetti

libreoffice-report-builder-bin
libreoffice-mysql-connector
libreoffice-style-human 
libreoffice-report-builder

presenti nell'altro.

Un'installazione da terminale si può fare facilmente con

sudo apt install libreoffice-report-builder-bin libreoffice-mysql-connector libreoffice-style-human libreoffice-report-builder
coll. permanente

ha risposto 16 Lug '16, 16:56

dadexix86's gravatar image

dadexix86 ♦♦
16.9k716161

modificato 16 Lug '16, 16:58

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×42
×13

domanda posta: 13 Lug '16, 18:30

domanda visualizzata: 465 volte

ultimo aggiornamento: 16 Lug '16, 16:58

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.