Buonasera a tutti! Avrei un grosso problema con le partizioni... : qualcuno mi può aiutare...?

Ho usato testdisk per risistemare la tabella delle partizioni, e ho fatto del macello con il file system, per cui ora il sistema mi entra nella modalità "grub-rescue", e l'errore è "unknow filesystem". In sostanza avevo un HD vecchio da 250 GB che funzionava male. Su questo HD avevo una partizione per Ubuntu (con il loader) e una con Windows. Ho comprato un nuovo HD da 1GB e ho clonato il vecchio HD con dd. Senza farla troppo lunga, diciamo che ho avuto un po' di problemi nell'avviare il nuovo disco, così sono entrato in una delle modalità di ripristino e ho cercato di correggere gli errori. Alla fine il sistema funzionava ma la partizione di Windows non era più nel loader, e Ubuntu mi presentava una partizione di 104 MB dicendomi che non era montata, (che dovrebbe essere quella del loader originale). In realtà i problemi li avevo avuti perché avevo modificato impropriamente fstab, e quindi secondo me in origine la clonazione era avvenuta correttamente. Poi con i tentativi di ripristino ho incasinato le cose, putroppo. Così ho usato testdisk sul vecchio HD (non ho collegato i due HD contemporaneamente) e ho visto qual era la tabella delle partizioni vecchia. Poi ho usato testdisk sul nuovo HD e ho modificato la tabella come quella che avevo sull'altro HD. All'inizio testdisk mi diceva che la partizione di avvio era "bad". Allora ho usato l'opzione "rebuild" e poi mi diceva "ok". Ho riavviato e non riconosce il loader (che è in NTFS)alt text Ora sto scrivendo dal sistema che è sul vecchio HD.. ho scaricato l'ISO di ubuntu e mi appresto a masterizzare una versione live, da avviare con il nuovo HD collegato. Vorrei cercare di ripristinare il sistema, com'era sull'HD originale, ampliando la partizione di Linux a tutto lo spazio disponibile nel nuovo HD. Se qualche santo mi da una mano gli sarò eternamente grato!

Riporto 2 immagini di come ho usato testdisk sul vecchio HD...

alt text

chiesto 02 Set '16, 00:07

faberubuntu's gravatar image

faberubuntu
203

modificato 02 Set '16, 00:09

Penso che dovresti almeno, come minimo sindacale, dire di quale sistema operativo stai parlando?

(02 Set '16, 07:09) enzoge enzoge's gravatar image

Il sistema è ubuntu 16.04 LTS

(02 Set '16, 10:21) faberubuntu faberubuntu's gravatar image

Sistema Ubuntu 16.04 LTS

(02 Set '16, 10:22) faberubuntu faberubuntu's gravatar image

Quello che farei io è clonare di nuovo il disco vecchio sul nuovo, aggiornare l'fstab relativo e poi riprovare, senza toccare null'altro per ora.

(02 Set '16, 10:52) dadexix86 ♦♦ dadexix86's gravatar image

Ciao dadexix86, e grazie del consiglio. Però non vorrei percorrere questa strada, perché è un po' che uso il nuovo HD.. e non vorrei perdere i nuovi dati.... Quello che pensavo di fare io è di far partire la versione live e ripristinare il grub usando testdisk o qualche altro strumento.... anche se non ho ancora chiaro il dettaglio. Vorrei cercare di ripristinare il loader di win, perché al momento non ho più la possibilità di installarlo ex novo ...

(02 Set '16, 11:26) faberubuntu faberubuntu's gravatar image

Ho avviato da live e questa e' la tabella delle partizioni. Secondo voi cosa c'e' che non va?

http://chiedi.ubuntu-it.org/upfiles/Screenshot_from_2016-09-02_12-41-59.png

(02 Set '16, 14:43) faberubuntu faberubuntu's gravatar image

@faberubuntu, usa i commenti, non le risposte

(03 Set '16, 08:47) enzotib ♦♦ enzotib's gravatar image

Grazie Ho risolto

(03 Set '16, 15:43) faberubuntu faberubuntu's gravatar image

Se ti va di spiegare come in una risposta ed accettarla, altri potranno usufruire della tua esperienza in futuro per risolvere problemi simili :)

(03 Set '16, 18:54) dadexix86 ♦♦ dadexix86's gravatar image

Ho trovato la soluzione sui video di youtube. Ce ne sono diversi. In sostanza bisogna dire a grub quale filesystem usare. Da prompt, con ls si ottiene la lista dei 4-5 filesystem presenti. Per esempio (hd0,msdos3). Poi si prova a listarne uno specifico. Es. ls (hd0,msdos3). Oppure ls (hd0,msdos6). Quando come risposta si riceve ext2, o ext4, o comunque non unknown filsystem, si procede così:

(04 Set '16, 13:38) faberubuntu faberubuntu's gravatar image

Supponendo di usare (hd0,msdos3):

Set boot=(hd0,msdos3)

Set prefix=(hd0,msdos3)/root/grub

Insmode=normal

Normal

Tutto senza maiuscole. Poi il sistema si riavvia. Spero di aver scritto bene. Sono andato a memoria. Cmq non sono riuscito a ripristinare il loader windows. Il sistema non trovava il file "normal" per la "i-386". Ho provato ad aggiornare a grub2 ma niente. Alla fine ho eliminato windows.

(04 Set '16, 13:39) faberubuntu faberubuntu's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×146
×143
×58
×32

domanda posta: 02 Set '16, 00:07

domanda visualizzata: 234 volte

ultimo aggiornamento: 04 Set '16, 13:40

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.