Buonasera, Ho installato ubuntu su un notebook asus ma, come da titolo, la tastiera interna e il touchpad integrato non funzionano. Devo usare tastiera e mouse esterni collegati via usb. Come posso risolvere? Nell'installazione ho settato acpi off, se può servire.. ;) Grazie

chiesto 20 Set '16, 19:38

Anto123's gravatar image

Anto123
2514

Modello esatto del pc?

Potrebbe essere quello il problema, ACPI serve a far riconoscere al sistema le periferiche... Da live funziona tutto?

(20 Set '16, 19:49) dadexix86 ♦♦ dadexix86's gravatar image

Asus x59gl Si, da live funzionavano. Ho dovuto disattivare acpi perchè altrimenti non si installava, si bloccava.

(20 Set '16, 20:07) Anto123 Anto123's gravatar image

A giudicare da una breve ricerca Google sembra già un mezzo miracolo che tu sia riuscito ad installarlo, su quel pc... C'è un bug aperto dal 2009 (nota a latere: su un PC così vecchio lascia perdere Ubuntu, mettici al massimo Xubuntu) oltre a "una tonnellata" di altri problemi con, appunto, ACPI (e di conseguenza un sacco di periferiche).
[...]

(20 Set '16, 20:16) dadexix86 ♦♦ dadexix86's gravatar image

[...]

Qui suggeriscono di lasciar perdere direttamente Ubuntu e derivate e provare altro, in particolare PCLinuxOS.

(20 Set '16, 20:17) dadexix86 ♦♦ dadexix86's gravatar image

Infatti ho faticato parecchio.. Ci ho messo due pomeriggi quasi per provarle tutte.. Ho installato ubuntu accanto a windows 7, poi ho messo anche lubuntu, che gira già meglio. Ma apparte tastiera e qualche parola in inglese, sembra che vadi benone. Poi sono nuovo di linux, ma per il momento.. Pensavo che l'opzione acpi disattivandola era solo nell'installazzione. Quindi anche ora è ancora disattivata? C'è modo di provare a attivarla? Grazie ;)

(20 Set '16, 20:29) Anto123 Anto123's gravatar image

Dipende da come l'hai disabilitata. Se l'hai disabilitata dal BIOS, finché non la riattivi non vedo perché debba riabilitarsi. Se l'hai disabilitata invece sul sistema live aggiungendo un parametro di boot, in teoria dovrebbe restare disabilitata (se necessiti di averla per il boot live, non vedo cosa cambi nel momento in cui installi su disco), ma non sono un esperto. In questo secondo caso (ovvero se l'hai disabilitata da parametro di avvio) posta l'output di

cat /etc/default/grub
(21 Set '16, 11:22) dadexix86 ♦♦ dadexix86's gravatar image

Grazie. Io l'ho disabilitata nell'installazione dal boot. Funziona ugualmente a riattivarla in questo modo?

(22 Set '16, 21:18) Anto123 Anto123's gravatar image

Postami l'output che ti ho chiesto per favore :)

(22 Set '16, 21:28) dadexix86 ♦♦ dadexix86's gravatar image
(19 Ott '16, 06:06) Anto123 Anto123's gravatar image

A meno di rispondere alla (tua) domanda principale usa i commenti e non le risposte, grazie.

Hai sia acpi=off che nomodeset, questo non me l'avevi detto.

Hai installato qualcosa di più leggero alla fine, tipo Xubuntu o Lubuntu? Se sì e questo è il file di configurazione di GRUB della nuova installazione, ti spiego come rimuovere nomodeset.

(19 Ott '16, 10:32) dadexix86 ♦♦ dadexix86's gravatar image

Scusa :S Si, avevo disattivato qualcos'altro per far partire l'installazione ma non ricordavo.. Ho installato sia ubuntu che lubuntu. Entrambi hanno lo stesso problema. Ma preferisco usare lubuntu, da cui ho estratto l'output. Nomodeset era per i driver grafici? L'installazione non partiva se non lo disattivavo, rimaneva lo schermo nero. Ho installato lubuntu e poi scaricato i driver nvidia. Riattivandolo sovrascrive questi? Grazie

(19 Ott '16, 14:19) Anto123 Anto123's gravatar image

nomodeset da sì che non vengano caricati moduli aggiuntivi del kernel, riducendo al minimo indispensabile le capacità dell'hardware. In genere serve a far funzionare tutto, ma poco.

Se anche con Lubuntu hai lo stesso problema, fossi in te proverei a togliere sia nomodeset che acpi=off.

Per provare una volta, quando arrivi al GRUB premi "e" e cancella quelle due istruzioni dalla riga di avvio. Poi avvii (mi sembra premendo F10, ma controlla nella schermata) e provi. Se non si blocca, il problema stava lì. Se si blocca, prova a togliere solo una delle due.

(19 Ott '16, 14:30) dadexix86 ♦♦ dadexix86's gravatar image

Risolto!!! Ho tolto solamente la voce acpi off, perchè nomodeset c'era ma era seguito da quiet e un'altra stringa e non volevo far danni.. Provare a togliere anche nomodeset che magari potrebbe dare altri problemi? Comunque la tastiera e touchpad ora funzionano!!! Grazie :)

(19 Ott '16, 14:45) Anto123 Anto123's gravatar image

Ottimo! mah, se non hai altri problemi io lascerei stare nomodeset per ora...

Scrivo una risposta, tu accettala :)

(19 Ott '16, 15:31) dadexix86 ♦♦ dadexix86's gravatar image

Fatto. Grazie mille per il supporto. Finalmente posso usare la distro sul notebook come si deve. Grazie ;D Risolto

(19 Ott '16, 18:28) Anto123 Anto123's gravatar image

È stato sufficiente eliminare acpi=off dal GRUB per risolvere il problema.

coll. permanente

ha risposto 19 Ott '16, 15:31

dadexix86's gravatar image

dadexix86 ♦♦
16.9k716161

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×80
×64
×34

domanda posta: 20 Set '16, 19:38

domanda visualizzata: 486 volte

ultimo aggiornamento: 19 Ott '16, 18:28

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.