Buongiorno, sono un utente alle prime armi. Ho istallato Ubuntu 16.04 facendo l'upgrade da 15.10.

Per un po' tutto ok, sono perfino riuscito ad istallare cups per gestire due stampanti di cui una in rete (domestica). Improvvisamente le stampanti mi danno segnale di "interrotto" nel collegamento.

Ho disistallato sia le stampanti che cups e provato ad istallare solo quella che ho collegato mediante USB. Il fatto è che l'applicazione "stampanti" nelle impostazioni di sitema non mi dà più l'opzione di agire localmente per cui l'opzione "aggiungi" è inattiva.

Il messaggio dice: "servizio di stampa inattiva, avviare il servizio su questo computer oppure connettersi ad un altro server" ma il tasto "avvia servizio" non è, come dicevo, attivo.

Aiuto :o

Andrea

chiesto 30 Set '16, 14:50

Andyzeta's gravatar image

Andyzeta
20113

Quando dici che non va in locale intendi che non trova più le stampanti USB?

(02 Ott '16, 15:48) dadexix86 ♦♦ dadexix86's gravatar image

Ciao, scusami il ritardo ma questo sistema è pura follia. Qui si perde tempo in complicazioni inutili.

Comunque, grazie per la cortesia di provare ad aiutarmi.

Dunque. Se apro l'applicazione Stampanti compare il messaggio che ho riportato sopra, ovvero: " servizio di stampa inattiva, avviare il servizio su questo computer oppure connettersi ad un altro server" Purtroppo è impossibile avviarlo sul computer perchè il tasto "Avvia servizio" non è cliccabile perchè non attivo.

Parimenti non è attivo nemmeno il tasto "Aggiungi" Quindi sono bloccato e non so che fare. :-)

(02 Ott '16, 16:30) Andyzeta Andyzeta's gravatar image

Non è una risposta ma non so come fare a dare questo ulteriore contributo per spiegarmi meglio. Allego schermata della finestra dell'app stampanti dove si riconoscono i tasti non attivi. Naturalmente fino a prima di dover istallare cups (solo per utilizzare una stampante in rete!!!) la stampante conessa all'usb funzionava senza problemi. alt text

(02 Ott '16, 16:43) Andyzeta Andyzeta's gravatar image

Mah, questa cosa è stranissima. Hai utilizzato qualche strumento di "pulizia" del computer? Tipo per provare a velocizzare l'avvio, eliminare file "inutili", ecc?

In teoria CUPS è installato di default. Il sistema 16.04 l'hai installato da zero o hai fatto un avanzamento da tipo 15.10? 14.04?

(02 Ott '16, 16:48) dadexix86 ♦♦ dadexix86's gravatar image

Si, credo proprio di aver utilizzato Bleacbit (non come root) perchè firefox è molto lento ad avviarsi. Lento è rimasto, però mi sono fulminato le stampanti :-)

Si, ho avanzato da 15.10

Che faccio: reistallo cups?

(02 Ott '16, 16:51) Andyzeta Andyzeta's gravatar image

Bleachbit era proprio da evitare, soprattutto senza un consiglio passo-passo da parte di qualcuno veramente esperto.

Quando io ho avuto la malaugurata esperienza di utilizzare Bleachbit, l'unica "soluzione" che avevo trovato per il mio sistema era stato reinstallare; ora lo tratto come la peste.
Per ora ti sei accorto di CUPS, ma una volta risolto questa sono certo che ne spunterà fuori un'altra, e poi un'altra, ecc.

Reinstallare CUPS deve essere il primo passo, ma poi devi anche cercare di recuperare i files che ha cancellato Bleachbit che configuravano CUPS "alla Ubuntu" e ricrearli.

(02 Ott '16, 16:56) dadexix86 ♦♦ dadexix86's gravatar image

Magnifico.

Credo convenga a questo punto reinstallare daccapo. Solo che ho il cd di 15.10 per cui mi ci va un tempo infinito e speravo di risolvere altrimenti.

C'è un modo di reinstallare direttamente 16.04?

(02 Ott '16, 17:01) Andyzeta Andyzeta's gravatar image

Conviene che usi una penna USB anziché un CD.

Scarichi la iso della 16.04, apri il "Creatore dischi di avvio" e gli fai scrivere la live della 16.04 sulla USB.

(02 Ott '16, 17:24) dadexix86 ♦♦ dadexix86's gravatar image

Ehm... grazie.

Vediamo se ho capito. Scarico la iso di 16.04 direttamente sulla chiavetta. Apro creatore di dischi ( che non ho mai aperto) e gli dico ... cosa?

Abbi pazienza ma per me è un po' arduo seguirti

(02 Ott '16, 17:34) Andyzeta Andyzeta's gravatar image

No, no, scaricala in Scaricati, o in altra cartella che vuoi, ma NON sulla chiavetta (che verrà formattata per poterla usare).

Poi apri il Creatore dischi di avvio, in alto selezioni la iso e in basso la pennetta.

(02 Ott '16, 18:02) dadexix86 ♦♦ dadexix86's gravatar image

Ecco, non avevo capito nulla.

Ora mi è chiaro. Ho visto.

Poi per istallare?

(02 Ott '16, 18:14) Andyzeta Andyzeta's gravatar image

Per installare segui la guida ufficiale :)

(02 Ott '16, 18:43) dadexix86 ♦♦ dadexix86's gravatar image

Ah sì, chiaro. Come vedi ogni tanto mi perdo in poco. grazie.

(02 Ott '16, 18:46) Andyzeta Andyzeta's gravatar image

Prego! fammi sapere :)

(02 Ott '16, 18:57) dadexix86 ♦♦ dadexix86's gravatar image

Reinstallato tutto. Ora l'applicazione stampanti funziona. Cups funziona e quando apro la pagina http://localhost:631/printers/ ho accesso.

Non riesco più ad installare il driver della stampante laser che ho in rete. E' una brother 1610 con istruzioni qui: http://support.brother.com/g/b/downloadhowto.aspx?c=it&lang=it&prod=dcp1610w_eu_as&os=128&dlid=dlf101533_000&flang=4&type3=559

Seguendo queste istruzioni in passato avevo installato e funzionava ora quando provo a dare il comando /etc/printcap mi dice "permesso negato" e i punti successivi sono un mistero :-)

(03 Ott '16, 16:26) Andyzeta Andyzeta's gravatar image

Ottimo! Sai che devi stare alla larga, larghissima da bleachbit e altri tool di pulizia in futuro ;)

Quello non è un comando che devi dare, ma un file di configurazione che devi adattare alle tue esigenze (come spiegato lì)

(03 Ott '16, 21:46) dadexix86 ♦♦ dadexix86's gravatar image

Grazie per l'aiuto e per la pazienza.

Alla larghissima, certo.

File di configurazione? Bello. Come lo trovo e come lo apro?

Onestamente mi chiedo come mai con Ubuntu debba essere tutto così complicato. :-)

(04 Ott '16, 08:36) Andyzeta Andyzeta's gravatar image

Scusa, sì, occorre gedit per aprire il file. Aperto.

E la soddisfazione massima è che stamattina non funziona più Cups, Firefox non riesce a connettersi a http://localhost:631/printers/ Cioè siamo punto e daccapo

(04 Ott '16, 09:12) Andyzeta Andyzeta's gravatar image

Scusa, falso allarme, si vede che ha avuto un attimo di sconforto. Ora va.

(04 Ott '16, 09:29) Andyzeta Andyzeta's gravatar image

Mi hai fatto prendere un bel colpo XD

Ora funziona tutto?

(04 Ott '16, 12:54) dadexix86 ♦♦ dadexix86's gravatar image

Grazie.

Certo che no. La stampante Brother non va, Non riesco ad installare il suo driver, pur seguendo le istruzioni, perchp la modifica del file /etc/princap mi dà errore. Sarò io che sbaglio qualcosa. Certo quando vedo che i miei figli l'hanno istallata in rete con un clic e che gli funziona anche lo scanner wifi, senza problemi di sorta...

(04 Ott '16, 14:09) Andyzeta Andyzeta's gravatar image

Quale error ti dà esattamente?

Purtroppo le Brother sono un gradino sotto persino alle Canon quando si tratta di compatibilità con sistemi liberi :(

(04 Ott '16, 14:11) dadexix86 ♦♦ dadexix86's gravatar image

Bah, un sistema che ti costringe all'uso del terminale ... :(( e non solo x le Brother ... ;-)

comunque

Le istruzioni sono sempre qui: http://support.brother.com/g/b/downloadhowto.aspx?c=it&lang=it&prod=dcp1610w_eu_as&os=128&dlid=dlf101533_000&flang=4&type3=559

A parte che i prerequisiti richiesti sono un delirio da sistemare, e che qui non ci sono i caratteri a sufficienza per cui farò tanti commenti

Sono al passo finale

Apro con gedit /etc/princap ed eseguo le istruzioni quando salvo il terminale mi dice:

(04 Ott '16, 14:22) Andyzeta Andyzeta's gravatar image

(gedit:4122): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(gedit:4122): WARNING : Set document metadata failed: Impostazione dell'attributo metadata::gedit-spell-enabled non supportata

(gedit:4122): WARNING : Set document metadata failed: Impostazione dell'attributo metadata::gedit-encoding non supportata

(04 Ott '16, 14:22) Andyzeta Andyzeta's gravatar image

nel file c'è questo: DCP1610W:\ :mx=0:\ :sd=/var/spool/lpd/DCP1610W:\ :sh:\ :rm=192.168.0.164\ :rp=lp\ :if=/opt/brother/Printers/DCP1610W/lpd/filter_DCP1610W:

(04 Ott '16, 14:23) Andyzeta Andyzeta's gravatar image

con 15.10 alla fine ero riuscito a farlo funzionare

(04 Ott '16, 14:24) Andyzeta Andyzeta's gravatar image

alla fine capita questo: christian@christian-desktop:~$ /etc/init.d/lpr restart bash: /etc/init.d/lpr: File o directory non esistente christian@christian-desktop:~$ sudo /etc/init.d/lpr restart sudo: /etc/init.d/lpr: comando non trovato

(04 Ott '16, 14:27) Andyzeta Andyzeta's gravatar image

Non è troppo vero che devi usare il terminale sempre; i miei usano Ubuntu quotidianamente e non credo nemmeno sappiano come si apre il terminale...

Comunque imparare a usare il terminale a un certo punto è comodo, ed è anche vero che nessuno ti costringe a usarlo se non ti va.
Esistono anche sistemi diversi, c'è chi si trova meglio con Windows, chi con BSD, chi con Linux, chi con OSX... Se non ti trovi bene con un sistema e non ti va di perderci tempo ad impararlo, tanto vale che cambi :)

[...]

(04 Ott '16, 14:51) dadexix86 ♦♦ dadexix86's gravatar image

[...]
Ho visto ora i prerequisiti. Allora... Li hai seguiti tutti quelli relativi a Ubuntu, dal punto (2) in poi?

Dall'errore che ricevi (che non esiste /etc/init.d/lpr), sembra che tu abbia saltato il punto (3) di quella guida.

Commento a latere: certo che ci si mettono proprio d'impegno!
Con HP basta che la metti dentro e fa tutto automaticamente...

(04 Ott '16, 14:52) dadexix86 ♦♦ dadexix86's gravatar image

Per punto 3 intendi dire i prereqisiti? cioè istallare le librerie?

le ho installate, ma mi ha dato risposta che sono obsolete, quindi diceva che erano state sostituite da altre, che ho installato

(04 Ott '16, 15:03) Andyzeta Andyzeta's gravatar image

ora mi chiedo, devo rifare tutto daccapo?

(04 Ott '16, 15:03) Andyzeta Andyzeta's gravatar image

No, quello in cui ti dice di creare il link simbolico

Creating a symbolic link is required before the installation (superuser authorization is required to run the command)

For Debian based distributions [...]

(04 Ott '16, 15:07) dadexix86 ♦♦ dadexix86's gravatar image

Ehm... non solo non l'ho vista e non la vedo ma non comprendo nemmeno cosa significhi... :-)

(04 Ott '16, 15:09) Andyzeta Andyzeta's gravatar image

Devi dare il comando che ti dice lì, nei Prerequisiti (nella pagina di download loro linkano dal punto (5), ma ce n'è altri 4 prima...).

(04 Ott '16, 15:15) dadexix86 ♦♦ dadexix86's gravatar image

Sai che l'ho capito adesso?

I primi 4 punti mi riguardano comunque. (Mi chiedo come potesse aver funzionato prima. Mistero.) quindi ora procedo dal punto 1 dei prerequisiti, poi avrò il problema di non aver seguito la sequenza, devo anche reinstallare il driver?

Ovvio che è l'ultima brother che entra da me. Solo hp.

(04 Ott '16, 15:18) Andyzeta Andyzeta's gravatar image

Mah, secondo me se non hai avuto altri errori prima, direi che quei comandi che non ti han dato errore sono andati a buon fine.

(04 Ott '16, 15:20) dadexix86 ♦♦ dadexix86's gravatar image

Dunque ho letto i passi precedenti. Punto 1 non è per UBuntu, lo salto

punto 2.1 mi dice così:

christian@christian-desktop:~$ sudo aa-complain cupsd [sudo] password di christian: sudo: aa-complain: comando non trovato

punto 2.2 mi dice così sudo mkdir /usr/share/cups/model mkdir: impossibile creare la directory "/usr/share/cups/model": File già esistente

punto 3 fatto.

ma non mi cambia nulla dopo. Sempre directory inesistente mi dice.

(04 Ott '16, 15:34) Andyzeta Andyzeta's gravatar image

Per aa-complain mi sa che devi installare il pacchetto apparmor-utils, che lo fornisce (no, non è installato di default. Perché non ti dicono di installarlo? non ne ho idea :S )

(04 Ott '16, 15:37) dadexix86 ♦♦ dadexix86's gravatar image

ah ah, si vede che vogliono vedere se posso farmi degli amici...

e si chiamano Brother ... figuriamoci se si chiamavano enemy :-)

vado, poi ti dico

(04 Ott '16, 15:41) Andyzeta Andyzeta's gravatar image

fatto tutto passo passo quando ho provato ad aprire etc/printcap la risposta è stata:

sudo gedit /etc/printcap

(gedit:7324): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(04 Ott '16, 15:55) Andyzeta Andyzeta's gravatar image

la nuova notizia è che ho un segnale di errore dal software updater che non va più.

mi dice anche pacchetto dcp1610wlpr:i386 da reistallare ma non c'è un archivio

(04 Ott '16, 16:25) Andyzeta Andyzeta's gravatar image

Per cui ho deciso di riformattare tutto e ripartire nel pulito.

Ho reinstallato Ubuntu 16.04 da chiavetta.

Appena aperto mi dà un messaggio di errore dicendo che alcuni pacchetti potrebbero avere dipendenze irrisolte.

(04 Ott '16, 17:57) Andyzeta Andyzeta's gravatar image

Quello di gedit è solo un warning, avrebbe dovuto aprirsi senza problemi.

Però dovresti usare gksudo o pkexec per le applicazioni grafiche, non sudo, ma son dettagli per ora trascurabili.

Il problema del software center è il pacchetto brother. L'avevi installato correttamente e completamente?

(05 Ott '16, 10:18) dadexix86 ♦♦ dadexix86's gravatar image

Si è aperto, ma quando salvo, sebbene salvi correttamente, esce quell'avviso.

Gedit quindi è una applicazione grafica?

pacchetto Brother istallato seguendo tutte le istruzioni e passi.

L'istallazione del driver è terminata con un messaggio che diceva impossibile riavviare lpd o qualcosa del genere

il driver sembra istallato ma non so per reistallarlo come fare e se devo reiniziare tutta la procedura dai prerequisiti

Grazie

(05 Ott '16, 10:28) Andyzeta Andyzeta's gravatar image

"o qualcosa del genere" non è troppo utile :)

Prova a riavviare. Funziona?
Se no, riprova tutti i passaggi della guida ma stavolta crea un pastebin con tutti gli input che dai e gli output che ricevi (fai copia-incolla) così che io possa vedere esattamente tutti gli errori e i messaggi che ricevi. (poi devi cliccare "Paste" e mettere qui il link della pagina).

(05 Ott '16, 10:47) dadexix86 ♦♦ dadexix86's gravatar image

Riavviando non ha funzionato. Ho rifatto tutta la procedura e adesso l'azione di restart per Restarting lpd (via systemctl): lpd.service ha avuto buon esito sono arrivato alla fine e ci sono problemi sulla linea di arrivo. ho il patebin che non so cosa sia né come utilizzarlo per fartelo vedere :-)

(05 Ott '16, 11:32) Andyzeta Andyzeta's gravatar image

pastebin , scusa

(05 Ott '16, 11:33) Andyzeta Andyzeta's gravatar image

Metti semplicemente qui il link :)

(05 Ott '16, 11:39) dadexix86 ♦♦ dadexix86's gravatar image

Ok, ho capito il problema. lpr non esiste più su ubuntu da tempi immemori. Ma l'installazione ti ha già riavviato lpd.

Prova a riavviare il sistema e vedere se funziona.

(05 Ott '16, 11:59) dadexix86 ♦♦ dadexix86's gravatar image

Non funziona. ora non si accede più nemmeno a http://localhost:631/printers/

il driver della 1610 non compare nell'elenco dei driver

(05 Ott '16, 12:33) Andyzeta Andyzeta's gravatar image

localhost dice connection refused

(05 Ott '16, 12:34) Andyzeta Andyzeta's gravatar image

però....

se vado nella cronologia e riapro la pagina vecchia di localhost:631/printers ... funziona. anche chiudendo e riaprendo dal browser... funziona...

(05 Ott '16, 12:38) Andyzeta Andyzeta's gravatar image

No. è l'illusione della cache ... non va il sito localhost

(05 Ott '16, 13:09) Andyzeta Andyzeta's gravatar image

per riavviarlo ho cancellato la cache. ora pare che vada

(05 Ott '16, 13:26) Andyzeta Andyzeta's gravatar image

Sta funzionando tutto? Io ho esaurito le mie conoscenze :)

(08 Ott '16, 10:50) dadexix86 ♦♦ dadexix86's gravatar image

Ciao. Purtroppo non funziona nulla. Qualche volta cups si apre dal Browser, e molte altre no.

Ti ringrazio comunque per la tua cortese sollecitudine.

(08 Ott '16, 11:06) Andyzeta Andyzeta's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×28
×13
×10

domanda posta: 30 Set '16, 14:50

domanda visualizzata: 1,172 volte

ultimo aggiornamento: 08 Ott '16, 11:06

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.