1
1

Salve ragazzi,

è possibile una cosa del genere? Mezz'ora fa dal sito di Ubuntu ho scaricato e installato la versione a 64 bit di Ubuntu 12.04.3 LTS, ma invece di avere il kernel 3.2 ho il 3.8.0-29. È possibile o mi son bevuto il cervello?

Al di là di tutto, questo kernel mi rende impossibile installare i Catalyst per la mia Ati HD4870.

$ cat /etc/issue 
Ubuntu 12.04.3 LTS \n \l

$ uname -r 
3.8.0-29-generic

Edit

Faccio un inciso e mi scuso se vado un po' fuori tema, ma così provo a farvi capire qual è il mio problema.

Ho una ATI HD4870 e per regolare la ventola ho bisogno dei Catalyst, quindi dopo vari tentativi ho capito che non posso andare oltre i Catalyst 12.4 perché questi ultimi non supportano kernel successivi al 3.2. Ho provato anche con i Catalyst Legacy 13.1 con versioni del kernel successive (ecco il perché di tutte queste installazioni), ma niente, va sempre in low graphic mode. Ho provato prima con Ubuntu Gnome 13.04, poi con la 12.04.3 versione della comunità con kernel 3.5, poi con la 12.04.3 con il kernel 3.8, ma niente. Per curiosità ho riprovato con la ISO della 12.04 (kernel 3.2) che sto usando ora con Catalyst 12.04 e non c'è stato nessun problema.

Per ora mi accontento, il sistema funziona bene, il PC ha qualche anno e probabilmente lo cambierò scegliendo una scheda grafica integrata.

L'unico problema è che non posso andare oltre al kernel 3.2.xxxx.

chiesto 21 Set '13, 22:51

Andrea%20Carpitelli's gravatar image

Andrea Carpi...
18336

modificato 22 Set '13, 12:03

enzotib's gravatar image

enzotib ♦♦
14.0k112186

@andrea-carpitelli: non usare le risposte per aggiungere ulteriori info, o usi i commenti o modifiche la domanda.

(22 Set '13, 12:05) enzotib ♦♦ enzotib's gravatar image

Canonical e comunità forniscono ogni 2 anni versioni di Ubuntu LTS (=long time support), come la 12.04 LTS appunto, che vengono supportate per 5 anni. In questi 5 anni di supporto, è garantito anche il supporto al nuovo hardware per i primi 2 anni, mentre gli aggiornamenti del sistema operativo sono garantiti per tutta la durata del supporto (link periodo di supporto Ubuntu desktop). Ora, per garantire il supporto al nuovo hardware, vengono rilasciate delle SRU di Ubuntu, come la 12.04.1, 12.04.2, 12.04.3 e 12.04.4, ad intervalli regolari. Ad eccezione della 12.04.1, tutte le altre versioni "aggiornate" dell'originale Ubuntu 12.04 portano con sé anche aggiornamento ai nuovi kernel Linux e x.org, derivati da quelli delle versioni intermedie tra una LTS e l'altra.

Per capirci:

-Ubuntu 12.10 (kernel 3.5) --> Ubuntu 12.04.2 (kernel 3.5 + nuovo x.org)

-Ubuntu 13.04 (kernel 3.8) --> Ubuntu 12.04.3 (kernel 3.8 + nuovo x.org)

Kernel e x.org aggiornati garantiscono quindi supporto a nuovo hardware. Tuttavia, se Ubuntu 12.04 viene installato dalla versione originale (o dalla 12.04.1), i nuovi kernel e x.org non verranno forniti mediante i normali aggiornamenti del sistema operativo, ma si dovrà effettuare una nuova installazione delle SRU del sistema operativo per utilizzarli (o si dovrà operare da terminale). In caso contrario si continuerà ad utilizzare il kernel 3.2.0-xx (xx=numero di revisione) ed il vecchio x.org.

Nonostante il supporto per il nuovo hardware, a volte capita che nuove versioni di Linux e x.org non permettano più l'installazione di driver proprietari, come per il caso della tua scheda grafica ATI HD4870, ma non è un problema dovuto ad x.org o ad Ubuntu in generale. Il problema sta nel fatto che la AMD ha ridimensionato il supporto per le schede grafiche delle famiglie Radeon HD 2xxx, 3xxx e 4xxx, rilasciando solo aggiornamenti "saltuari" dei driver, che non forniscono supporto alle nuove versioni di x.org e kernel Linux. Questi driver non vengono più sviluppati in maniera congiunta ai driver per le schede video più recenti (dalla serie HD 5xxx in avanti), che invece supportano x.org e kernel nuovi. Ecco perchè non puoi installare i driver catalyst per la tua scheda grafica su Ubuntu 12.04.3!!!

L'unico modo per risolvere il tuo problema, quindi, è installare Ubuntu 12.04 LTS originale oppure la 12.04.1 (meglio la seconda, ha già numerosi aggiornamenti presenti ed è più stabile) in quanto utilizzano ancora l'originale versione di x.org per Ubuntu 12.04.

Ecco la pagina dove trovare tutte le versioni di Ubuntu 12.04, basta scorrere la lista.

coll. permanente

ha risposto 23 Set '13, 08:13

alevipri's gravatar image

alevipri
5.5k1479

modificato 12 Mar '14, 18:42

Ho capito perfettamente cosa dici, spiegazione perfetta.

Quando ho visto che con la versione 13.04 e il kernel 3.5 i Catalyst 13.1 non funzionavo ho scaricato la 12.04.3 della comunità pensando che fosse uguale alla versione che avevo io, non sapendo degli aggiornamenti del kernel e di xorg. Il mio pc non "nasce" per Ubuntu, quando l'ho comprato la configurazione la scelsi per giocarci e come SO avevo Vista. L'idea di Ubuntu è venuta dopo. Terrò questo SO che funziona egregiamente finché non cambierò pc (quello di ora ha 5 anni), magari scegliendo una scheda video integrata.

(23 Set '13, 09:35) Andrea Carpi... Andrea%20Carpitelli's gravatar image

Per il momento anche io sto mantenendo la versione Ubuntu 12.04 originale, avendo come scheda grafica una ATI HD 3650, e devo dire che Ubuntu funziona benissimo con i driver proprietari installati. é veloce e non dà problemi di alcun genere. Certo, i driver proprietari catalyst per linux (almeno quelli disponibili per la mia scheda grafica) non sono comparabili a quelli disponibili per Windows, ma fanno comunque un buon lavoro e riescono a "far girare" bene anche giochi come Xonotic, Red Eclipse o 0 A.D., per citarne alcuni.

Quando uscirà Ubuntu 14.04 LTS penserò ad un aggiornamento;) ciao

(29 Set '13, 14:59) alevipri alevipri's gravatar image

Per utilizzare il kernel 3.2 lts devi fare così:

sudo apt-get remove --purge linux-generic-lts-raring linux-headers-generic-lts-raring linux-image-generic-lts-raring

sudo apt-get install linux-generic linux-headers-generic linux-image-generic

a questo punto riavvii e scegli il 3.2 al boot, dopodiché disinstalli il 3.8

sudo apt-get remove --purge linux-headers-3.8.0-29 linux-headers-3.8.0-29-generic linux-image-3.8.0-29-generic
coll. permanente

ha risposto 22 Set '13, 12:39

nico's gravatar image

nico
9833416

Ebbene sì, è così, come puoi vedere su
http://packages.ubuntu.com/precise/linux-image-3.8.0-29-generic

Sarebbe interessante vedere l'output di

apt-cache policy linux-image-3.8.0-29-generic
coll. permanente

ha risposto 21 Set '13, 23:01

enzotib's gravatar image

enzotib ♦♦
14.0k112186

modificato 21 Set '13, 23:05

Scusami, ma io sapevo che per la versione 12.04 il kernel non andava più in la dalle 3.2...
Ecco qua.
$ apt-cache policy linux-image-3.8.0-29-generic linux-image-3.8.0-29-generic: Installato: 3.8.0-29.42~precise1 Candidato: 3.8.0-29.42~precise1 Tabella versione: *** 3.8.0-29.42~precise1 0 500 http://it.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages 500 http://security.ubuntu.com/ubuntu/ precise-security/main amd64 Packages 100 /var/lib/dpkg/status

(21 Set '13, 23:05) Andrea Carpi... Andrea%20Carpitelli's gravatar image

Mah,forse gli aggiornamenti fatti, hanno installato anche il kernel v.3.8

Vedi nelle impostazioni aggiornamenti se fosse spuntata anche i proposti .

(22 Set '13, 08:15) Webber Webber's gravatar image

@Webber, ho guardato l'output di apt-cache policy apposta, il pacchetto non proviene dai proposed.

(22 Set '13, 09:17) enzotib ♦♦ enzotib's gravatar image

Ho controllato la versione del kernel subito all'inizio, dopo il primo aggiornamento. Io il kernel non lo aggiorno mai manualmente.

(22 Set '13, 10:59) Andrea Carpi... Andrea%20Carpitelli's gravatar image

Sì è corretto, essendo un lts viene supportata per 5 anni e attualmente sta usando gli aggiornamenti del pacchetto linux-image-generic del raring, di conseguenza anche i suoi relativi kernel.

coll. permanente

ha risposto 22 Set '13, 09:35

franco81's gravatar image

franco81
943612

Ok, io però ho anche una 12.04 già installata e perfettamente funzionante, che aggiornata di volta in volta, è arrivata alla versione 12.04.3 ma il kernel è sempre 3.2.0-53.

(22 Set '13, 10:57) Andrea Carpi... Andrea%20Carpitelli's gravatar image

È perchè nel synaptic hai attivo il pacchetto linux-image-generic 3.2.0.53.63, che è l'ultima versione disponibile.

(22 Set '13, 13:16) franco81 franco81's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×185
×69
×33
×4

domanda posta: 21 Set '13, 22:51

domanda visualizzata: 4,316 volte

ultimo aggiornamento: 12 Mar '14, 18:42

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.