1
1

Come da oggetto, il problema è nel reboot, mentre ha funzionato col semplice spegnimento/accensione. Che fare? Ho già appurato altre volte che Windows mi scombina sempre l'ordine di boot nello UEFI…

Il mio PC è un HP 500-413nl (un desktop) con dual boot Ubuntu 16.04.1 e Windows 10.

Voi dite che è meglio aspettare l'imminente 16.10 o il problema non si può risolvere / non è stato risolto?

(Ho già disabilitato il "Fast Startup" in Windows, il "Fast Boot" e il "Secure Boot" nel BIOS/UEFI)

chiesto 12 Ott '16, 18:20

andy-drew's gravatar image

andy-drew
55127

modificato 12 Ott '16, 21:47

Hai controllato di avere tutti gli aggiornamenti disponibili per il tuo BIOS?

(12 Ott '16, 19:17) dadexix86 ♦♦ dadexix86's gravatar image

E come faccio? :| Sul sito HP c'è una lista non corrispondente di driver per il mio PC (http://support.hp.com/it-it/drivers/selfservice/hp-pavilion-500-400-desktop-pc-series/7161732/model/7450654#Z7_3054ICK0K8UDA0AQC11TA930O2), addirittura con presenza di driver per Scheda TV, quando questo modello di PC non ne ha proprio! :\ Se installo HP Support Assistant, che dovrebbe darmi solo i driver giusti per il mio modello, questo non trova niente (programma bacato da far ribrezzo)…

(12 Ott '16, 19:32) andy-drew andy-drew's gravatar image

(togli la parentesi finale del link per vederlo)

(12 Ott '16, 19:33) andy-drew andy-drew's gravatar image

Idea: e se disabilito proprio nell'ordine di boot (nell'UEFI/BIOS) il Windows Boot Manager (tanto Windows me lo avvia col grub)? Che ne dite?

(12 Ott '16, 21:42) andy-drew andy-drew's gravatar image

Io aggiornerei il BIOS prima di tutto, già che un aggiornamento c'è...

(12 Ott '16, 21:53) dadexix86 ♦♦ dadexix86's gravatar image

Io ho paura che quell'aggiornamento su quella pagina del sito HP che ti ho linkato prima non corrisponda proprio, lì c'è scritto "Compaq etc." e il mio PC con Compaq non è, quell'elenco è pasticciato da far paura; se installo un driver sbagliato di un componente credo si blocchi tutto, parlando del BIOS, per il momento pare funzioni disabilitando il Windows Boot Manager… Comunque domani riprovo con i driver per Windows che trovo sulla pagina di Win 8.1, 7 e 10… maledizione alla HP, è tutto imbrogliato! Su Win 8.1 c'è un driver per il BIOS/UEFI che sembra corrispondere, ma è la stessa versione!

(12 Ott '16, 22:57) andy-drew andy-drew's gravatar image

Compaq è stata comparata dalla HP da qualche anno ormai, e ne produce(va) buona parte dell'hardware Desktop...

(12 Ott '16, 23:12) dadexix86 ♦♦ dadexix86's gravatar image

Ho trovato il BIOS/UEFI adatto al mio PC (ROM 2AF7), non c'entra il driver Compaq, la versione è passata dal 80.20 al 80.22, e nel frattempo è sparito "ubuntu" dall'ordine di boot… (sto scrivendo da Windows adesso)

(13 Ott '16, 17:59) andy-drew andy-drew's gravatar image

Ottimo :) Probabilmente devi ripristinare il bootloader, come spiegato sulle guide. Hai installato con UEFI o MBR?

(13 Ott '16, 20:08) dadexix86 ♦♦ dadexix86's gravatar image

UEFI, non modalità legacy; nelle guide ricordo c'era scritto che se Windows (10, in questo caso) era già installato in modalità UEFI, era meglio installare anche ubuntu in UEFI per non creare problemi.

(13 Ott '16, 20:33) andy-drew andy-drew's gravatar image

Sì, sì, è corretto. Segui la guida per il ripristino del bootloader UEFI.

(13 Ott '16, 20:35) dadexix86 ♦♦ dadexix86's gravatar image

Macché, l'UEFI non mi riconosce la pennetta col boot-repair… eppure con la stessa chiavetta ci avevo installato più di una volta Ubuntu 16.04(.1 pure). Ho usato il file "http://sourceforge.net/projects/boot-repair-cd/files/latest/download?source=files" e creando il disco d'avvio l'utility mi diceva che era un Lubuntu 14.04.1 (Trusty Tahr)… forse è per quello (troppo vecchio)?

(13 Ott '16, 22:52) andy-drew andy-drew's gravatar image

Come sospettavo: invece con la live di Ubuntu 16.10 la stessa chiavetta viene letta tranquillamente dal PC HP… Come fare per recuperare o almeno visionare i file sulla Scrivania della precedente installazione di Ubuntu (16.04.1)? Non ricordo cosa c'era (anche se erano pochissimi elementi)…

(14 Ott '16, 20:35) andy-drew andy-drew's gravatar image

Da live puoi vederli tranquillamente, basta che monti la partizione di Ubuntu.

È strano che boot repair non funzioni, perché è fatta apposta per sistemi UEFI. È possibile che il BIOS HP la blocchi di proposito, ma non ne vedo troppo il motivo... Hai disabilitato il Secure boot sì?

(15 Ott '16, 10:33) dadexix86 ♦♦ dadexix86's gravatar image

Sì, lo avevo già disabilitato prima

(16 Ott '16, 21:05) andy-drew andy-drew's gravatar image

Bene (finalmente posso dirlo!) la soluzione è risolvere il problema in Windows (10), perché è lì che sta, non in Ubuntu. Bisogna dare questo comando da un prompt come amministratore:

Bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

Spero possa servire anche ad altri ;-)

coll. permanente

ha risposto 05 Feb '17, 16:05

andy-drew's gravatar image

andy-drew
55127

(vedi prima risposta, quella di febbraio 2017, che è quella definitiva)

Ho risolto: consiglio vivamente a tutti quelli che hanno un BIOS / UEFI simile al mio di disattivare il Windows Boot Manager (nel mio caso, come scritto nelle istruzioni del BIOS, con F5) nelle impostazioni del BIOS stesso (tanto ci pensa il grub a mostrarlo se volete avviare Windows) perchè ogni santa volta che si riavvia da Windows la lista del boot order viene scombinata e "ubuntu" va all'ultimo posto. (consiglio da eseguire oltre a, come descritto prima, disabilitare il "Secure Boot" e "Fast/Quick Boot" nel BIOS e il "Fast Startup" in Windows, nelle impostazioni del risparmio energetico)

coll. permanente

ha risposto 16 Ott '16, 21:08

andy-drew's gravatar image

andy-drew
55127

modificato 05 Feb '17, 16:11

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×255
×94
×50

domanda posta: 12 Ott '16, 18:20

domanda visualizzata: 1,092 volte

ultimo aggiornamento: 09 Feb '17, 08:20

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.