Ciao a tutti

Devo installare la toolbox qutip per python. Di default, ho python2.7.12 ma se installo (con pip ad esempio) qutip, questa è alla versione più recente. Perciò ho voluto provare Python3.5 siccome è consigliato python3 . Ho impostato il PYTHONPATH, ho modificato il symlink di "python" all'eseguibile della versione 3.5. Detto questo, il mio problema è che non riesco a installare alcun pacchetto. Gli errori che mi da sono riportati sotto. So che ConfigParser è diventato configparser per python3 ma comunque non ho idea di come installare l'altro visto che non mi fa installare nulla.

Vi prego aiutatemi, non so più dove sbattere la testa, devo fare funzionare sto benedetto qutip

Configurazione di cython (0.23.4-0ubuntu5)...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: errore nell'elaborare il pacchetto cython (--configure):
 il sottoprocesso installato script di post-installation ha restituito lo stato di errore 1
Configurazione di python-numpy (1:1.11.0-1ubuntu1)...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: errore nell'elaborare il pacchetto python-numpy (--configure):
 il sottoprocesso installato script di post-installation ha restituito lo stato di errore 1
Configurazione di python-pip (8.1.1-2ubuntu0.2)...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: errore nell'elaborare il pacchetto python-pip (--configure):
 il sottoprocesso installato script di post-installation ha restituito lo stato di errore 1
Configurazione di python-pkg-resources (20.7.0-1)...
Traceback (most recent call last):                                                                                                                                                           
  File "/usr/bin/pycompile", line 35, in     <module>                                                                                                                                            
    from debpython.version import SUPPORTED, debsorted, vrepr, \                                                                                                                             
  File "/usr/share/python/debpython/version.py", line 24, in <module>                                                                                                                        
    from ConfigParser import     SafeConfigParser                                                                                                                                                
ImportError: No module named 'ConfigParser'                                                                                                                                                  
dpkg: errore nell'elaborare il pacchetto python-pkg-resources (--configure):                                                                                                                 
 il sottoprocesso installato script di post-installation ha restituito lo stato di errore 1                                                                                                  
Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports                                                                                                     
                                                                                            dpkg: problemi con le dipendenze impediscono la configurazione di python-    setuptools:                 
 python-setuptools dipende da python-pkg-resources (= 20.7.0-1); comunque:                                                                                                                   
  Il pacchetto python-pkg-resources non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto python-setuptools (--configure):                                                                                                                    
 problemi con le dipendenze - lasciato non configurato                                                                                                                                       
Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports                                                                                                     
                                                                                        Configurazione di python-wheel (0.29.0-1)...                                                         
Traceback (most recent call last):                                                                                                                                                           
  File "/usr/bin/pycompile", line 35, in     <module>                                                                                                                                            
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: errore nell'elaborare il pacchetto python-wheel (--configure):
 il sottoprocesso installato script di post-installation ha restituito lo stato di errore 1
Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di     MaxReports
                                                                                        Si sono verificati degli errori nell'elaborazione:
 cython
 python-numpy
 python-pip
 python-pkg-resources
 python-setuptools
 python-wheel
E: Sub-process /usr/bin/dpkg returned an error code (1)

chiesto 15 Ott '16, 01:38

lindi's gravatar image

lindi
2012

Qual è il comando esatto che hai dato che ti ha dato quegli errori? Versione di Ubuntu?

(15 Ott '16, 10:56) dadexix86 ♦♦ dadexix86's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×788
×170
×33
×28

domanda posta: 15 Ott '16, 01:38

domanda visualizzata: 450 volte

ultimo aggiornamento: 15 Ott '16, 10:56

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.