Buongiorno, da poco ho installato su un portatile un po' datato, Xubuntu come unico sistema operativo, cancellando definitivamente Windows 7 preinstallato. Quando ero in modalità live, il computer era silenzioso e veloce. Una volta installato, invece, anche senza fare niente parte il rumore forte delle ventole. Cosa posso fare?

Le specifiche del mio computer portatile sono: HP Pavilion g-6 (4 GB di RAM) processore 1.9 Ghz AMD Dual-Core A4-3300; scheda video AMD Radeon HD 6510G2 Dual Grafichs (1 GB DDR3 dedicata).

Non ho installato nessun driver aggiuntivo e la situazione è così:

alt text

Grazie. Saluti.

chiesto 27 Ott '16, 11:21

sabry795's gravatar image

sabry795
3535

Ciao @sabry795 è sempre Xubuntu 16.04 vero?
Da Software e aggiornamenti (immagine allegata) puoi installare un firmware per la CPU (scegli liberamente se installarlo), ma non è questo (penso) il problema.

A sentimento (potrei sbagliarmi) è la scheda grafica Radeon HD 6510G2 che funziona sempre "al massimo". Potrebbe essere causato fatto che il driverRadeon non gestisce correttamente la tua scheda video. Per rimediare esiste un metodo semplicissimo, questo

(27 Ott '16, 12:11) alevipri alevipri's gravatar image

Comunque, prima di provare ad aggiungere il parametro d'avvio radeon.dpm=1, puoi linkarci la guida che hai seguito per disabilitare il KMS (l'hai scritto qui)?

(27 Ott '16, 12:12) alevipri alevipri's gravatar image

Ok, quindi hai inserito il parametro d'avvio nomodeset al fine /etc/default/grub.
Così facendo tuttavia non vengono utilizzati i driver idonei per la tua scheda grafica, ovvero niente driver Radeon (quindi la guida che ti ho indicato precedentemente è inutile). Al contrario vengono utilizzati dei driver "generici", che non forniscono effetti grafici 3D, accelerazione hardware o alcun tipo di controllo sulle temperature e sulla gestione delle ventole.

(27 Ott '16, 13:09) alevipri alevipri's gravatar image

Ok, quindi è questa la causa del problema. Ma allora devo ripristinare come prima? Il fatto è che così il computer diventa inutilizzabile, compare il logo xubuntu e poi schermo nero, non mi fa interagire. Infatti il cambio del parametro, ho dovuto farlo inserendo la pendrive, in modalità live. Aiuto!

(27 Ott '16, 13:49) sabry795 sabry795's gravatar image

Eh questo è un problema. Si vede che questa versione del driver Radeon non funziona bene con la tua scheda grafica.
Se provi Xubuntu da live (ovvero selezioni "Prova") compare il problema? O succede solo a sistema installato?

(27 Ott '16, 14:08) alevipri alevipri's gravatar image

Infatti succede solo a sistema installato. Quando ho fatto la prova, tutto funzionava bene! Devo dire che inizialmente ho provato Ubuntu, e succedeva lo stesso, allora ho pensato che con una versione più leggera come Xubuntu non avrei avuto lo stesso problema, e invece sì!

(27 Ott '16, 14:31) sabry795 sabry795's gravatar image

@sabry795 innanzitutto complimenti, se questa è la tua prima esperienza con Linux sei già fin troppo brava.

Tornando al problema, per come la vedo io abbiamo due strade:

  • disabilitare la schermata d'avvio (il logo di Xubuntu al caricamento) per vedere se compaiono degli errori dai cui partire per tentare di risolvere il problema.
  • provare un'altra versione di Xubuntu (o un altro sistema operativo) per vedere se il problema non si presenta (il driver radeon della 14.04.1 non è lo stesso della 16.04.1, per intenderci)
(27 Ott '16, 14:34) alevipri alevipri's gravatar image

Proviamo a vedere se compaiono degli errori una volta disabilitata la schermata di avvio. È la cosa più veloce da fare.

Per farlo, ti basta seguire quando indicato qui, in particolar modo al paragrafo Rendere definitive le modifiche.

Devi semplicemente rimuovere i parametri quiet splash, salvare il file /etc/default/grub e riavviare il pc.

Se non compaiono errori, è la volta di togliere anche nomodeset.

(27 Ott '16, 14:38) alevipri alevipri's gravatar image

Trovato l'errore, mettilo in un commento qui sotto e ripristina nomodeset da live, in modo da riuscire nuovamente ad accedere a Xubuntu.

Spero di non farti impazzire con tutti questi passaggi...

(27 Ott '16, 14:39) alevipri alevipri's gravatar image

Allora eccomi qui di nuovo! Grazie per i complimenti, anche se non lo merito perché capisco metà di quello che sto facendo...

Tornando al problema, non so se ho capito bene i passaggi, comunque io ho rimosso i parametri quiet splash e ho lasciato soltanto nomodeset. Infatti, quando aggiorno il grub mi appare questo messaggio

Attenzione: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.

E qui mi sono fermata. E' un errore? Ho fatto male?

(27 Ott '16, 18:20) sabry795 sabry795's gravatar image

Il il file /etc/default/grub salvato è diventato

GRUB_DEFAULT=0 GRUB_HIDDEN_TIMEOUT=0 GRUB_HIDDEN_TIMEOUT_QUIET=true GRUB_TIMEOUT=10 GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian GRUB_CMDLINE_LINUX_DEFAULT="nomodeset" GRUB_CMDLINE_LINUX=""

Grazie e scusa ancora!

(27 Ott '16, 18:21) sabry795 sabry795's gravatar image

Buongiorno, riporto qui un aggiornamento.

Ho voluto provare e ho rimosso anche il parametro nomodeset e il computer si avvia normalmente. Addirittura mi sembra, per quel poco che lo sto usando, che le ventole facciano meno rumore. Comunque il messaggio sul terminale lo fa ancora.

Attenzione: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.

Attendo conferma. Grazie. Saluti.

(28 Ott '16, 11:26) sabry795 sabry795's gravatar image

Ciao, quindi rimuoverendo tutti e tre i parametri quiet splash nomodeset funziona tutto senza problemi?
Questa è una bella notizia!

Significa che il driver Radeon funziona a dovere, mentre il problema era dato dai parametri quiet splash.
Pertanto il parametro nomodeset non è necessario ;)

Se confermi che il problema è risolto, scrivo una risposta.

(28 Ott '16, 18:03) alevipri alevipri's gravatar image

Riguardo al messaggio:

Attenzione: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.

Ho controllato il mio file /etc/default/grub e ho notato una differenza. Il mio parametro:

#GRUB_HIDDEN_TIMEOUT=0

come vedi è preceduto da #.
Prova a fare la stessa modifica al tuo file /etc/default/grub, salva il file e riavvia. Fai sapere se risolvi.

(28 Ott '16, 18:07) alevipri alevipri's gravatar image

Ciao! Sì confermo che togliendo tutti e tre i parametri (ho lasciato solo le virgolette per capirci) funziona!

Per quanto riguarda l'altro messaggio, con questo aggiornamento mi appare anche il menù GRUB, che non è mai apparso prima.

Grazie mille per tutto!

(28 Ott '16, 18:51) sabry795 sabry795's gravatar image

@sabry795 ottimo! Ora scrivo la risposta, ricordati di accettarla ;)

(29 Ott '16, 11:42) alevipri alevipri's gravatar image

Intro

Il problema delle ventole sempre in funzione era dovuto all'introduzione di nomodeset tra i parametri di avvio, operazione che si era resa inizialmente necessaria per poter installare Xubuntu 16.04 sul PC. Difatti, una volta completata l'installazione del sistema operativo, il sistema si avviava con schermata nera e non era possibile fare nulla.
L'introduzione del parametri nomodeset aveva temporaneamente risolto il problema della schermata nera, introducendo tuttavia nuovi problemi. Con il parametro nomodeset infatti non vengono utilizzati i driver Radeon idonei per la scheda grafica AMD. Al contrario vengono utilizzati dei driver "generici", che non forniscono ne accelerazione hardware ne alcun tipo di controllo sulle temperature e sulla gestione delle ventole.

Risoluzione del problema

Per ripristinare il corretto funzionamento delle ventole si è reso pertanto necessario rimuovere il parametro nomodeset, questa volta rimuovendo anche i parametri quiet splash in modo da visualizzare eventuali errori di avvio. L'idea infatti era quella di individuare eventuali errori nell'avvio del driver Radeon, per poi cercare su internet la soluzione del problema.

Ci si è invece accorti che la rimozione di tutti e tre i parametri d'avvio consente l'avvio del PC e del driver Radeon in maniera normale, visualizzando lo schermo del pc e consentendo una gestione corretta della ventola della scheda video.

Pertanto il problema non era dovuto al driver Radeon, bensì ai parametri d'avvio quiet splash.

Per modificare i parametri d'avvio è sufficiente modificare con un editor di testo e con i privilegi di amministrazione la riga:

GRUB_CMDLINE_LINUX_DEFAULT=

del file /etc/default/grub, seguendo la procedura indicata in questa pagina wiki.

coll. permanente

ha risposto 29 Ott '16, 11:58

alevipri's gravatar image

alevipri
5.5k1479

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×242
×53
×24

domanda posta: 27 Ott '16, 11:21

domanda visualizzata: 453 volte

ultimo aggiornamento: 29 Ott '16, 11:58

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.