Buongiorno al popolo di Ubuntu; non sono un esperto in materia UNIX-UBUNTU e dopo anni mi ritrovo felicemente a riutilizzare questo OS su un vecchio PC e va come un razzo e non credo di volerlo più cambiare per nessum motivo!

Ho un solo problema: nell'ultima settimana non riesco a scaricare/installare gli aggiornamenti validi per Ubuntu 13.04 (cioè ho già la versione 13.04 ma non riesco a installare nuovi pacchetti).

I dettagli dell'operazione ve li riporto di seguito:

> installArchives() failed: (Reading database ... 
(Reading database ... 5%
...
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 283243 files and directories currently installed.)
Unpacking libwayland-client0:i386 (from .../libwayland-client0_1.2.1-1~r~gd_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_i386.deb (--unpack):
 trying to overwrite '/usr/lib/i386-linux-gnu/libwayland-client.so.0.1.0', which is also in package libwayland0:i386 1.0.5-0ubuntu1
Unpacking libwayland-server0:i386 (from .../libwayland-server0_1.2.1-1~r~gd_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_i386.deb (--unpack):
 trying to overwrite '/usr/lib/i386-linux-gnu/libwayland-server.so.0', which is also in package libwayland0:i386 1.0.5-0ubuntu1
Unpacking libwayland-cursor0:i386 (from .../libwayland-cursor0_1.2.1-1~r~gd_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libwayland-cursor0_1.2.1-1~r~gd_i386.deb (--unpack):
 trying to overwrite '/usr/lib/i386-linux-gnu/libwayland-cursor.so.0.0.0', which is also in package libwayland0:i386 1.0.5-0ubuntu1
Errors were encountered while processing:
 /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_i386.deb
 /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_i386.deb
 /var/cache/apt/archives/libwayland-cursor0_1.2.1-1~r~gd_i386.deb
Error in function: 
dpkg: dependency problems prevent configuration of libgtk-3-0:i386:
 libgtk-3-0:i386 depends on libwayland-client0 (>= 1.0.2); however:
  Package libwayland-client0:i386 is not installed.
 libgtk-3-0:i386 depends on libwayland-cursor0 (>= 1.0.2); however:
  Package libwayland-cursor0:i386 is not installed.

dpkg: error processing libgtk-3-0:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libegl1-mesa-drivers:i386:
 libegl1-mesa-drivers:i386 depends on libwayland-client0 (>= 1.2.1); however:
  Package libwayland-client0:i386 is not installed.
 libegl1-mesa-drivers:i386 depends on libwayland-server0 (>= 1.2.1); however:
  Package libwayland-server0:i386 is not installed.

chiesto 24 Set '13, 11:45

dombruno's gravatar image

dombruno
20113

modificato 24 Set '13, 12:11

marcobra's gravatar image

marcobra
8992519

Ciao a tutti ho visto che il problema affrontato è simile al mio attuale, dato che non riesco a scaricare gli aggiornamenti. Uno dei problemi che mi ritrovo è che facendo la selezione automatica del server più adatto alla mia posizione mi dice che non ci sono server disponibili e di controllare la mia connessione. Ovviamente il problema non è la connessione dato che funziona tutto perfettamente sia con wufi che con cavo, per cui immagino siano altre impostazioni. Io ho un compaq presario con ubuntu 13.04 a 64 bit e scheda grafica geforce 8200. Se qualcuno potesse darmi una mano ne sarei grato ;)

(04 Ott '14, 11:06) niccoloco niccoloco's gravatar image
1

@niccoloco: per prima cosa, non usare le risposte, usa i commenti.
Poi, la 13.04 non è più supportata, i suoi repo sono congelati e disponibili in old-releases: per istruzioni segui la risposta accettata alla seguente domanda: http://chiedi.ubuntu-it.org/questions/24579/aggiornamento-ubuntu-1304-scaricamento-delle-informazioni-non-riuscito

(04 Ott '14, 11:13) enzotib ♦♦ enzotib's gravatar image

ok grazie enzotib per la risposta tempestiva ;), vedrò di aggiornare il tutto

(04 Ott '14, 11:23) niccoloco niccoloco's gravatar image

Il problema è il repository esterno che hai aggiunto. Il responsabile del ppa ha caricato una nuova versione di wayland non considerando che alcuni pacchetti come gtk+3.0, ecc hanno bisogno di essere ricompilati, oppure nel pacchetto mancano i giusti replace/conflict.

La soluzione in questo caso è semplice, rimuovi quel ppa:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:oibaf/graphics-drivers
sudo apt-get dist-upgrade
coll. permanente

ha risposto 24 Set '13, 19:56

nico's gravatar image

nico
9833416

Ciao grazie per la risposta, allora ho provato ad eseguire la prima stringa e la risposta da terminale è : Reading package lists... Done Building dependency tree
Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: libegl1-mesa : Depends: libwayland-client0 (>= 1.2.1) but it is not going to be installed Depends: libwayland-server0 (>= 1.2.1) but it is not going to be installed libegl1-mesa-drivers : Depends: libwayland-client0 (>= 1.2.1) but it is not going to be installed Depends: libwayland-server0 (>= 1.2.1) but it is not going to be installed libgbm1 : Depends: libwayland-client0 (>= 1.2.1) but it is not going to be installed Depends: libwayland-server0 (>= 1.2.1) but it is not going to be installed libgtk-3-0 : Depends: libwayland-client0 (>= 1.0.2) but it is not going to be installed Depends: libwayland-cursor0 (>= 1.0.2) but it is not going to be installed ppa-purge : Depends: aptitude (>= 0.6.6-1ubuntu1.2) but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

credo che ci sia un ulteriore errore di installazione. Qualche suggerimento? scusa ma da terminal non so operare...

(25 Set '13, 15:27) dombruno dombruno's gravatar image

Dai:

sudo apt-get -f install ppa-purge

(25 Set '13, 18:49) nico nico's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×263
×138

domanda posta: 24 Set '13, 11:45

domanda visualizzata: 2,376 volte

ultimo aggiornamento: 04 Ott '14, 11:23

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.