installato ubuntu 16 dopo riparazione pc sony vaio vgn-z21. stampante locale non disponibile al momento dell'installazione, tentato installazione successivamente con collegamento usb. il sistema vede stampante locale (la stessa che funzionava con precedente versione ubunto 14), lascia selezionare opzioni di stampa, ma NON STAMPA. Coda di stampa vuota. Tentato upload di driver stampante HP officejet 4630, ma menù strumenti di sistema > administration NON contiene la selezione "stampanti". Sw update con stampante inserita: no esito. Comandi da terminale 'sudo apt-get update' e 'sudo apt-get upgrade' non risolvono. Please, help! 1-E' normale che il menu gnome-ubuntu non contenga 'stampanti'? 2- dovrebbe stampare con stampante generica installata? 3-come posso risolvere?

chiesto 07 Nov '16, 18:58

linusino's gravatar image

linusino
10113

@linusino, potresti per favore spiegarti meglio:

  1. Ubuntu 16 e poi??? inoltre 32 0 64 bit;
  2. pc sony vaio vgn-z21 !!! e le caratteristiche, chi vuole aiutarti deve cercarsele?
  3. sei sicuro che il pc e le porte usb dopo la riparazione funzionino?
(07 Nov '16, 19:23) enzoge enzoge's gravatar image

giusto ilgallinetta, qui i dati: - Ubuntu 16.04 LTS > kernel 4.4.0-45#66 > gcc ver. 5.4. (desktop gnome per evitare barra Unity) - PC Sony VAIO VGN-Z21MN > CPU Intel centrino 2 - X86-64 una partizione default Ext4 (Linux 83)+Swap 82 e una partizione NFTS (x Windows 7) - sì, sicuro. All'inizio (subito post installazione) funzionava, ho stampato; dopo alcuni aggiornamenti non sono più riuscito a stampare. E non trovo la voce "stampanti" nel menu' Administrator, quindi non saprei come installare il driver anche se lo trovassi (i driver Windows messi a disposizione dai costruttori delle periferiche funzionano su Linux? e come installarli?) Grazie per l'aiuto che mi vorrai dare linusino

(09 Nov '16, 21:11) linusino linusino's gravatar image

da linusino: ho risposto fornendo i dati, spero in modo esauriente, ma non c'è stato seguito. pls fammi sapere se ti servono ulteriori info per valutare se hai suggerimenti risolutivi.

(17 Nov '16, 12:30) linusino linusino's gravatar image

@linusino come scritto qui la stampante HP officejet 4630 funziona su qualunque sistema GNU/Linux con HPLIP 3.13.9 o versione successiva.
La 16.04 contiene pre-installati i driver HPLIP 3.16.3 (vedi qui), quindi la stampante dovrebbe essere riconosciuta automaticamente.

  • Controlla innanzitutto che il pacchetto hplip sia installato.
  • Non ho mai usato Ubuntu GNOME, ma non esiste il programma Stampanti?
  • Hai installato qualcosa scaricato dal sito HP?
(17 Nov '16, 13:01) alevipri alevipri's gravatar image

Se la stampante con Windows 7 funziona collegata alla USB, evidentemente funzionano.Forse potresti vedete con sudo apt autoremove di eliminare eventuali pacchetti senza tutte le dipendenze e poi, da Ubuntu software center (no Ubuntu software), installare hplip toolbox (hplip dovresti trovarlo già istallato), e vedere se con quest'ultimo funziona.

(17 Nov '16, 19:14) enzoge enzoge's gravatar image

grazie ilgallinetta, grazie alevipri, ero convinto di avere il driver per la stampante hp, di solito me lo installava automaticamente. Ho controllato è non è(non è più?) a bordo. Dal sito HPLIP ho scaricato il driver selezionando da lista, installato, ha cercato dipendenze, alla fine riconosce l'esistenza della stampante, ma NON TROVA IL FILE PPD della stampante e di conseguenza NON STAMPA. No, non c'è prg Stampanti (che era presente sulle precedenti release)

(19 Nov '16, 21:29) linusino linusino's gravatar image

@lunisino: hai provato anche con hplip toolbox?

(20 Nov '16, 07:52) enzoge enzoge's gravatar image

@alevipri era quanto sapevo, ero convinto che i driver fossero stati installati automaticamente, ma non li ho trovati: da terminale dpkg -l hplip risponde rc ..), perciò ho installato da sourceforge selezionando il driver giusto per distro-printer, ma installazione fallisce al termine ((no PPD file: error: No PPD found for model officejet_4630 using old algorithm. error: No appropriate print PPD file found for model officejet_4630_series)

coll. permanente

ha risposto 20 Nov '16, 13:35

linusino's gravatar image

linusino
10113

@ilgallinella eseguito autoremove, ha eliminato un mare di file (preoccupante), Non posso installare hplip toolbox da ubuntu software center perchè NON è presente sulla distro attuale, c'è solo ubuntu software. Provato da terminale (sudo apt-get ?) senza esito (come è nome corretto del pkg hplip toolbox?). Confermo che la precedente installazione del driver fallisce all'ultimo passo (no PPD file: error: No PPD found for model officejet_4630 using old algorithm. *error: No appropriate print PPD file found for model officejet_4630_series) malgrado a questo punto riconosca la stampante

coll. permanente

ha risposto 20 Nov '16, 13:32

linusino's gravatar image

linusino
10113

Da "Ubuntu software", tu stai usando questo, devi installare "Ubuntu software center", e li trovi sia hplip che hplip toolbox. Tieni presente che l'icona di Ubuntu software center è uguale a quella di Ubuntu software.

(20 Nov '16, 13:52) enzoge enzoge's gravatar image

Come suggerito da ilgallinetta e da alevipri: da Ubuntu software center finalmente installavo hplip e hplip-toolbox. Installato driver, riconosceva la stampante ma errore per mancanza PPD file (già segnalato). Disinstallavo ultimo driver installato 3.16.10 e sostituivo con driver 3.16.3 (come suggerito da alevipri): FUNZIONA! Problema risolto. Grazie. Come faccio a attribuire i punti di gradimento a voi che avete suggerito la soluzione? Pls replicate risposta così posso attribuire e chiudere positivamente domanda.

(02 Dic '16, 19:32) linusino linusino's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×251
×181
×10

domanda posta: 07 Nov '16, 18:58

domanda visualizzata: 926 volte

ultimo aggiornamento: 02 Dic '16, 19:32

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.