Volevo segnalare che da quando ho installato 16.04 sui miei 3 PC la condivisione di file e directory è diventata impossibile. Credo di aver installato corretamente (seguito molti tutorials) e con tutti i predecessori tutto funzionava bene. Usando windows 10 (dual boot) tutto funziona. Sono persino riuscito a collegare il MAC di mia moglie e a far dialogare tutti con tutti, compresi tablets e smartphones. Sto impazzendo! Qualcuno può cortesemente aiutarmi? Grazie in anticipo

chiesto 10 Nov '16, 10:11

frency's gravatar image

frency
45116

Stai condividendo con quale protocollo? samba? ssh? FTP?

(10 Nov '16, 10:22) dadexix86 ♦♦ dadexix86's gravatar image

Con Samba, che è quello per i meno "tecnici" e che si installa da solo quando rendi una cartella condivisa in rete.

(11 Nov '16, 09:58) frency frency's gravatar image

Ho fatto col tasto dx; uo anche installato gnome-system-tools ed usato sudo shares-admin per definire il nome della LAN. Adesso provo con questo nautilus-share, che per me è una novità. Non è citato su nessuna guida che ho trovato sul web.

(11 Nov '16, 10:03) frency frency's gravatar image

Negativo. Nautilus-share risulta già installato. Comunque, i 2 PC con 15.10 (o con Win10) condividono benissimo. Il terzo con 16.04 entra faticosamente nei primi, ma questi non possono entrare in lui. Compare il messaggio: "recupero dell'elenco delle condivisioni dal server non riuscito: connessione rifiutata". Boh!?

(11 Nov '16, 10:40) frency frency's gravatar image

A, dimenticavo. Il PC con 16.04 (in dual boot con win10), non spegne completamente tutte le periferiche USB collegate. Per ottenere uno spegnimento completo devo farlo da win10.

(14 Nov '16, 09:33) frency frency's gravatar image

Inizialmente, con la 16.04, diversi utenti hanno avuto problemi con lo spegnimento, ma con gli ultimi aggiornamenti del kernel sembra sia tutto risolto. Hai provato ad aggiornare il sistema?

(14 Nov '16, 09:54) cialu cialu's gravatar image

Ho provato eccome. Addirittura ho installato la 16.04.1 da zero. E dopo varie prove ho constatato che mi incasina la rete! Se parte per primo, gli altri PC non riescono a vedersi. Quando si vedono 16.04 entra faticosamente negli altri ma gli altri non in lui. Inoltre la vers. aggiornata a risolto parzialmente lo spegnimento dei disp.USB, perché un po funzione ed un po no. Mah!

(15 Nov '16, 10:56) frency frency's gravatar image

@frency: sperando possa esserti utile ti elenco passo passo le operazioni che ho fatto, prima di affermare che Samba con la 16.04 funziona:

  1. assegnazione dell'indirizzo IP a due PC (192.168.1.3 e 192.168.1.4) con indirizzamento all'IP del router (192.168.1.254) e DNS di google (8.8.8.8,8.8.4.4) con inserimento dei loro valori nel router, che prima aveva proxi;
  2. verifica dei collegamenti hardware con l'utilizzo del comando ping;
  3. click col destro ad entrambi i computer su una cartella da condividere, con conseguente installazione di Samba;
  4. riavvio dei sistemi;
  5. click con il destro dalla maschera del programma File, sulla voce "Connetti al server";
  6. a connessione avvenuta, sulla parte sinistra della maschera del programma File, appare la dicitura relativa al mount di ciò che mette a disposizione il PC in rete, mentre nella maschera centrale appaiono i dispositivi ed i files.
coll. permanente

ha risposto 03 Dic '16, 18:48

enzoge's gravatar image

enzoge
4.6k203987

modificato 07 Dic '16, 16:56

Tasto destro sulla cartella che vuoi condividere e selezioni l'opzione per condividere su network locale, poi setti tutti i parametri necessari nella finestra che ti si apre.

Nel caso non ti apparisse l'opzione per la condivisione su network locale, allora devi installare i pacchetti tramite:

sudo apt-get update

sudo apt-get install nautilus-share
coll. permanente

ha risposto 10 Nov '16, 15:48

cialu's gravatar image

cialu
1.1k21127

Spero di non urtare la sensibilità di nessuno, ma l'assenza di risposte mi suggerisce che 16.04 è difettoso. A ulteriore riprova c'è il fatto che non spegne correttamente la macchina (ogni volta un dispositivo diverso rimane acceso). E' con rammarico che a questo punto mi trovo a dover “retrocedere” alla 15.10 e non escludo a Win10. Grazie comunque a chiunque abbia mostrato interesse per questo mio problema che, ritengo, non sia affatto trascurabile, dato che riguarda l'affidabilità del sistema.

coll. permanente

ha risposto 28 Nov '16, 09:28

frency's gravatar image

frency
45116

@frency, a me funziona bene, è probabile che ci sia qualche impostazione da rivedere. Non so se io potrei essere all'altezza di aiutarti, ma è certo che le pochissime notizie che dai, sia sull'hardware che sul software, non invogliano molto. Credo che facendo una domanda del genere si debba almeno dire quali guide si sono seguite, se c'è un firewall, come è impostata la rete, come sono impostati i permessi ecc., ecc.. Il fatto che con Windows funzioni non vuole dire anche che sia sicura, ed il fatto che con versioni precedenti funzionasse ed ora no potrebbe significare una maggior sicurezza.

(28 Nov '16, 16:33) enzoge enzoge's gravatar image

Caro “ilgallinetta”, grazie per il tuo interessamento. Non mi sono dilungato sul HW dei miei PC perché in rete ne ho 5 diversi, win, Mac, fissi, portatile oltre a vari tablet e smartphone. TUTTO a sempre funzionato bene fino alla 15.10 compresa; tutti dialogavano con tutti anche se SO diversi. Uso U. da almeno 5 anni e imposto reti domestiche così dalla vers.14.04. I problemi sono iniziati con la 16.04. Guarda caso hanno fatto una versione 16.04.1. Come ho già spiegato, mi ha dato problemi ANCHE con spegnimento e dual boot con win10. Ecco perché mi sono scoraggiato.

(29 Nov '16, 09:08) frency frency's gravatar image

@frency, non serve che tu spieghi tutta la struttura hardware e software di tutti i tuoi PC, è sufficiente che almeno per sommi capi, dia una qualche indicazione su quello interessato al problema: la/e guide che hai seguito, come hai installato, ecc.. Anche perché da quanto dici (ANCHE spegnimento), pur non trovando indicazioni nella domanda (leggere tutti i commenti, quando non sono pochi è "impegnativo"), un qualche problema di installazione, potrebbe starci.
./.

(29 Nov '16, 11:40) enzoge enzoge's gravatar image

./.
Il fatto della versione è normale, e tu che usi U. (credo tu intenda Ubuntu) da tanto tempo, è bene che lo sappia: tutte le versioni vengono aggiornate e generalmente la xx.04.1 LTS (che avviene circa un mese dopo l'uscita della xx.04) coincide con il rilascio dell'avanzamento di versione on-line, che chi è certo della compatibilità del suo hardware e dell'eventuale software di terze parti con l'ultima release uscita, può fare in tutta tranquillità. Poi col passare del tempo arrivano anche alla xx.04.5.

(29 Nov '16, 11:47) enzoge enzoge's gravatar image

Allora, U.16.04 mi ha dato problemi di installazione su 2 pc differenti. Comunque, seguirò il tuo consiglio. Aspetto ancora un pò di tempo e poi proverò a riscaricarlo e reinstallarlo. Grazie ancora per il tuo interessamento.

(30 Nov '16, 08:20) frency frency's gravatar image

La 16.04.1 non è stata fatta per caso. Tutte le LTS hanno delle point-release che corrispondo all'uscita delle non-LTS intermedie, in cui vengono aggiornati molti pacchetti (tra cui il kernel).

Se con 14.04 funzionava, non vedo cosa ci sia di male al tenersi quella, dato che è supportata fino al 2019. Il server di ubuntu-it gira addirittura su 12.04 (che scadrà tra meno di un anno, quindi si cercherà presto di fare l'avanzamento alla 14.04).

(30 Nov '16, 21:36) dadexix86 ♦♦ dadexix86's gravatar image

Beh, la 14.04 funzionava sì. Però c'era qualche piccolo dettaglio (ognuno di noi ha le proprie manie) che ho trovato migliorato nella 15.10. Per esempio, il tastierino numerico che ha cominciato ad avviarsi automaticamente e senza problemi dalla 15.10, appunto. Per quel che mi riguarda, questa è stata l'edizione migliore. Comunque grazie per l'interessamento.

(02 Dic '16, 08:47) frency frency's gravatar image

@frency forse me lo sono perso nei tanti commenti, ma potresti specificare che mezzo di connessione utilizza la tua LAN? Ethernet, wi-fi, altro?

(02 Dic '16, 09:17) cialu cialu's gravatar image

Utilizzo rete mista wifi-Ethernet, con dispositivi diversi. Su 2 PC con chiavetta TP-Link n600, Il mac e l'HP portatile hanno la loro scheda apposita; il terzo PC ha una scheda Ethernet appunto. Poi ci sono i tablet e gli Smartphone. ribadisco: fino alla 15.10 TUTTO funzionava nonostante l'eterogeneità dei dispositivi.

(03 Dic '16, 12:16) frency frency's gravatar image

A me su Ubuntu 16.04 desktop Unity lo sharing funziona benissimo su 3 PC diversi tra 16.04 e 16.04 e anche tra 16.04 e 14.04 o 16.10. Non so con Windows perchè dopo la derattizzazione di 2 anni fa non ho più Windows in giro sul mio local network. Il 16.04 da cui scrivo è nato a marzo da una daily alpha.

(03 Dic '16, 17:17) corradoventu corradoventu's gravatar image

Vorrei risponderti ma mi limita i caratteri! Comunque proverò i tuoi consigli. Grazie

(04 Dic '16, 14:30) frency frency's gravatar image

@frency; oa l'ho convertita io in commento, ma per le comunicazioni non usare le risposte! Altrimenti succede come con la tua precedente comunicazione: "Spero di non urtare la sensibilità di nessuno", che se la si trasforma si eliminano i commenti successivi.

(04 Dic '16, 15:32) enzoge enzoge's gravatar image

Mi dava solo 10 caratteri disponibili nei commenti prima! Senti, non potremmo scambiarci le e-mail, così possiamo parlare con calma? Poi il risultato lo postiamo qui, che dici? Sono molto interessato a quello che mi spieghi, vorrei imparare!

(05 Dic '16, 14:39) frency frency's gravatar image

@frency: scusa se te lo dico, ma quando con un commento ti rivolgi a qualcuno, dovresti scrivere anche il suo nome. Se poi il nome lo fai precedere da una @, identifica l'iscritto e viene scritto in rosso. :)

(05 Dic '16, 15:53) enzoge enzoge's gravatar image

@ilgallinetta: scusa ma non sono pratico di forum. Mi sembra che tu ci capisci molto più di me. Vorrei sapere se sei disposto a seguirmi passo passo. In tal caso re-installo per l'ennesima volta 16.04 e provo a far funzionare la mia rete domestica. Intanto provo quello che mi hai già scritto. Che dici? Per prima cosa mi dovresti spiegare come si usa ping...

(06 Dic '16, 11:47) frency frency's gravatar image

@francy: penso che prima di ripetere l'installazione, dovresti provare a mettere in cantiere i suggerimenti e, nell'eventualità, accettare la risposta che ti ha suggerito la soluzione.
Io ho un'email, però, obbiettivamente penso sia meglio stare qui, dove tu puoi fare tutte le domande che vuoi e, visto che qui la platea è molto più vasta, è più probabile che tu ottenga le risposte giuste.

(06 Dic '16, 13:25) enzoge enzoge's gravatar image

@ilgallinetta: va bene, come vuoi. Però già dovresti spiegarmi cosa fare dopo il punto 6. Comunque non ho capito perché bisogna usare la voce "connetti al server". Sui precedenti la condivisione mi sembrava (parlo da non esperto) molto più semplice. Dopo aver reso condivise le rispettive cartelle sui 2 (o più) PC, il resto avveniva automaticamente.

(06 Dic '16, 14:36) frency frency's gravatar image

@frency: se tutto è andato bene al punto 6 la/e cartelle messe a disposizione della rete sono utilizzabili, come stabilito dall'amministratore del sistema. Per quanto concerne altri metodi, non saprei, io anche con i database ho sempre usato gli indirizzi IP anzi, modificando opportunamente il file Hosts, penso che anche in questi casi sia possibile utilizzare il nome dell'host, anziché l'IP.

(06 Dic '16, 15:56) enzoge enzoge's gravatar image

@ilgallinetta: ma guarda che che il metodo di condivisione che ho usato sempre e che ho descritto l'ho imparato da varie guide sul web. Comunque non appena termino la re-installazione di 16.04.1 applico tutto quanto mi hai detto e ti faccio sapere

(06 Dic '16, 16:00) frency frency's gravatar image

@frency: oltre a ribadire che era meglio che prima di installare nuovamente Ubuntu, tu provassi le operazioni che ti ho suggerito, non saprei proprio cosa risponderti. Non metto in dubbio che tu abbia sempre usato altri metodi, io ti ho solo detto come faccio e aggiungo che così funziona anche con reti eterogenee.

(06 Dic '16, 18:41) enzoge enzoge's gravatar image

@ilgallinetta: mi sono dovuto fermare già al punto 1 della tua guida perché nell'instradamento predefinito all'IP del router mi chiede la "metrica"; che gli dico? eppoi inserim. dei loro valori nel router, che prima aveva proxy; ma devo entrare nel set-up del router? Ci sono entrato ma non sono riuscito a trovare impostazione proxy o dove devo inserire i valori DNS di Google (cosa che ho fatto già per i PC)

(06 Dic '16, 19:53) frency frency's gravatar image

@frency: qui trovi qualche informazione sulla metrica.
Nella risposta ho indicato ciò che penso tu debba fare per risolvere la domanda. Non ho mai parlato di metrica, ne di "instradamento predefinito" (voce che nella 16.04 non mi risulta esserci).
Nella risposta trovi esclusivamente ciò che devi fare, se invece vuoi approfondire anche altri argomenti, o fai qui altre domande (una per argomento) o leggi guide ufficiali come questa. :)

(07 Dic '16, 07:07) enzoge enzoge's gravatar image

@ilgallinetta: ma guarda che hai detto esattamente così:"con instradamento predefinito all'IP del router (192.168.1.254) e DNS di google (8.8.8.8,8.8.4.4) con inserimento dei loro valori nel router, che prima aveva proxi". Comunque provo a proseguire e ti faccio sapere. Anche io per ora voglio solo risolvere la domanda. Poi approfondirò... comunque un altro problema è dato dal fatto che qui nella maschera di rete apparentemente non rimane "fissata" quella che gli ho dato, ma compare un 24!?!

(07 Dic '16, 12:21) frency frency's gravatar image

@ilgallinetta: allora, sono riuscito a condividere le cartelle fra tutti i PC. E questo è bene. Tuttavia nella finestra "Connetti al server/Server recenti compare la dicitura: "condivisioni Windows su 192.168.1.33 smb://192.168.1.33". Perché dice condivisioni Windows? E perché nella rete linux/ubuntu che ho creato e denominato "serra2" su cui si vedono automaticamente gli altri due PC/15.10 questo PC con 16.04 non compare? Per trovare la sua icona bisogna andare in workgroup?E perché se lancio per 1° il PC con 16.04 la rete serra2 sparisce?

(07 Dic '16, 15:14) frency frency's gravatar image

E perché il Mac compare sempre? Io ti ringrazio perché alla fine tutto ha funzionato. Ma spero che riconoscerai che prima era tutto molto più semplice. Avevo creato la rete con i comandi "sudo apt-get install samba gnome-system-tools" e "sudo shares-admin" la rete serra2, con la quale tutti i PC comunicavano automaticamente semplicemente utilizzando esplora rete

(07 Dic '16, 15:17) frency frency's gravatar image

@ilgallinetta: scusa mi ero dimenticato di mettere il tuo nome

(07 Dic '16, 15:18) frency frency's gravatar image

@frency, grazie per la precisazione, per errore ho scritto instradamento predefinito che non esiste, anziché indirizzamento. Ho corretto la risposta, togliendo anche il predefinito, per evitare confusione. Grazie ancora per la segnalazione!

(07 Dic '16, 17:03) enzoge enzoge's gravatar image

@ilgallinetta: grazie a te per l'aiuto. Concordi che le cose si sono complicate rispetto a prima?

(07 Dic '16, 17:12) frency frency's gravatar image

@frency: le attività per accedere ai dati altrui e per proteggerli sono sempre più accanite, trovo quindi piuttosto normale che alcune operazioni possano presentare maggiori difficoltà. Io ti ho detto come faccio per operare in sicurezza e tranquillità, senza pensare di escludere altri metodi, come da altre risposte.
Per i comportamenti anomali di computer con sistema operativo diverso da Ubuntu/Linux, purtroppo non sono in grado di consigliarti. Dovresti fare nuove domande, che qui su Chiedi vedendole, qualcuno potrebbe aiutarti. Oppure rivolgerti all'assistenza tecnica dei vari O.S..

(07 Dic '16, 17:26) enzoge enzoge's gravatar image

@frency: ho visto che hai votato positivamente la mia risposta. Se ritieni però che abbia risolto il problema posto con la domanda, devi accettarla in modo che altri con problemi analoghi possano beneficiare della soluzione.

(07 Dic '16, 17:33) enzoge enzoge's gravatar image

@ilgallinetta: e come faccio ad accettarla?

(07 Dic '16, 17:50) frency frency's gravatar image

@frency, per accettare una risposta bisogna spuntare la V posta sotto le mani a sinistra della risposta stessa.

(07 Dic '16, 17:56) enzoge enzoge's gravatar image

@ilgallinetta: ecco, spero di aver fatto giusto. Però non hai risposto alle mie lamentele. Se Ubuntu vuole rubare utenza a Windows deve semplificare, non complicare! Comunque grazie ancora e complimenti per le tue competenze

(07 Dic '16, 18:25) frency frency's gravatar image

@frency: tutto ok, grazie.
Le mie competenze sono quelle che sono, generalmente si sa quello che interessa ciò che si fa. Credo di poter dire che nessuno sa tutto e, come dicevo in un commento precedente, conviene usare Chiedi, proprio perché facendo una domanda, visto il numero degli utenti, è più probabile trovare qualcuno che conosca la soluzione.
Per il resto, io sono un utente come te, e non è che non voglia risponderti, semplicemente non so cosa dire ma, ammesso e non concesso che non si possa fare diversamente, fra la facilità e la sicurezza scelgo quest'ultima.

(07 Dic '16, 18:52) enzoge enzoge's gravatar image

@enopit: ma ho parlato con te? Pensavo di aver colloquiato con ilgallinetta. Comunque sto sperimentando l'utilizzo smbclient; ho l'impressione che funzioni anche questo. Che ne dici?

(12 Dic '16, 15:28) frency frency's gravatar image

@enzopit: chiedo scusa, volevo dire enzopit.

(12 Dic '16, 15:29) frency frency's gravatar image

@frency: beh, un buon bicchiere è sempre gradito!
Sono contento che la rete funzioni.
P.s. Appena scritto un commento, alla sua sinistra trovi l'icona di una matita, che cliccandola ti permette di correggere eventuali errori.

(12 Dic '16, 16:43) enzoge enzoge's gravatar image

@enzopit: ok, grazie, terrò presente

(12 Dic '16, 18:29) frency frency's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×101

domanda posta: 10 Nov '16, 10:11

domanda visualizzata: 890 volte

ultimo aggiornamento: 12 Dic '16, 18:29

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.