Non riesco a installare software da Ubuntu Software Center né da altre sorgenti. Il messaggio d'errore è:

E: La riga 18 nel file /etc/apt/sources.list non è corretta (dist parse)
E: Impossibile leggere l'elenco sorgenti

Ho aperto il file sources.list con gedit ed è il seguente:

deb http://archive.ubuntu.com/ubuntu precise main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu precise main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu precise-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu precise-updates main restricted universe multiverse

## UBUNTU SECURITY UPDATES
deb http://archive.ubuntu.com/ubuntu precise-security main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu precise-security main restricted universe multiverse

## CANONICAL COMMERCIAL REPOSITORY (Hosted on Canonical servers, not Ubuntu
## servers. RealPlayer10, Opera, DesktopSecure and more to come.)

deb http://archive.ubuntu.com/ubuntu precise-security restricted multiverse

deb http://packages.medibuntu.org/ precise free non-free
deb http://archive.canonical.com/ubuntu precise partner
deb http://www.remastersys.com/ubuntu precise main
deb http://archive.ubuntu.com/ubuntu universe
deb-src http://archive.ubuntu.com/ubuntu universe
deb http://archive.ubuntu.com precise universe
deb-src http://archive.ubuntu.com precise universe

La riga 18 sarebbe questa:

deb http://archive.ubuntu.com/ubuntu universe

Va corretta? E come?

Grazie

D

chiesto 18 Dic '16, 00:01

darmius's gravatar image

darmius
2012

modificato 18 Dic '16, 10:19

enzotib's gravatar image

enzotib ♦♦
14.0k112186


Mi pare che manchi la distribuzione, anche nella riga successiva. Invece di

deb http://archive.ubuntu.com/ubuntu universe
deb-src http://archive.ubuntu.com/ubuntu universe

dovrebbe essere

deb http://archive.ubuntu.com/ubuntu precise universe
deb-src http://archive.ubuntu.com/ubuntu precise universe
coll. permanente

ha risposto 18 Dic '16, 10:20

enzotib's gravatar image

enzotib ♦♦
14.0k112186

Non dici che Ubuntu usi, ne che versione, ne che release.
Prova così:

  1. Clicca in alto a sinistra sull'icona di Ubuntu.
  2. Nel campo di ricerca scrivi aggiornamenti.
  3. Clicca su aggiornamenti e poi su Impostazioni.
  4. Nella nuova maschera seleziona la scheda Altro software e da lì deseleziona il repository che ti da il problema.
  5. Avvia una finestra di terminale e dai il comando "sudo rm /var/lib/apt/list/* -vf".
  6. Terminato il punto 5, dai il comando "sudo apt-get update" e poi "sudo apt-get upgrade".

Prova se funziona.

Edit

Tieni anche presente che alcune versioni, nella scheda "Aggiornamenti", offrono la possibilità di stabilire il download e l'installazione di alcuni aggiornamenti.

coll. permanente

ha risposto 18 Dic '16, 08:21

enzoge's gravatar image

enzoge
4.6k183887

modificato 18 Dic '16, 09:18

La versione di ubuntu è 12.04 LTS.

  • Ho tolto la spunta a universe.
  • ho provato il punto 5, ma mi dice che il comando non trovato
  • ho fatto il punto 6. Ora posso riaprire Ubuntu Software Center, ma se provo a installare un programma dalla sorgente universe appare questo messaggio:

Scarimento delle informazioni del repository non riuscito

Dettagli:E:GPG error: http://packages.medibuntu.org precise Release: The following signatures were invalid: NODATA 1 NODATA 2

(18 Dic '16, 14:35) darmius darmius's gravatar image

Per comunicare usa i commenti.

Quale è il nome del comando che non trova?

(18 Dic '16, 14:47) enzoge enzoge's gravatar image

@darmius: cosa vuoi comunicare con il link inserito nel tuo ultimo commento?

(18 Dic '16, 15:32) enzoge enzoge's gravatar image

scusami se sono un po' lento: - il comando non trovato è "sudo rm /var/lib/apt/list/* -vf" - il link non è un link, ho solo copiaincollato il messaggio che usciva cliccando su "dettagli".

Ti ringrazio per la pazienza

(18 Dic '16, 22:31) darmius darmius's gravatar image

@darmius: se non trova sudo è perché, o non è installato, o l'utente utilizzato non ha i permessi di amministrazione.
Ubuntu 12.04 da dove lo hai scaricato?

(19 Dic '16, 07:26) enzoge enzoge's gravatar image

@enzopit: installato all'acquisto del pc.

(19 Dic '16, 09:49) darmius darmius's gravatar image

Beh, visto che ad aprile 2017 la 12.04 non sarà più supportata ne aggiornata, fossi in te scaricherei la 14.04 o la 16.04 che sono anch'esse LTS e, dopo aver provato tulle le funzionalità del sistema (connessioni internet comprese) con il DBD o la USB in modalità prova, e dopo aver fatto un bel backup, installerei quella prescelta.

(19 Dic '16, 11:23) enzoge enzoge's gravatar image

Qualche tempo fa avevo provato a installare la 14.04, ma mancava qualcosa nella macchina (tipo scheda grafica obsoleta). A questo punto credo mi convenga farmi fare (daun tecnico) un upgrade di tutto il pc. Ti ringrazio

(19 Dic '16, 12:03) darmius darmius's gravatar image

Siccome oggigiorno i computer, oltre a costare meno, hanno il firmware UEFI (anziché il BIOS) e il Secure Boot, per il quale Ubuntu è certificato; se ne acquisti uno nuovo, prima dell'acquisto, prova tutti i componenti con il DVD o la USB (i commercianti preferiscono il DVD) in modalità prova.

(19 Dic '16, 12:55) enzoge enzoge's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×9

domanda posta: 18 Dic '16, 00:01

domanda visualizzata: 309 volte

ultimo aggiornamento: 19 Dic '16, 12:55

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.