Salve,

da qualche tempo grub non si carica piu' al primo boot.

Ho un sistema win8.1 e ubuntu 14.04.

L'unico modo in cui riesco ad accedere ad ubuntu e':

  • accendo il pc
  • press ESC
  • press F9 ..enter boot manager
  • select ubuntu
  • grub appare (con opzioni ubuntu e windows)
  • seleziono ubuntu
  • ubuntu parte

Altrimenti il computer parte automaticamente con win8.1.

Le uniche cose che ho fatto sono updates di win8.1 e updates di ubuntu, cose che faccio regolarmente.

Mi sono letto un po di cose a riguardo, uefi non uefi .. ma e' tutto molto caotico. Nota: il mio dual-boot ha funzionato per anni e poi qualcosa e' andato storto.

Ho provato anche ad usare boot-repair ma senza risultati.

Qual'e' la causa di tutto cio' e come posso fare per far si che grub ritorni come era? Nota: se non premo ESC per tempo devo aspettare che win8.1 si carichi, spegnere il pc, rimuovere la batteria, poi posso riaccendere il laptop.

Qui boot-repair logs del mio sistema:

http://paste.ubuntu.com/24850682/

Grazie

chiesto 13 Giu '17, 21:12

jhon_marco's gravatar image

jhon_marco
2013

Probabilmente succede dopo che Windows, generalmente in chiusura del sistema, esegue degli aggiornamenti. "Pensa che tutti vogliano usare solo Windows, fa parte del suo DNA" e, infischiandosene di come è strutturato il sistema, predispone l'EFI all'avvio automatico del solo Windows.

Se usi tanto Windows probabilmente la soluzione migliore e quella che elenchi e che, per la precisione, potrebbe differire da pc a pc, a seconda del modello.

Ubuntu non danneggia l'avvio di altri sistemi, anzi, con tutta probabilità l'avvio potrebbe sistemarsi, dopo un aggiornamento di Ubuntu completo di kernel.

(14 Giu '17, 07:35) enzoge enzoge's gravatar image

Grazie enzoge per la risposta, ho risolto.

Ho letto il seguente post - https://chiedi.ubuntu-it.org/questions/17445/boot-repair-non-ripristina-il-grub

Da li ho trovato link a queste wiki:

https://wiki.ubuntu-it.org/AmministrazioneSistema/Uefi?action=show&redirect=Installazione%2FUEFI

https://wiki.ubuntu-it.org/Hardware/DispositiviPartizioni/Partizioni

Da cui ho capito che il mio sistema:

  • ha una partizione di ripristino nascosta di windows (sda1)
  • partizione UEFI (sda2)
  • win 8.1 e' installato in EFI mode
  • ubuntu e' installato in EFI mode
  • il sistema usa partizionamento GTP
  • ho ricontrollato che win8.1: disable legacy
  • ho ricontrollato che win8.1: disable secure boot
  • ho ricontrollato che win8.1: disable fast boot

Una volta capito e confermato quanto sopra, ho spento tutto. Avviato ubuntu dal mio disco rigido, reinstallato GRUB bootloader in UEFI mode (grub-efi) usando boot-repair selezionando "Backup and rename the Windows EFI files option" e anche "Purge GRUB before reinstalling it" e facendo attenzione a specificate "grub location" (nel mio caso /sda6).

Ho preso spunto da risposta, opzione 2 a questo post - https://askubuntu.com/questions/327676/dual-boot-menu-with-ubuntu-and-windows-8-not-showing-up

In fine per riarrangiare la grub list ho installato Grub Customizer - https://launchpad.net/~danielrichter2007/+archive/ubuntu/grub-customizer

Fatto i necessari cambiamenti e adesso GRUB e' tornato! Ad ogni avvio e senza bisogno di premere svariati tasti, con una semplice freccia posso scegliere ubuntu o windows.

Se puo' esser di aiuto questo e' il boot-repair logs del mio sistema dopo essere stato riparato - http://paste.ubuntu.com/24856876/

Un ultima domanda: ora ho due opzioni per lanciare windows ma non so quale sia la differenza tra:

  • far partire win con bootmgfw.efi
  • far partire win con bootx64.efi
  • inoltre l'opzione windows recovery sembra essere sparita

Spero possa esser utile a qualcuno,

Grazie

coll. permanente

ha risposto 15 Giu '17, 13:16

jhon_marco's gravatar image

jhon_marco
2013

Sono contento che tu abbia risolto, e a tale proposito dovresti accettare la tua stessa risposta, in modo che possa tornare utile ad altri. Per quanti riguarda il tuo problema con Windows, personalmente non saprei darti suggerimenti, ma credo ti convenga chiedere all'assistenza Windows.
Per quanto riguarda la mia risposta, che commuto in commento, volevo dire che ho notato più volte simili comportamenti da parte di Windows, da lì il consiglio,in caso di uso frequente dello stesso, di continuare ad usare il pc come stavi facendo, per evitare di perdere tempo nel riparare ogni volta il GRUB.

(16 Giu '17, 08:12) enzoge enzoge's gravatar image

Grazie enzoge. Ritengo cmq che questo non debba succedere. Non ho avuto problemi per quasi due anni. Deve essere proprio l'aggiornamento di win8 a win8.1, quindi per un altro po dovrei stare tranquillo.

(16 Giu '17, 11:36) jhon_marco jhon_marco's gravatar image

Credp che questo problema, in alcuni casi, riguardi pc EFI.

(16 Giu '17, 15:35) enzoge enzoge's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×268
×209
×27
×21

domanda posta: 13 Giu '17, 21:12

domanda visualizzata: 401 volte

ultimo aggiornamento: 16 Giu '17, 15:35

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.