Mentre provo a fare l'aggiornamento compare sempre "manca l'intestazione "Package".

Ubuntu 17.04 ubuntu 4.10.0-22-generic x86_64

chiesto 21 Giu '17, 21:48

frizzy93's gravatar image

frizzy93
202

modificato 22 Giu '17, 15:33

Così non si capisce, prova a postare gli output di questi, uno alla volta

sudo apt-get update
sudo apt-get upgrade

Allegali qui https://paste.ubuntu.com/ Compila i campi e poi posta qui il link che ti crea

(21 Giu '17, 21:52) anonimo09 anonimo09's gravatar image

ciao , grazie per la risposta , comunque quando ho messo l'upgrade compare " : Campo non valido nel file delle preferenze /etc/apt/preferences.d/multiarch-libgcc1, manca l'intestazione "Package""

(21 Giu '17, 21:55) frizzy93 frizzy93's gravatar image

Problema che non ho mai visto, io non ho nessun file in quella directory,questo cosa risponde?

cat -n /etc/apt/preferences.d/multiarch-libgcc1

Che versione di Ubuntu usi? posta anche

lsb_release -ds && echo $DESKTOP_SESSION && uname -rm
(21 Giu '17, 22:36) anonimo09 anonimo09's gravatar image

cat -n /etc/apt/preferences.d/multiarch-libgcc1

1 -e Package: libgcc1:i386 2 Pin: version 1:4.9.2* 3 Pin-Priority: 500

lsb_release -ds && echo $DESKTOP_SESSION && uname -rm

Ubuntu 17.04 ubuntu 4.10.0-22-generic x86_64

(21 Giu '17, 22:42) frizzy93 frizzy93's gravatar image

prova a editare il file

sudo -H gedit /etc/apt/preferences.d/multiarch-libgcc1

e modificalo così

Package: libgcc1:i386
Pin: version 1:4.9.2*
Pin-Priority: 500

salva e riprova update e upgrade

(21 Giu '17, 23:07) anonimo09 anonimo09's gravatar image
  • (gedit:6064): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-position non supportata
(21 Giu '17, 23:11) frizzy93 frizzy93's gravatar image

ma il file si è aperto comunque e l'hai modificato?

(21 Giu '17, 23:21) anonimo09 anonimo09's gravatar image

Non è che hai seguito qualche guida in rete?

Mi pare una cosa anomala su Ubuntu file in quella directory, mai visti di default.

Comunque, o modifichi il file come ti dicevo, che cè quella "-e" alla prima riga e non riconosce "Package:"

Oppure lo rimuovi direttamente, se è una cosa di cui non sai nemmeno perchè è lì (per la mia esperienza su Ubuntu non ci dovrebbe essere niente di default) per rimuoverlo

sudo rm /etc/apt/preferences.d/multiarch-libgcc1

e poi

sudo apt update && sudo apt upgrade
(21 Giu '17, 23:37) anonimo09 anonimo09's gravatar image

sudo rm /etc/apt/preferences.d/multiarch-libgcc1

rm: impossibile rimuovere '/etc/apt/preferences.d/multiarch-libgcc1': File o directory non esistente

(22 Giu '17, 00:53) frizzy93 frizzy93's gravatar image

sudo apt update && sudo apt upgrade

37 pacchetti possono essere aggiornati: eseguire "apt list --upgradable" per vederli.

È utile eseguire "apt --fix-broken install" per correggere ciò. I seguenti pacchetti hanno dipendenze non soddisfatte: libgcc1:i386 : Dipende: libc6:i386 (>= 2.2.4) ma non è installato libgcrypt20:i386 : Dipende: libc6:i386 (>= 2.15) ma non è installato libgpg-error0:i386 : Dipende: libc6:i386 (>= 2.15) ma non è installato

(22 Giu '17, 00:54) frizzy93 frizzy93's gravatar image

E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).

(22 Giu '17, 00:54) frizzy93 frizzy93's gravatar image

Dai

sudo apt install -f

E posta tutto l'output sul link che ti ho messo al primo commento

(22 Giu '17, 06:11) anonimo09 anonimo09's gravatar image

Scusate, nella domanda non potreste aggiungere di quale sistema operativo si tratta? Senza che per saperlo uno debba leggersi i commenti!

(22 Giu '17, 08:21) enzoge enzoge's gravatar image

Deve aggiungerlo @frizzy93 , io con i miei punti non posso fare niente

(22 Giu '17, 08:31) anonimo09 anonimo09's gravatar image

Si @prezzemolo, lo so e ti chiedo scusa se ho scritto al plurale. Personalmente ho corretto la domanda mettendo le maiuscole, il punto alla fine e correggendo i verbi.
Ora tocca a chi l'ha fatta aggiungere la versione, che, per inciso, va sempre indicata nella domanda; altrimenti chi ha lo stesso problema, non capisce e soprattutto non la segue. È per questo che regolamento e manuale spiegano come fare i quesiti!

(22 Giu '17, 08:46) enzoge enzoge's gravatar image

sudo apt update Lettura elenco dei pacchetti... Fatto E: Impossibile impostare il blocco /var/lib/apt/lists/lock - open (11: Risorsa temporaneamente non disponibile) E: Impossibile bloccare la directory /var/lib/apt/lists/

(26 Giu '17, 20:54) frizzy93 frizzy93's gravatar image

ti avevo chiesto un altro comando, non l'update

sudo rm /var/lib/apt/lists/lock

e poi posta il comando che ti avevo detto

sudo apt install -f
(26 Giu '17, 21:09) anonimo09 anonimo09's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×18

domanda posta: 21 Giu '17, 21:48

domanda visualizzata: 156 volte

ultimo aggiornamento: 26 Giu '17, 21:09

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.