Salve! Ho da poco installato Ubuntu versione 17.04 con macchina virtuale. Volevo però utilizzare Gnuplot ma non sono riuscito. Quando digito sul terminale gnuplot, mi avvisa di digitare "sudo apt install <PACCHETTO SELEZIONATO". Ho provato con tutti i pacchetti (tra cui gnuplot-now, gnuplot-x11...) ma ogni volta mi appare questa scritta: Lettura elenco dei pacchetti...Fatto Generazione albero delle dipendenze Lettura informazioni sullo stato... Fatto E: Impossibile trovare il pacchetto gnuplot-nox (per esempio).

Ho provato a inserire altri comandi per l'installazione di gnuplot da terminale trovati su internet, ma niente. Sarei grato se qualcuno potesse essere tanto gentile da aiutarmi. Vi ringrazio in anticipo!

chiesto 28 Giu '17, 19:46

lucar's gravatar image

lucar
29114

modificato 29 Giu '17, 10:11

@lucar: a corredo di qualche versione di Ubuntu gnuplot non è contemplato, per cortesia, puoi correggere la domanda, inserendo la versione di Ubuntu, come del resto indicato nel manuale.

(29 Giu '17, 08:22) enzoge enzoge's gravatar image

Nn conosco il software in questione, ma nei repo delle release supportate è presente

https://packages.ubuntu.com/search?keywords=gnuplot

Tu che versione hai di Ubuntu? Posta l'output

lsb_release -ds && echo $DESKTOP_SESSION && uname -rm
(29 Giu '17, 09:13) anonimo09 anonimo09's gravatar image

@prezzemolo @enzoge versione 17.04

(29 Giu '17, 10:16) lucar lucar's gravatar image

Come scritto nel link che ti ho messo prima, i pacchetti ci sono su 17.04 fai un update

sudo apt update

E allega il risultato, tutto qui

https://paste.ubuntu.com

Che vediamo cosa dice, compila tutti i campi e poi allega il link che ti crea

(29 Giu '17, 10:38) anonimo09 anonimo09's gravatar image

@lucar: per cortesia per comunicare usa i commenti.

(29 Giu '17, 12:03) enzoge enzoge's gravatar image

@prezzemolo. Non riesco a fare l'aggiornamento, mi dà alcuni errori. Non riesce a recuperare e risolvere it.archive.ubuntu.com, security.ubuntu.com .. Ma poi scrive che tutti i pacchetti sono stati aggiornati e infine che è impossibile scaricare alcuni file di indice: saranno ignorati o usati quelli vecchi. Perdonami, ma non sono per niente esperto.

(29 Giu '17, 14:14) lucar lucar's gravatar image

Devi postare l'output come ti ho detto altrimenti non si può capire, pare un problema sul server IT , cambia server, dai

sudo software-properties-gtk

E alla scheda "software per Ubuntu" seleziona server principale alla voce "scaricare da" fatta la modifica, chiudi la finestra e dai l'update

sudo apt update

E postalo tutto, come ti dicevo prima su paste ubuntu

(29 Giu '17, 14:24) anonimo09 anonimo09's gravatar image

@prezzemolo devo essere connesso a internet ma non riesco. Grazie mille del tempo perso per me ma non penso di essere in grado di riuscire a far funzionare le cose.

(29 Giu '17, 14:35) lucar lucar's gravatar image

Se vuoi nstallare qualcosa devi per forza essere connesso

(29 Giu '17, 15:01) anonimo09 anonimo09's gravatar image

L'installazione di Gnuplot, volendo, è possibile farla in modalità grafica con Ubuntu 16.04 LTS, previa installazione di "Ubuntu software center" (da non confondere con il nuovo Ubuntu software); mentre con la versione 17.04, non è possibile installare "Ubuntu software center", è solo possibile installare "LUbuntu software center".
Si fa così:

  1. dopo aver installato ed aggiornato la 16.04, si avvia Ubuntu software;
  2. dopo aver selezionato la voce "Tutto" dalla maschera di Ubuntu software, si imposta "Ubuntu software center" nel campo di ricerca;
  3. individuata la voce "Ubuntu software center", si procede all'installazione;
  4. ad installazione terminata, si chiude la maschera di Ubuntu software e si clicca sull'icona di Ubuntu, in alto a sinistra e nel campo di ricerca che appare si imposta Ubuntu software center, per poi cliccarne l'icona per avviarlo;
  5. nel campo di ricerca della maschera di "Ubuntu software center" si scrive Gnuplot e, individuato il software, si installa.
coll. permanente

ha risposto 29 Giu '17, 11:51

enzoge's gravatar image

enzoge
4.6k213987

modificato 29 Giu '17, 11:54

Ma se non si vede prima se ha problemi o se nn ha fatto update dei pacchetti disponibili non lo installa comunque, a lui dice che non esiste, se non esiste per apt non esiste nemmeno per software.

Verificato come da link che ho messo che i pacchetti sono nei repo, se non li trova, bisogna verificare l'update e n caso il source.list che sia ntegro con tutti i repo.

E poi qui si sta parlando di 17.04 , a che serve spiegare per 16.04?

(29 Giu '17, 11:56) anonimo09 anonimo09's gravatar image

E poi qui si sta parlando di 17.04 , a che serve spiegare per 16.04?
@prezzemolo: forse ti è sfuggito che ho scritto che (volendo) si può anche fare così, come ho poi spiegato!

(29 Giu '17, 13:47) enzoge enzoge's gravatar image

Non mi è sfuggito, ma visto che la domanda verte su 17.04, tutta la parte che riguarda 16.04 e Ubuntu software center era evitabile, visto proprio il fatto che su 17.04 non è installabile.

Come eviterei anche l'installazione di Lubuntu Software Center su 17.04 , piuttosto se vuole un gestore grafico affidabile (a differenza di Software) consiglierei synaptic

(29 Giu '17, 15:38) anonimo09 anonimo09's gravatar image

@prezzemolo: verissimo, hai perfettamente ragione; ho parlato della 16.04 perché le LTS mi danno più affidamento e perché, dopo tanti tentativi senza risultati, forse quella soluzione non era malvagia.

(29 Giu '17, 16:31) enzoge enzoge's gravatar image

@lucar: ti ringrazio per l'extra, però per non decurtare i tuoi punti, quando ti ricapita, ti conviene usare le manine che sono sulla sinistra di domande e risposte.

(29 Giu '17, 16:40) enzoge enzoge's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×776
×137

domanda posta: 28 Giu '17, 19:46

domanda visualizzata: 1,112 volte

ultimo aggiornamento: 29 Giu '17, 16:40

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.