Ciao a tutti, ho un dell xps 9360 con ubuntuu 16.04. Il comando sudo-s mi riporta la seguente riga di comando:

sudo: impossibile risolvere l'host lorenzoxps

e dopo mi fa inserire la password. Qualcuno sa come risolvere?

chiesto 02 Lug '17, 09:52

lorenzooo's gravatar image

lorenzooo
4526

@lorenzooo: fra sudo e -s devi mettere uno spazio. La password è la stessa dell'utente.

(02 Lug '17, 10:29) enzoge enzoge's gravatar image
1

Posta

cat /etc/hosts

E

cat /etc/hostname
(02 Lug '17, 11:51) anonimo09 anonimo09's gravatar image

Dai

sudo gedit /etc/hosts

Cancella

127.0.1.1 lolli-XPS-13-9360

E incolla

127.0.1.1 lorenzoxps

Fatta la modifica, salva e chiudi il file, in caso prova anche un riavvio.

coll. permanente

ha risposto 02 Lug '17, 14:10

anonimo09's gravatar image

anonimo09
(sospeso)

il primo comando mi da:

127.0.0.1 localhost

127.0.1.1 lolli-XPS-13-9360

The following lines are desirable for IPv6 capable hosts ::1 ip6-localhost ip6-loopback

fe00::0 ip6-localnet

ff00::0 ip6-mcastprefix

ff02::1 ip6-allnodes

ff02::2 ip6-allrouter

il secondo comandi mi dà questo:

lorenzoxps

(02 Lug '17, 14:00) lorenzooo lorenzooo's gravatar image

ora non mi da più problemi, grazie ancora prezzemolo!

(02 Lug '17, 14:14) lorenzooo lorenzooo's gravatar image

Non c'è di che, però accetta anche la risposta, così resta marcata come risolta, ciao

(02 Lug '17, 14:46) anonimo09 anonimo09's gravatar image

@lorenzooo: da quello che vedo c'erano 2 utenti, lolli-XPS e lorenzoxps. Ciedo se lorenzoxps e stato creato dopo e senza i permessi di amministrazione?

(02 Lug '17, 14:50) enzoge enzoge's gravatar image

nono sono stato io che ho smanettato non essendo esperto in materia

(02 Lug '17, 14:51) lorenzooo lorenzooo's gravatar image

Beh! Uno che ha usato sudo per correggere il file hosts quando con quell'utente non riusciva ad usarlo, non è davvero inesperto. Complimenti!

(02 Lug '17, 15:31) enzoge enzoge's gravatar image

@lorenzooo: forse non mi sono spiegato bene! Per cortesia puoi spiegarmi come può un utente che non può usare il comando "sudo", usarlo per correggere il file hosts?

(03 Lug '17, 12:33) enzoge enzoge's gravatar image

I comandi da root con sudo li poteva usare, altrimenti, come dovresti aver visto in questa discussione, non avrebbe nemmeno potuto editare il file, o come nell'altra sua discussione , fare gli aggiornamenti.

Era un warning, per il fatto che non c'era il suo utente in /etc/hosts, ma altro utente, probabilmente ha cazzeggiato troppo con il sistema.

Non era un problema ad usare sudo in sé, il file viene creato automaticamente dal sistema con l'utente inserito

@lorenzooo rinnovo l'invito, quando ti riconnetti ad accettare la risposta, utile anche ad altri utenti in caso di stesso problema

(03 Lug '17, 13:06) anonimo09 anonimo09's gravatar image

@prezzemolo: grazie per il chiarimento, perché a prima vista sembrava quasi l'aver autorizzato un utente sprovvisto dei permessi di amministrazione.
Lo spazio fra sudo e -s, manca ancora!

(03 Lug '17, 13:26) enzoge enzoge's gravatar image

Io gli suggerirei di cambiare il titolo così, mi pare più appropriato

sudo: impossibile risolvere l'host

Il problema era ogni volta che usava i comandi con sudo

(03 Lug '17, 13:34) anonimo09 anonimo09's gravatar image

@prezzemolo: non saprei, perché con l'utente lolli-XPS-13-9360 non mi sembra ci fossero problemi.
Lo spazio non manca nel titolo, manca nel testo della domanda.

(03 Lug '17, 13:44) enzoge enzoge's gravatar image

Era proprio quello il problema, lui in /etc/hosts aveva lolli-XPS, ma ci doveva essere il nome del suo utente, quello che si vede in /etc/hostname cioè lorenzoxps, file /etc/hosts che il sistema crea in automatico, per questo dicevo che qualcosa deve aver fatto, il file non si modifica da solo

Il titolo più giusto, se si vuole essere utili ad altri utenti, è quello che gli suggerivo

(03 Lug '17, 13:54) anonimo09 anonimo09's gravatar image

Infatti! Chissà se reinstallando sudo oltre ad abilitare lolli-XPS-13-9360 avrebbe abilitato anche l'altro. L'hostname non mi sembra determinante.

(03 Lug '17, 14:10) enzoge enzoge's gravatar image

Non c'entra niente reinstallare sudo, era l'utente in /hosts sbagliato, molto probabilmente, non ha nemmeno un utente lolli-XPS-13-9360

Per me la cosa è chiusa qui, inutile dilungarsi con ipotesi strane.

(03 Lug '17, 14:14) anonimo09 anonimo09's gravatar image

Certo è che anche in queste cose è tutto relativo. In quanto all'inutilità di dilungarsi, mi trovi d'accordo!
Ciao.

(03 Lug '17, 14:20) enzoge enzoge's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×147

domanda posta: 02 Lug '17, 09:52

domanda visualizzata: 381 volte

ultimo aggiornamento: 03 Lug '17, 14:20

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.