Ciao a tutti, premettendo che sono davvero un principiante totale, ho cmq installato da DVD Lubuntu 17.04 su un vecchio Toshiba Portege M300. L'installazione è andata a buon fine, (il pc prima stava soffocando con win 7) ma nonostante i numerosi tentativi non riesco in alcun modo a connetterlo a internet, ne tramite wi-fi, ne tramite cavo Ethernet (ho Fastweb come provider). Ho letto varie discussioni e da quello che ne posso capire potrebbe trattarsi dei driver della scheda di rete, o forse del protocollo Wi-Fi obsoleto ma non lo so con certezza e comunque non saprei come installarli. Fatto sta che nonostante rilevi la mia rete e nonostante io abbia più volte inserito la password, il Pc rimane offline, anche con il cavo Ethernet inserito direttamente nel router. Ho anche provato a cercare di trafficare un po' con i comandi a terminale ma non sapendo dove mettere le mani e cosa cercare è stato inutile. Qualcuno può aiutarmi? Grazie mille in anticipo!

chiesto 05 Ago, 16:35

voltaic1701's gravatar image

voltaic1701
2012

Che scheda di rete hai? Se hai una broadcom segui questa guida:

https://wiki.ubuntu-it.org/Hardware/DispositiviSenzaFili/Broadcom

(14 Ago, 12:02) giosuelupato giosuelupato's gravatar image

Prova da terminale a dare

sudo leafpad /etc/NetworkManager/NetworkManager.conf

nel file che si apre dopo le voci presenti,aggiungi anche

[device]
 wifi.scan-rand-mac-address=no

Salva,chiudi,riavvia

coll. permanente

ha risposto 06 Ago, 09:55

Webber's gravatar image

Webber
3.0k1535

modificato 06 Ago, 09:56

Ciao, allora intanto grazie mille davvero per la risposta! Ho fatto come hai detto tu, mi si è aperto un file testuale e ho aggiunto il comando che mi hai scritto, ma quando provo a salvarlo sovrascrivendo il file mi dice: "impossibile aprire il file per la scrittura", è un problema di permessi? Cosa posso fare?

(06 Ago, 11:16) voltaic1701 voltaic1701's gravatar image

Da terminale dai

sudo apt-get update

poi

sudo apt-get install gksu

Ora prova ad aprire di nuovo il file stavolta con gksudo

gksudo leafpad /etc/NetworkManager/NetworkManager.conf

modificando come da risposta sopra

(06 Ago, 12:18) Webber Webber's gravatar image

Allora, ho capito che il problema era che non digitavo "sudo" prima delle istruzioni che mi hai detto di imputare, mi chiedeva la password, e non capivo che la scriveva anche senza mostrarmela.....vabbè come detto sono poco pratico.....

Cmq, sono riuscito a fare ciò che mi hai detto nella tua prima risposta, ho aperto il file testuale del network manager e ho copiato all'interno:

[device] wifi.scan-rand-mac-address=no

Ho poi salvato, riavviato il PC, e ritentato di aprire il browser, ma niente, non è riuscito a caricare nulla. Ho anche provato ad andare in "edit connections", per rimuovere e poi riselezionare la mia rete wi-fi reinserendo la pw, ma continuo ad essere off-line, hai qualche altra idea? Grazie ancora

(07 Ago, 18:45) voltaic1701 voltaic1701's gravatar image

Prova a connetterti ad un'altra rete (semmai anche hotspot-cellulare)

Prova anche in network manager-modifica connessioni seleziona la tua rete poi modifica quindi in impostazioni ipv6 sia impostato su ignora

Poi da terminale dai

sudo lshw -c network

Copia incolla il risultato su http://paste.ubuntu.com/

e posta il link su chiedi nella tua risposta

(usa il tasto aggiungi commento per postare su chiedi )

(08 Ago, 12:52) Webber Webber's gravatar image

Ciao, ho fatto come mi hai detto, ipw6 l'ho impostato su ignora, e ho inserito il comando a terminale, ecco il risultato:

rodrigo@Rod-Laptop:~$ sudo lshw -c network

[sudo] password for rodrigo:

Segmentation fault (core dumped)

rodrigo@Rod-Laptop:~$

L'ho incollato sul link che mi hai indicato, ma a parte farmi incollare il testo, cliccare su paste e poi generare lo stesso testo spaziato, non mi ha fatto fare altro, non c'era il tasto aggiungi commento, forse ho sbagliato qualcosa? Al momento ovviamente sto scrivendo da un PC con windows 10 e usando una penna usb per trasferire e riportare le istruzioni all'altro PC.

(08 Ago, 21:47) voltaic1701 voltaic1701's gravatar image

Avevi provato la connessione da live prima di installare ?

Prova a dare il comando da terminale

lspci -knn | grep Net -A3

e posta direttamente su chiedi

(09 Ago, 18:56) Webber Webber's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×371
×280
×254
×112
×15

domanda posta: 05 Ago, 16:35

domanda visualizzata: 622 volte

ultimo aggiornamento: 14 Ago, 12:02

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.