Salve a tutti gli smanettoni

Ho un Pc blablabla con schermo 19 pollici widescreen 16:10 e ubuntu gnome 16.04 LTS. Ho impostato da terminale la risoluzione predefinita con ris_pred a 1440x900_60.00 ma ogni volta che accendo il pc devo dare da terminale il comando succitato perchè non riesco a salvare le impostazioni di risoluzione come predefinite.

Ho cercato un po in giro nel forum ma non ho trovato niente, ho capito però che non è una cosa semplice. qualcuno sa muoversi e vuole darmi una mano??

Grazie

chiesto 15 Ott '17, 16:48

hodoeporicus's gravatar image

hodoeporicus
40713

modificato 17 Ott '17, 15:44

cialu's gravatar image

cialu
1.1k21629

Marca e modello del monitor?

(15 Ott '17, 16:58) dadexix86 ♦♦ dadexix86's gravatar image

philips 190CW8FB/00 19 pollici widescreen 16:10

(16 Ott '17, 20:08) hodoeporicus hodoeporicus's gravatar image

Come ha fatto il mio commento a finire nell'edit della domanda?

(17 Ott '17, 11:19) cialu cialu's gravatar image

hahaha è una storia contorta: avevo aperto due account perchè al primo non mi arrivava la mail di verifica quindi non potevo fare domande. Quando si è attivato ho spostato tutte le domande sull'account preferito e ho copiato anche la tua risposta. spero non sia contro le regole, se è un problema la tolgo subito.

(17 Ott '17, 11:59) hodoeporicus hodoeporicus's gravatar image

Non credo sia un problema, avevo chiesto soltanto per comprendere cosa di preciso fosse accaduto. Vedo di rimuovere l'edit dalla domanda (per lasciarla più chiara) e sposto nei commenti.

(17 Ott '17, 15:38) cialu cialu's gravatar image

Non riesci a impostarla dal pannello di controllo di GNOME? Scheda grafica e driver?

(17 Ott '17, 15:43) cialu cialu's gravatar image

HODOEPORICUS: 22 ORE FA ciao cialu per pannello di controllo intendi le impostazioni? da lì posso vedere la risoluzione che ho impostato tramite terminale, ma non mi fa premere "applica" per configurarla in modo permanente, poichè le risoluzioni disponibili sono altre, e credo che a causa di questo stesso problema mi dà "display Sconosciuto.

scheda grafica: 00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

driver: driver=i915 latency=0

(17 Ott '17, 15:43) cialu cialu's gravatar image

Se il comando funziona, allora puoi creare uno script con esso e lanciarlo all'avvio.

sudo vi /usr/bin/ris_avvio

Editi il file con all'interno il comando:

#!/bin/bash
Qui metti i comandi per settare la risoluzione

Salvi e lo rendi eseguibile:

sudo chmod +x /usr/bin/ris_avvio

Crei un lanciatore per lo script all'avvio:

cd ~/.config/autostart/
ln -s /usr/bin/ris_avvio ris_avvio.desktop

Infine riavvii.

Se usi ambienti alternativi a Ubuntu classico, ti consiglio di controllare i percorsi corretti sulla wiki AmministrazioneSistema>AvvioAutomatico.

coll. permanente

ha risposto 17 Ott '17, 11:39

cialu's gravatar image

cialu
1.1k21629

ciao cialu, ben ritrovatoXD

Allora se seguo i tuoi consigli con comando
sudo vi/usr/bin/ris_avvio
mi da

~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
~                                                                               
"/usr/bin/ris_avvio" [New File]

se invece considero che non ho ubuntu classico ma gnome 16.04 LTS e seguo le istruzioni del link che mi hai dato, mi dice di aprire "impostazioni di sistema" e selezionare un "applicazione d'avvio", cosa che già ho fatto: quando accendo il pc si apre il terminale digito le paroline magiche e si imposta la risoluzione predefinita.
Preferirei tuttavia trovare una soluzione fissa.

(17 Ott '17, 12:18) hodoeporicus hodoeporicus's gravatar image

Scusa, ho dato per scontato che sapessi utilizzare vi. Per informazioni a riguardo, puoi vedere la guida del wiki su Editor di testo > Vim.

Nel tuo caso, ti conviene utilizzare Gedit. Da terminale:

sudo -H gedit /usr/bin/ris_avvio

E poi segui le istruzioni sopra.

(17 Ott '17, 13:19) cialu cialu's gravatar image

cialu devo aggiungere lo stesso il tag??

#!/bin/bash

nei comandi per settare la risoluzione vanno specificati i 60hz? e il rapporto lo inserisco con spazio o con "x" ?? per intenderci

1440 900 60.00

oppure

1440x900_60.00
(17 Ott '17, 15:16) hodoeporicus hodoeporicus's gravatar image

Dopo

#!/bin/bash

devi mettere l'esatto comando che usi da terminale per settare la risoluzione.

(17 Ott '17, 15:35) cialu cialu's gravatar image

Non funziona Cialu ricapitolo per verificare la corretta sequenza

sudo -H gedit /usr/bin/ris_avvio

si apre il file e inserisco

#!/bin/bash
ris_pred

salvo e chiudo, poi comando

sudo chmod +x /usr/bin/ris_avvio
cd ~/.config/autostart/
ln -s /usr/bin/ris_avvio ris_avvio.desktop
reboot.

A comando

sudo -H gedit /usr/bin/ris_avvio

mi da output

** (gedit:1775): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-position non supportata

cosa sto sbagliando?

(17 Ott '17, 15:51) hodoeporicus hodoeporicus's gravatar image

Presumo che ris_pred sia uno script, prova a postare l'output di:

cat ris_pred
(17 Ott '17, 15:58) cialu cialu's gravatar image

cat: ris_pred: File o directory non esistente

(17 Ott '17, 16:20) hodoeporicus hodoeporicus's gravatar image

Quando dici "Ho impostato da terminale la risoluzione predefinita con ris_pred a 1440x900_60.00" cosa intendi? Potresti riportare qui il comando preciso che utilizzi per impostare la risoluzione da terminale?

(17 Ott '17, 16:25) cialu cialu's gravatar image

per aggiungere la risoluzione 1440x900_60.00 ho trovato una guida su internet, ora la risoluzione è presente nel sistema ma non è salvata come predefinita quindi ad ogni accensione apro il terminale e comando

ris_pred

lo schermo si spegne per un secondo e poi mi da la risoluzione che ho salvato, ,cioè 1440X900_60.00

(17 Ott '17, 16:31) hodoeporicus hodoeporicus's gravatar image

Posta il risultato di

which ris_pred
(17 Ott '17, 16:44) cialu cialu's gravatar image

mi da output

/usr/bin/ris_pred
(17 Ott '17, 16:47) hodoeporicus hodoeporicus's gravatar image

Ora posta l'output di

cat /usr/bin/ris_pred
(17 Ott '17, 16:48) cialu cialu's gravatar image

è parte del processo che ho effettuato per aggiungere questa risoluzione.

xrandr --newmode "1440x900_60.00"  106.47  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync
xrandr --addmode VGA-1 1440x900_60.00
xrandr --output VGA-1 --mode 1440x900_60.00

la stringa dopo "--newmode" l'ho ottenuta con

gtf 1280 720 60 | grep Modeline
(17 Ott '17, 16:52) hodoeporicus hodoeporicus's gravatar image

Dai

sudo -H gedit /usr/bin/ris_avvio

inserisci i due comandi xrandr, poi salvi e quindi riavvii.

Ovviamente se avevi già eseguito gli altri comandi postati nella soluzione sopra, altrimenti devi ridare anche quelli.

(17 Ott '17, 16:55) cialu cialu's gravatar image

giusto per essere preciso:

intendi i primi due comandi "xrandr" che mi hai chiesto in output +

#!/bin/bash
ris_pred

??

(17 Ott '17, 17:00) hodoeporicus hodoeporicus's gravatar image

Facciamo così, anche perché sarebbe un duplicato a questo punto.

Per prima cosa, cancelliamo ciò che avevamo creato con:

sudo rm /usr/bin/ris_avvio

sudo rm ~/.config/autostart/ris_avvio.desktop

Poi mettiamo un link in autostart allo script res_pred:

cd ~/.config/autostart/

ln -s /usr/bin/ris_pres ris_pred.desktop

Quindi puoi riavviare.

(17 Ott '17, 17:05) cialu cialu's gravatar image

nada non funziona cialu il file è stato eliminato ma a riavvio la risoluzione è sempre da reimpostare.

hodoeporicus@hodoeporicus-homunculus:~$ cd ~/.config/autostart/
hodoeporicus@hodoeporicus-homunculus:~/.config/autostart$ ln -s /usr/bin/ris_pres ris_pred.desktop
ln: creazione del collegamento simbolico 'ris_pred.desktop' non riuscita: File già esistente
(17 Ott '17, 17:12) hodoeporicus hodoeporicus's gravatar image

Posta output di:

cat ~/.config/autostart/ris_pred.desktop
(17 Ott '17, 17:14) cialu cialu's gravatar image

outupu è

cat: /home/hodoeporicus/.config/autostart/ris_pred.desktop: File o directory non esistente
(17 Ott '17, 17:28) hodoeporicus hodoeporicus's gravatar image

Qualcosa non torna, per favore, posta output di:

ls ~/.config/autostart/
(17 Ott '17, 17:31) cialu cialu's gravatar image

output è

gnome-terminal.desktop  imposta_ris.desktop  ris_pred.desktop

"ris_pred.desktop" è evidenziato in rosso

(17 Ott '17, 17:36) hodoeporicus hodoeporicus's gravatar image

Ok, quindi è un collegamento corrotto.

Risolviamo con:

cd ~/.config/autostart/
rm ris_pred.desktop
ln -s /usr/bin/ris_pres ris_pred.desktop

E infine riavvia il sistema.

(17 Ott '17, 17:39) cialu cialu's gravatar image

ancora niente, la risoluzione dopo il riavvio non è quella richiesta dal monitor

(17 Ott '17, 17:44) hodoeporicus hodoeporicus's gravatar image

Ok, vediamo allora così:

cd ~/.config/autostart/
rm ris_pred.desktop
gedit ris_pred.desktop

Edita il file così:

[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=ris_pred
Exec=/usr/bin/ris_pres
Terminal=false
X-GNOME-Autostart-enabled=true

Salva e riavvia.

(17 Ott '17, 17:50) cialu cialu's gravatar image

niente ancora, ti prego dimmi che hai altre ideeXD

(17 Ott '17, 17:55) hodoeporicus hodoeporicus's gravatar image

Una soluzione alternativa può essere quella di installare un front-end grafico di Xrandr e fare sistemare il tutto a quello.

A esempio, per ARandR:

sudo apt install arandr

Oppure puoi provare ResolutionX. Entrambi dovrebbero salvare le impostazioni per il caricamento automatico al login.

(17 Ott '17, 18:06) cialu cialu's gravatar image

Ovviamente dopo averlo installato, lo lanci come qualsiasi applicazione grafica. E ricorda di effettuare il salvataggio delle impostazioni.

(17 Ott '17, 18:08) cialu cialu's gravatar image

Leggendo sul sito ufficiale, mi pare di capire che devi selezionare la risoluzione a te congeniale e poi effettuate il salvataggio della stessa.

(17 Ott '17, 18:10) cialu cialu's gravatar image

ti dispiacerebbe spiegarmi nel dettaglio?

(17 Ott '17, 18:11) hodoeporicus hodoeporicus's gravatar image

Nel menu Output > Display Attivo > Selezioni risoluzione e poi premi l'icona con la spunta, infine quella per il salvataggio.

(17 Ott '17, 18:13) cialu cialu's gravatar image

cialu ho fatto esattamente quello che hai detto, in realtà pensavo fosse una cosa più complicata, ho ripetuto l'operazione anche più volta ma la risoluzione al riavvio è sempre quella sbagliata.

in terminale non trovo ResolutionX, provo da software...magari funziona..

(17 Ott '17, 18:24) hodoeporicus hodoeporicus's gravatar image

ResolutionX non si trova neanche in software. ho installato altri programmi da software come per esempio "selettore risoluzione" ma a riavvio non mantengono la risoluzione richiesta.

Aspetterò altre idee da terzi, grazie cialu per la pazienza.

(17 Ott '17, 18:38) hodoeporicus hodoeporicus's gravatar image
1

Per ResolutionX è necessario scaricare il sorgente dal link sopra e lanciarlo da terminale con ./resolutionx. Non credo cambi nulla, si tratta di app equivalenti e, comunque, anche la soluzione da terminale avrebbe dovuto funzionare. Mi spiace, al momento, non so come aiutarti in altro modo.

(17 Ott '17, 20:14) cialu cialu's gravatar image

cialu può essere che sia dovuto al fatto che il monitor risulta come "display sconosciuto" ??

(18 Ott '17, 18:47) hodoeporicus hodoeporicus's gravatar image
1

È sicuramente dovuto al fatto che non riconosce il monitor e quindi non sa quali siano le risoluzioni supportate. PS_Non ti rivolgere a me in particolare, sii generico, Chiedi è una piattaforma collaborativa.

(18 Ott '17, 20:13) cialu cialu's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×74
×46
×23
×22

domanda posta: 15 Ott '17, 16:48

domanda visualizzata: 705 volte

ultimo aggiornamento: 18 Ott '17, 20:13

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.