Ciao a tutti, sono un principiante nel mondo di ubuntu e sto cercando di installare Gnu Octave ma sto fallendo miseramente, credo ci siano altri problemi di fondo. La prima cosa che ho provato è il comando dal terminale sudo apt install octave ottenendo questo:

Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti: [elenco pacchetti molto lungo] 0 aggiornati, 49 installati, 0 da rimuovere e 0 non aggiornati. È necessario scaricare 27,3 MB/33,4 MB di archivi. Dopo quest'operazione, verranno occupati 160 MB di spazio su disco. Continuare? [S/n] S

E mi da una serie di errori dei quali copio solo i primi due

Err:1 http://it.archive.ubuntu.com/ubuntu yakkety/main amd64 libblas-common amd64 3.6.1-2ubuntu1 404 Not Found Err:2 http://it.archive.ubuntu.com/ubuntu yakkety/main amd64 libblas3 amd64 3.6.1-2ubuntu1

finiti quelli mi da questo

E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/main/l/lapack/libblas-common_3.6.1-2ubuntu1_amd64.deb 404 Not Found E: Impossibile recuperare http://it.archive.ubuntu.com/ubuntu/pool/main/l/lapack/libblas3_3.6.1-2ubuntu1_amd64.deb 404 Not Found [...] E: Impossibile scaricare alcuni pacchetti. Potrebbe essere utile eseguire "apt-get update" o provare l'opzione "--fix-missing".

Quindi provo come mi dice ad eseguire apt-get update ma mi da un'ennesima serie di messaggi di questo tipo

utente@alfred:~$ sudo apt-get update Ign:1 http://security.ubuntu.com/ubuntu yakkety-security InRelease Err:2 http://security.ubuntu.com/ubuntu yakkety-security Release
Ign:13 http://ppa.launchpad.net/octave/stable/ubuntu yakkety/main all Packages [...] Lettura elenco dei pacchetti... Fatto E: The repository 'http://security.ubuntu.com/ubuntu yakkety-security Release' does no longer have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default.

Poi ho trovato online un altro modo

sudo add-apt-repository ppa:octave/stable The latest version of GNU Octave built for all supported Ubuntu releases. GNU Octave is normally distributed with Ubuntu, this PPA is for you if you have a need to use a newer version of Octave than what you can already get from your installed version of Ubuntu.

Simply follow the instructions below to add this PPA to your system and install the octave package. If it's not that easy or you encounter any errors, contact the team and let us know.

Much credit goes to the Debian Octave Group who maintain the official Debian packages that this work is derived from. Without their efforts to bring Octave packaging to such a high level of quality in Debian and Debian derivatives, this PPA would not be here. Maggiori informazioni: https://launchpad.net/~octave/+archive/ubuntu/stable Premere [INVIO] per continuare o Ctrl+C per annullare

gpg: keybox '/tmp/tmprzz4xx4x/pubring.gpg' created gpg: /tmp/tmprzz4xx4x/trustdb.gpg: creato il trustdb gpg: chiave 4F2D377DDCB1CB6E: chiave pubblica "Launchpad PPA for GNU Octave" importata gpg: Numero totale esaminato: 1 gpg: importate: 1 OK sudo apt-get update [stessi errori di prima]

Provo comunque a installare i pacchetti di octave:

I seguenti pacchetti NUOVI saranno installati: aglfn gnuplot gnuplot-data gnuplot-qt libwxbase3.0-0v5 libwxgtk3.0-0v5 0 aggiornati, 6 installati, 0 da rimuovere e 0 non aggiornati. È necessario scaricare 6.347 kB/6.376 kB di archivi. Dopo quest'operazione, verranno occupati 24,5 MB di spazio su disco. Ign:1 http://it.archive.ubuntu.com/ubuntu yakkety/universe amd64 gnuplot-data all 5.0.4+dfsg1-3 Err:2 http://it.archive.ubuntu.com/ubuntu yakkety/universe amd64 libwxbase3.0-0v5 amd64 3.0.2+dfsg-2 404 Not Found Err:3 http://it.archive.ubuntu.com/ubuntu yakkety/universe amd64 libwxgtk3.0-0v5 amd64 3.0.2+dfsg-2 404 Not Found

Eccetera, se per favore qualcuno può darmi una mano

chiesto 04 Feb, 18:03

alfreds's gravatar image

alfreds
20

chiuso 04 Feb, 18:41

enzoge's gravatar image

enzoge
4.6k203987

@alfreds: purtroppo la tua domanda riguarda un sistema operativo non più assistito da luglio 2017.
Per cercare qualcuno che sappia risolvere il problema, dovresti installare una release più recente e magari lts, come la 16.04.

(04 Feb, 18:39) enzoge enzoge's gravatar image

La domanda è stata chiusa con il seguente motivo «Altro, distribuzione non più assistita.» da enzoge 04 Feb, 18:41

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,598

domanda posta: 04 Feb, 18:03

domanda visualizzata: 54 volte

ultimo aggiornamento: 04 Feb, 18:41

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.