Ciao a tutti,ho appena installato l'ultima versione di ubuntu sul mio pc HP. Fino ad ora tutto bene,tranne per dei problemi con il wifi:

  • La potenza del segnale è molto bassa,anche stando ad un metro dal modem (mi segna due tacche)questo mi impedisce di utilizzare il pc in altre stanze.

  • Ogni tanto si scollega,oppure appare un punto interrogativo dove dovrebbe essere il simbolo del wifi.

Come posso risolvere? Confido in una vostra risposta

chiesto 22 Feb, 18:00

Vinz's gravatar image

Vinz
20125

modificato 29 Mar, 12:10

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161

Marca e modello della scheda wifi?

(22 Feb, 18:56) dadexix86 ♦♦ dadexix86's gravatar image

@dadexix86 non lo so,c'è quelche comando da mettere nel terminale per sapere marca e modello?

(22 Feb, 19:08) Vinz Vinz's gravatar image

Certo che sì! :) Ce ne sono di più semplici, ma quello che ci darà più informazioni è

lspci -vvnn | grep -A 9 Network

(puoi incollare nel terminale con Ctrl+Maiusc+v)

(22 Feb, 19:42) dadexix86 ♦♦ dadexix86's gravatar image

@dadexix86 mi ha restituito questo:

Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:804c]
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 38
    Region 0: I/O ports at 3000 [size=256]
    Region 2: Memory at f0c00000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: rtl8723be
    Kernel modules: rtl8723be

AGGIUNGO:quando si scollega dal wifi mi da il seguente avviso: attivazione della connessione di rete non riuscita

(22 Feb, 20:09) Vinz Vinz's gravatar image

A meno di rispondere alla (tua in questo caso) domanda principale usa i commenti e non le risposte, grazie!

Tornando a noi, quella scheda su HP ha un sacco di problemi con Linux. Ti scrivo una risposta spiegandoti bene cosa succede e come puoi provare a risolverlo.

(22 Feb, 22:08) dadexix86 ♦♦ dadexix86's gravatar image

@dadexix86 Va bene,grazie mille

(22 Feb, 22:12) Vinz Vinz's gravatar image

Traduco da questa domanda su AskUbuntu

Quella scheda in teoria (secondo le specifiche) sarebbe una gran scheda, con due antenne wifi che forniscono un segnale molto ampio. Purtroppo sta al produttore del computer (HP) e non al produttore del chip (RealTek) il compito di assemblare i pezzi e soprattutto di decidere come farlo.

HP ha scelto per quella scheda di installare una sola delle due antenne montando la scheda.
Il sistema Windows che forniscono preinstallato ha già scritto nei suoi file di configurazione qual è l'antenna giusta da usare.
Di contro, essendo il driver Linux pensato per adattarsi alle specifiche della scheda (rtl8723be) e non quelle del produttore del computer, e soprattutto non avendo HP rilasciato ufficialmente delle specifiche in cui descrive quale delle due antenne è montata, il driver per Linux prova ad usare tutte e due le antenne.

Questo provoca ovvi problemi di potenza come nel tuo caso, perché HP ha montato e alimentato il tutto sapendo di aver messo un'antenna sola.

La soluzione è quindi di specificare al driver quale antenna abilitare delle due con questo comando

sudo tee /etc/modprobe.d/rtl8723be.conf <<< "options rtl8723be ant_sel=1"

(ant_sel sta per antenna selection).

Ovviamente non si sa se è la prima o la seconda antenna che è attaccata alla tua scheda (potresti smontare il pc per scoprirlo, ma non ne vale la pena) quindi se dopo questo comando e un riavvio non vedi differenze potresti provare a usare la seconda antenna anziché la prima con

sudo tee /etc/modprobe.d/rtl8723be.conf <<< "options rtl8723be ant_sel=2"
coll. permanente

ha risposto 22 Feb, 22:16

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161

modificato 22 Feb, 22:17

@dadexix86 Grazie per il tuo tempo,sei stato davvero gentile,funziona tutto perfettamente :)

(22 Feb, 22:29) Vinz Vinz's gravatar image

Non siamo in forum. Non modificare il titolo della domanda quando è risolta per favore, ma accetta la risposta cliccando la "v" sotto le manine alla sua sinistra.

Riporto il titolo all'originale (è importante per la ricerca), tu accetta la risposta (idem, così la domanda viene segnata come risolta) per favore.

(22 Feb, 23:01) dadexix86 ♦♦ dadexix86's gravatar image

Ottima spiegazione, dadexix86! Infatti il mio HP, dopo l'aggiornamento al 18.04, era rimasto - chissà perché - impostato su ant_sel=2. Ora vede le reti wifi e si connette. Vedremo se saranno risolti anche i problemi di disconnessioni frequenti che avevo con le versioni precedenti.

coll. permanente

ha risposto 27 Lug, 09:37

antoniotrogu's gravatar image

antoniotrogu
201

di default c'e' anche abilitato il powersave:

ips:Set to 0 to not use link power save (default 1)

fwlps:Set to 1 to use FW control power save (default 1)

(27 Lug, 11:44) sacarde sacarde's gravatar image

@antoniotrogu la risposta ha risolto i tuoi problemi di disconnessione sulla 18.04?

(08 Ott, 10:04) dadexix86 ♦♦ dadexix86's gravatar image

Sì, ha risolto tutti i problemi. E dopo l'aggiornamento a 18.10 ho dovuto rifare la stessa modifica.

(08 Ott, 10:51) antoniotrogu antoniotrogu's gravatar image

Buongiorno a tutti

Io non risolvo ancora... Altre soluzioni? Mi trovo nella stessa condizione di una ricezione wifi quasi inesitente di livello; Basta allontanarmi 1 metro dal router e il segnale wifi è perduto!

coll. permanente

ha risposto 08 Ott, 09:57

NicLi's gravatar image

NicLi
202

Quale delle due antenne usa la tua scheda?

(08 Ott, 10:03) dadexix86 ♦♦ dadexix86's gravatar image
  • puo' essere un settaggio sul router:

802.11 b/g, al posto di 802.11 b/g/n

  • puo' essere il powersafe attivo
(08 Ott, 10:10) sacarde sacarde's gravatar image

Usava la numero 2 e continua ad usare la stessa. Ho risolto scaricando e installando i drivers aggiornati per la scheda di rete impostando le opzioni fwlps=0 swlps=0 per il driver.

coll. permanente

ha risposto 08 Ott, 10:33

NicLi's gravatar image

NicLi
202

modificato 08 Ott, 10:34

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,728
×407
×127

domanda posta: 22 Feb, 18:00

domanda visualizzata: 1,473 volte

ultimo aggiornamento: 08 Ott, 10:51

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.