Ciao a tutti,
sono nuovo del forum e vi chiedo di scusarmi qualora avessi sbagliato la stesura del messaggio.

Avendo da poco installato Ubuntu, ho riscontrato un errore nel download dei file da Ubuntu Software Center. L'errore che si verifica è il seguente:

Richiede l'installazione di pacchetti non fidati, Ciò richiede l'installazione di pacchetti da sorgenti non autenticate

Avendo letto delle conversazioni simili alla mia, ho digitato da terminale

sudo apt-get update

e vengono rilevati i seguenti errori:

W: Errore GPG: http://it.archive.ubuntu.com raring Release: Le seguenti firme non erano valide: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: Errore GPG: http://it.archive.ubuntu.com raring-backports Release: Le seguenti firme non erano valide: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

Chiedo a voi aiuto, e ringrazio anticipatamente chi ne sarà capace :)

chiesto 08 Ott '13, 18:39

Tiar93's gravatar image

Tiar93
20112

modificato 08 Ott '13, 18:58

enzotib's gravatar image

enzotib ♦♦
14.0k112186


Sei incappato nell'errore BADSIG delle chiavi GPG.

Ubuntu scarica nuovi programmi e aggiornamenti da specifici repository, i quali richiedono delle chiavi GPG specifiche. Il tutto per questione di sicurezza ovviamente. In questo modo verranno installati unicamente software sicuri e da sorgenti note.

Nel tuo caso non vengono più riconosciute le chiavi GPG.

Per ripristinarle puoi procedere come segue:

apri il terminale e incolla il comando seguente:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com xxxxxxxxxxxxx

dove, al posto delle xxxxxx devi inserire il codice corrispondende alla chiave GPG che non viene riconosciuta (nel tuo caso sono due). Al termine dell'operazione, se tutto è andato per il verso giusto, dai ancora da terminale il comando:

sudo apt-get update

Ora non dovrebbero esserci più problemi. Qualora questo metodo non funzionasse, prova a vedere questa domanda in AskUbuntu, in cui sono riportate altre soluzioni al tuo problema.

coll. permanente

ha risposto 08 Ott '13, 19:22

alevipri's gravatar image

alevipri
5.5k1479

modificato 08 Ott '13, 19:23

1

Grazie mille per aver risposto alla mia domanda. Ho provato col tuo metodo e sfortunatamente il problema non si era risolto. Però nel link che mi hai allegato ho provato il secondo metodo, cioè digitare da terminale i seguenti comandi:

$ sudo -i
# apt-get clean
# cd /var/lib/apt
# mv lists lists.old  
# mkdir -p lists/partial
# apt-get clean
# apt-get update

E i due errori non si sono più verificati. Inoltre ho provato a fare un download da Ubuntu Software Center e l'errore non si è più verificato.
Grazie ancora per il tempo che mi hai dedicato

(09 Ott '13, 10:09) Tiar93 Tiar93's gravatar image

@Tiat93: Le risposte non servono per chiedere chiarimenti o comunicare i risultati di qualcosa, ma tutto questo può essere scritto tramite i commenti.

(09 Ott '13, 10:15) enzotib ♦♦ enzotib's gravatar image
1

Grazie mille, ho risolto anche io utilizzando il comando sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com A6804EA8EAE0D85C e rifacendo sudo apt-get update

a questo punto si è messo a scaricare alla grande gli aggiornamenti grazie mille

(04 Feb '15, 13:34) paolokoh paolokoh's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×166

domanda posta: 08 Ott '13, 18:39

domanda visualizzata: 3,930 volte

ultimo aggiornamento: 04 Feb '15, 14:03

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.