Buonasera a tutti, da un po' di tempo non riesco più a installare nessun nuovo pacchetto. ogni volta che provo a installare qualcosa mi dà errore, ma non essendo troppo pratico di ubuntu vi do subito un esempio di output quando cerco di installare un programma a caso:

sudo apt install zypper [sudo]
password di nando: Lettura elenco
dei pacchetti... Fatto Generazione
albero delle dipendenze
Lettura informazioni sullo stato... Fatto ``È utile eseguire
"apt --fix-broken install" per
correggere ciò. I seguenti pacchetti
hanno dipendenze non soddisfatte:
discord : Dipende:
libappindicator1 ma non sta per essere
installato Dipende: libc++1 ma
non sta per essere installato zypper
: Dipende: libaugeas0 (>= 0.6.0)
ma non sta per essere installato
Dipende: libzypp ma non sta per essere
installato Dipende: zypper-common
(>= 1.12.4-1build1) ma non sta per
essere installato E: Dipendenze non
soddisfatte. Provare "apt --fix-broken
install" senza pacchetti (o
specificare una soluzione).

mentre se provo come suggerito "apt --fix-broken install" l'output è questo:

sudo apt --fix-broken install Lettura
elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato...
Fatto Correzione delle dipendenze...
Fatto I seguenti pacchetti sono stati
installati automaticamente e non sono
più richiesti:
linux-headers-4.10.0-19
linux-headers-4.10.0-19-generic
linux-headers-4.10.0-37
linux-headers-4.10.0-37-generic
linux-headers-4.10.0-38
linux-headers-4.10.0-38-generic
linux-image-4.10.0-19-generic
linux-image-4.10.0-37-generic
linux-image-4.10.0-38-generic
linux-image-extra-4.10.0-19-generic
linux-image-extra-4.10.0-37-generic
linux-image-extra-4.10.0-38-generic
linux-signed-image-4.10.0-19-generic
linux-signed-image-4.10.0-37-generic
linux-signed-image-4.10.0-38-generic
Usare "sudo apt autoremove" per
rimuoverli. The following additional
packages will be installed:
libappindicator1 libc++1 libc++abi1
libindicator7 Pacchetti suggeriti:
clang I seguenti pacchetti NUOVI
saranno installati: libappindicator1
libc++1 libc++abi1 libindicator7 0
aggiornati, 4 installati, 0 da
rimuovere e 4 non aggiornati. 1 non
completamente installati o rimossi. È
necessario scaricare 266 kB/288 kB di
archivi. Dopo quest'operazione,
verranno occupati 1.210 kB di spazio
su disco. Continuare? [S/n] s Err:1
http://it.archive.ubuntu.com/ubuntu
zesty/main amd64 libappindicator1
amd64 12.10.1+17.04.20170215-0ubuntu1
404 Not Found Err:2
http://it.archive.ubuntu.com/ubuntu
zesty/universe amd64 libc++abi1 amd64
3.9.1-2 404 Not Found Err:3 http://it.archive.ubuntu.com/ubuntu
zesty/universe amd64 libc++1 amd64
3.9.1-2 404 Not Found E: Impossibile recuperare
http://it.archive.ubuntu.com/ubuntu/pool/main/liba/libappindicator /libappindicator1_12.10.1+17.04.20170215-0ubuntu1_amd64.deb 404 Not Found E: Impossibile
recuperare
http://it.archive.ubuntu.com/ubuntu/pool/universe/libc/libc++ /libc++abi1_3.9.1-2_amd64.deb
404 Not Found E: Impossibile
recuperare
http://it.archive.ubuntu.com/ubuntu/pool/universe/libc/libc++ /libc++1_3.9.1-2_amd64.deb
404 Not Found E: Impossibile
scaricare alcuni pacchetti. Potrebbe
essere utile eseguire "apt-get update"
o provare l'opzione "--fix-missing".

qualcuno ha un consiglio o una soluzione da darmi a riguardo?

chiesto 23 Apr, 14:50

nandocaria33's gravatar image

nandocaria33
203

modificato 23 Apr, 15:02

non ho capito se prima hai sincronizzato gli indici:

sudo apt update

(23 Apr, 21:42) sacarde sacarde's gravatar image

sudo apt autoclean sudo apt autoremove sudo apt update può essere utile anche aprire software e aggiornamenti andare nel menù "altro software" e togliere la spunta ai link che vedi in rosso nell'output che hai postato prova così forse risolvi

coll. permanente

ha risposto 07 Mag, 21:05

marcarm's gravatar image

marcarm
203

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×785
×250
×127
×35

domanda posta: 23 Apr, 14:50

domanda visualizzata: 255 volte

ultimo aggiornamento: 07 Mag, 21:05

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.