Salve, uso Ubuntu da meno di un mese. Inizialmente va tutto alla grande, fin quando improvvisamente risulta impossibile stabilire una connessione ad internet. Si collega benissimo alla rete wireless, che su altri dispositivi funziona tranquillamente, ma arrivo a digitare "google.it" e appare la schermata "Impossibile trovare l'indirizzo IP del server". Lo stesso problema lo ho collegando il PC ad altre reti wireless. Provando a digitare il comando del ping dal terminale (ping -c 5 google.com) appare il seguente output "Ping: unknown host google.com". Invece lanciando il comando "Ping -c 5 192.168.1.254" trasmette pacchetti tranquillamente. Non ho la minima idea di dove poter andare a sbattere la testa, e soprattutto da cosa possa dipendere.

chiesto 08 Mag, 18:28

michmaik's gravatar image

michmaik
201

prova a aggiungere un server dns nel file: /etc/resolvconf/resolv.conf.d/head

esempio: nameserver 8.8.8.8

e a riavviare il servizio:

sudo systemctl restart resolvconf.service

(08 Mag, 20:36) sacarde sacarde's gravatar image

Sono entrato nel file ma me lo apre in sola lettura, senza poterci scrivere nulla, esiste un altro modo per aggiungere il DNS?

(08 Mag, 21:31) michmaik michmaik's gravatar image

hai messo "sudo" all'inizio del comando?

tipo: sudo gedit /etc/resolvconf/resolv.conf.d/head

(08 Mag, 21:36) sacarde sacarde's gravatar image

Ok ho aggiunto la stringa sudo gedit /etc/resolvconf/resolvconf.conf.d/head e ho aggiunto il nameserver col DNS di Google. Ho riavviato secondo la Sua risposta ma al momento non è cambiato nulla

(08 Mag, 21:44) michmaik michmaik's gravatar image
  • che hai adesso nel file /etc/resolv.conf ?

  • confermi che il "ping google.it" risponde correttamente ?

(08 Mag, 23:37) sacarde sacarde's gravatar image

@sacarde Il ping google.it non risponde, da il solito problema all'origine. Nel file compare la scritta "nameserver 127.0.0.53", credo quindi di aver sbagliato qualcosa nel passaggio precedente

(09 Mag, 10:44) michmaik michmaik's gravatar image

[EDIT] ho avuto l'idea di modificare direttamente il nameserver in quel file, e niente adesso funziona correttamente. Grazie mille per l'aiuto.

(09 Mag, 10:48) michmaik michmaik's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,640
×141
×117
×100
×43

domanda posta: 08 Mag, 18:28

domanda visualizzata: 40 volte

ultimo aggiornamento: 09 Mag, 10:48

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.