Salve, Mi ritrovo con questo problema ormai da settimane. Sia facendo l aggiornamento dalla versione 17.10 che reinstallando tutto da capo mi ritrovo con questo problema. All avvio nella schermata dei pallini ad un certo punto spunta il puntatore, la schermata si blocca e non posso fare piu nulla, il sistema resta fermo alla schermata di avvio. Ho gia provato dalla versione di prova facendo varie cose dal terminale come reinstallare gdm3, fare l upgrade e tutto. Cercando su google ho trovato qualche altro articolo di qualcuno col mio stesso problema, ma non e stato risolto

chiesto 03 Giu '18, 18:49

ElektroSpider's gravatar image

ElektroSpider
40132025

modificato 04 Giu, 19:33

  • se fai "ctrl-alt-f1" riesci a loggarti?

  • prova a avviare da grub eliminando i parametri sulla riga del kernel:

quiet splash

https://wiki.ubuntu-it.org/Installazione/ParametriAvvio

(04 Giu '18, 08:42) sacarde sacarde's gravatar image

Risolto togliendo il # all'inizio della riga "WaylandEnable=false" nel file "/etc/gdm3/custom.conf" e cambiando i parametri di avvio da "quiet splash" in "xforcevesa quiet"

coll. permanente

ha risposto 04 Giu, 19:32

ElektroSpider's gravatar image

ElektroSpider
40132025

Entra in Ubuntu tramite recovery mode, dal menu che ti si presenta scegli la prima opzione, quella di ripristino dell'avvio, dai sempre ok e dovresti riuscire ad arrivare al desktop; una volta dentro aggiorna tutto e successivamente apri il terminale e fai un "sudo nano /etc/gdm3/custom.conf" , aperto il file, nella sezione [daemon] togli il cancelletto alla riga dove trovi "WaylandEnable=false" , salva e riavvia, problema risolto ;-) .

coll. permanente

ha risposto 20 Giu '18, 14:51

maxvio's gravatar image

maxvio
201

Ciao, non ricevevo risposte quindi ho deciso di installare Ubuntu Mate 18.04 e va tutto a gonfie vele

(20 Giu '18, 14:54) ElektroSpider ElektroSpider's gravatar image

Comunque seguendo la procedura che ti ho indicato risolvi al 100%

(20 Giu '18, 15:08) maxvio maxvio's gravatar image

Ciao, ho riavuto lo stesso problema dopo l'installazione di Ubuntu 19.04. All'accensione non compare il GRUB, schermata viola e poi subito schermata nera all'infinito. Riesco ad accedere al sistema solamente continuando a premere il tasto SHIFT all'avvio. Ho provato a fare come dici tu, ma il problema rimane

(30 Mag, 20:55) ElektroSpider ElektroSpider's gravatar image

tolti i parametri passati al kernel "quiet splash" e inserito "nomodeset" ?

(30 Mag, 21:20) sacarde sacarde's gravatar image

Si,tolto i parametri "quiet spash" ed ho inserito "nomodeset" il PC al riavvio ha fatto partire Ubuntu tranquillamente, prima di accedere ad Ubuntu sono passate tutte le scritte che compaiono quando entri da recovery mode, ma comunque il sistema si è avviato. Al successivo riavvio invece, continuano a spuntare le scritte, ma lo schermo resta in una schermata nera col trattino in basso di scrittura, ormai ci sto perdendo le speranze con Ubuntu

(31 Mag, 15:28) ElektroSpider ElektroSpider's gravatar image
(31 Mag, 16:39) sacarde sacarde's gravatar image

Credo di aver fatto un po' di casino. Nomodeset al posto di quiet splash l'ho inserito tramite terminale modificando etc/default/grub, e forse è questo il problema. Ho fatto così perché seguendo la guida che mi hai postato, cliccando F6 ed ESC per poter scrivere nella riga e modificarla, dopo non riesco a salvare. Potresti dirmi cosa salvare in questo caso, magari il problema è perché il tutto non è stato fatto da li

(31 Mag, 17:43) ElektroSpider ElektroSpider's gravatar image
  • va bene se lo hai fatto in /etc/default/grub e dopo hai dato: sudo update-grub

  • per vedere le modifiche apportate esegui: cat /proc/cmdline

(31 Mag, 17:52) sacarde sacarde's gravatar image

Ok tutto sistemato. Ho tolto sia il # prima di WaylandEnable=false ed ho sostituito quiet splash con nomodeset ed Ubuntu si avvia sempre. Ora ci sono solamente 2 problemi, il fatto che all'avvio ci sono prima 3 minuti di scritte del tipo "[ OK ] Started ecc..", ed il fatto che come risoluzioni dello schermo mi riconosce solamente 800x600 e 1024x768, praticamente in 4:3 quando prima utilizzavo come risoluzione 1920x1080 senza nessun problema. Sai come risolvere anche questo?

(31 Mag, 18:55) ElektroSpider ElektroSpider's gravatar image
  • per non vedere le scritte basta rimettere "quiet"

se invece vuoi vedere perche' impiega tanto tempo, mostrami questi 2 comandi:

systemd-analyze critical-chain

systemd-analyze blame

e pastali qui: https://paste.ubuntu.com

  • per la risoluzione cosa vedi dal comando: xrandr
(31 Mag, 20:39) sacarde sacarde's gravatar image

Quiet va aggiunto prima di nomodeset o a sostituzione di nomodeset?

(01 Giu, 13:37) ElektroSpider ElektroSpider's gravatar image
  • non conta l'ordine dei moduli, conta se ci sono o no

p.s. quiet: non fa vedere i messaggi del kernel

nomodeset: fa in modo che vengano utilizzati driver video generici

(01 Giu, 13:49) sacarde sacarde's gravatar image

Comunque questo è quello che spunta dal primo comando: https://paste.ubuntu.com/p/6jBmzgJk26/

Questo dal secondo: https://paste.ubuntu.com/p/DVCrDTWYQb/

E questo dal comando per la risoluzione: https://paste.ubuntu.com/p/HFv6xH4xSF/

(01 Giu, 14:12) ElektroSpider ElektroSpider's gravatar image
  • farei una prova rimettendo i parametri: "quiet splash" tralasciando "nomodeset, in pratca come era all'inizio, quindi eliminando solo l'esecuzione di "wayland"

  • come tempi non vedo dei rallentamenti

  • dal comando la risoluzione sembra la: 1280x1024

(01 Giu, 14:22) sacarde sacarde's gravatar image
  • Ho appena provato a rimettere "quiet splash" come era all'inizio e si ripresenta sempre il vecchio problema, schermo nero permanente dopo lo schermo viola.

  • Si, adesso anziché darmi la possibilità di scegliere tra 2 risoluzioni in 4:3 mi da solo questa possibilità in 1280x1024 in 5:4

Edit: ho provato anche a lasciare entrambi i parametri "nomodeset quiet slpash" come diceva una guida inglese, il sistema parte, ma la risoluzione è semore in 5:4

PS: Sto ormai impezzendo, non capisco tutti questi problemi con Ubuntu dopo il ritorno di GNOME

(01 Giu, 14:35) ElektroSpider ElektroSpider's gravatar image
  • ci sarebbe un'altro parametro per forzare la modalita' grafica generica: xforcevesa

  • che driver video usi? inxi -G

(01 Giu, 16:35) sacarde sacarde's gravatar image

Alleluja! Inserendo solamente xforcevesa, la risoluzione è ritornata normale, mi mostra tutte le scelte, però ci sono altri 2 problemi:

  • Le scritte all'avvio sono ritornate, ma penso che inserendo "quiet splash" insieme ad "xforcevesa" la cosa si dovrebbe risolvere come per nomodeset.

  • Subito dopo il login la schermata rimane nera per almeno 1 minuto se non di più, per poi passare al desktop, ed il sistema sembra leggermente rallentato a tratti.

  • Questi sono i driver video: https://paste.ubuntu.com/p/zt8HTQMVgD/

(02 Giu, 14:23) ElektroSpider ElektroSpider's gravatar image
  • si con quiet inserito non vedi piu i messaggi

  • xforcevesa ti forza i driver video vesa-generici

  • i driver per la tua intel sarebbero: xserver-xorg-video-intel

li hai? dpkg -l | grep video-intel

https://wiki.ubuntu-it.org/Hardware/Video/Intel/Open

(02 Giu, 14:35) sacarde sacarde's gravatar image

Si, i driver sono proprio quelli. Comunque credo di aver risolto aggiungendo "xforcevesa quiet splash". Niente marea di scritte all'inizio, risoluzione a 1920x1080, e sopratutto niente schermata nera dopo l'avvio, ne dopo il login, e niente rallentamenti. Credo sia la combinazione migliore, almeno per me. Mi sei stato di grandissimo aiuto, come faccio a scegliere come miglior risposta la tua??

(02 Giu, 14:54) ElektroSpider ElektroSpider's gravatar image

Si a me ha funzionato togliere quiet splash e mettere "nomodeset" come spiegato qui: https://www.youtube.com/watch?v=zdLe3Kao2Ok

il problema è che dopo l'installazione che è andata buon fine riavviando non mi parte ubuntu ma di nuovo la schermata per:

  1. provarlo prima di istallarlo (nisba)
  2. far partire ubuntu (schermata nera)
  3. impostazioni avanzate ( qui smanettando dentro il recovery [tipo aggiusta pacchetti, aggiusta il file system etc] sono riuscito a far partire il desktop di ubuntu che SI VEDEVA SOLO A 800X600 PIXEL perché non riconosceva lo schermo{lo schermo si vedeva bene nella fase di pre istallazione} ma poi non sono riuscito a installare aggiornamenti...ora non riesco più a rifarlo e sto veramente rosikando )
  4. tornare al bootloader di windows (... =_=)
  5. qualcosa di inutile sul sistema che ora non ricordo

NON SONO UN ESPERTO ...qualcuno mi da una mano a capire almeno che diamine ho fatto? Ho provato installare ubuntu da una pennetta con rufus a 64 bit (ho windows a 64bit) ho ridotto il disco da windows della meta (450 gibabyte, dite che basta? :)) emmm basta... ah sì... AIUTO?! @_@

coll. permanente

ha risposto 21 Ott '18, 18:17

Lorenzo%20Suda's gravatar image

Lorenzo Suda
202

modificato 21 Ott '18, 18:20

ma e' come se partisse di nuovo l'usb del live ?

(21 Ott '18, 20:31) sacarde sacarde's gravatar image

sì? :( ...nel frattempo riesco a farlo partire correttamente ubuntu e aferlo funzionare e visualizzare bene...MA SOLO SE ogni volta che parte lo faccio partire in modalità recovery...

in effetti uno degli errori che sono riuscito a leggere più spesso è in questa libreria:

/1ib/recovery-mode / recovery-menu: riga 75: / etc / default /rcs: file o directory non esistente

aiuta a capire? percHé poi la stringa è lunghissima...

(21 Ott '18, 20:39) Lorenzo Suda Lorenzo%20Suda's gravatar image

fai delle prove, da grub , a passare i parametri:

nomodeset

e/o

xforcevesa

p.s. per vedere se dei servizi vanno in errore: sudo systemctl --failed

sudo journalctl -b -p err

(21 Ott '18, 21:20) sacarde sacarde's gravatar image

Come lo richiamo il grub?

e se escludo direttamente i servizi che vanno in errore "prima dell'allvvio" come dice la guida che avete messo?

https://wiki.ubuntu-it.org/Installazione/ParametriAvvio

(21 Ott '18, 21:53) Lorenzo Suda Lorenzo%20Suda's gravatar image
  • i servizi che non servono puoi disabilitarli:

sudo systemctl disable ......

  • il grub e' la prima cosa che parte, forse e' nascosto... premi shift all'avvio, dovrebbe mostrarti il menu di grub
(22 Ott '18, 08:55) sacarde sacarde's gravatar image

{fai delle prove, da grub , a passare i parametri:

nomodeset

e/o

xforcevesa }

ma devo reinstallare tutto per mettere il nomodeset e/o xforce vesa?

(23 Ott '18, 20:32) Lorenzo Suda Lorenzo%20Suda's gravatar image
  • no no, basta che tu intervenga al menu di grub editando l'entrata e aggiungere alla fine della riga "linux ..." i valori: nomodeset xforcevesa

  • se vuoi farlo in modo definitivo editare il file: /etc/default/grub inserendo i parametri li':

https://wiki.ubuntu-it.org/Installazione/ParametriAvvio#Rendere_definitive_le_modifiche

(23 Ott '18, 20:41) sacarde sacarde's gravatar image

Allora ho praticamente risolto...manca solo un 'imprescisione ma mesà che mela tengo...

ho seguito questa guida "How do I set 'nomodeset' after I've already installed Ubuntu: https://askubuntu.com/questions/38780/how-do-i-set-nomodeset-after-ive-already-installed-ubuntu"

Il punto però è:

  1. comunque mi parte in automatico il grub
  2. Sarà che ho scelto di istallare Servizi di e App di terze parti, sarà che non ho ridotto il tempo di timeout del grub (sempre se è quello) ma prima che si avvia ubuntu passano 3 minuti buoni......vabbeh...

soluzioni rapide al volo? grazie.

coll. permanente

ha risposto 24 Ott '18, 22:14

Lorenzo%20Suda's gravatar image

Lorenzo Suda
202

  • grub deve partire, e' il loader del kernel il quale dopo carichera' il primo processo del sistema

(basta scegliere se vedere o no i messaggi di sistema)

  • che vedi da: systemd-analyze blame
(24 Ott '18, 23:33) sacarde sacarde's gravatar image

Ti chiedo scusa , ho lo stesso problema, potresti aiutarmi passo passo? Grazie

coll. permanente

ha risposto 22 Mag, 01:38

giovane49's gravatar image

giovane49
10

ma hai installato o devi ancora farlo?

prova togliendo i parametri "quiet splash" e mettendo "nomodeset" al kernel

https://wiki.ubuntu.com/Kernel/KernelBootParameters#Temporarily_Add_a_Kernel_Boot_Parameter_for_Testing

(22 Mag, 08:48) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,798
×196
×177
×84
×7

domanda posta: 03 Giu '18, 18:49

domanda visualizzata: 6,325 volte

ultimo aggiornamento: 04 Giu, 19:33

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.