Buongiorno a tutti. Sono partito da un pc nuovo (i3-8100) con disco formattato e installazione di Bionic Beaver LTS. Nel tempo ho aggiornato il kernel sino ad arrivare alla 4.17 attuale. Non ho mai avuto il minimo problema. Alcuni giorni fa , dopo un normalissimo upgrade tramite Ubuntu Software, ho fatto ripartire il pc e ... non parte più. E non riesco a capire il perchè! Il primo errore segnalato è stato : Running /script/init-premount ... Random : plymouthd : uninizialized urandom read Create slice Slice User for gdm Starting user manager for UID 120 ... Started session c1 E via di seguito a volte fermandosi alla sessione c2 o c3 a volte arrivando sino alla c7 e provando anche UID 1000 Poi si inchioda e non c'è verso di farlo continuare, non carica il graphics display manager Con ctrl-alt-F2 ho fatto login su console di testo e ho fatto un po di prove per cercare di risolvere il problema, leggendomi il journalctl, cercando contemporaneamente in internet (con il portatile) eventuali soluzioni. Nulla da fare. Nel tempo sono cambiati leggermente gli errori, ma il problema mi rimane. Mi sono convinto a reinstallare, ma non ho formattato, ho fatto reinstalla, perchè ho un mucchio di impostazioni che vorrei conservare. L'installazione funziona, il PC parte e fa il boot normalmente. Poi, senza toccare nient'altro, appena faccio il primo upgrade consigliato dal sistema, mi si ripresenta lo stesso identico problema!! L'unica cosa che ho notato, con inxi, è che se il driver grafico normalmente è i915, dopo il crash in modalità testo mi da driver modesetting (unloaded: fbdev, vesa). Vi prego aiutatemi Allego l'estratto di inxi attuale, cioè con PC reinstallato e nessun aggiornamento o modifica fatta. Ditemi che cosa vi può essere utile per capire l'origine del problema

mauro@Mauro-69:~$ inxi -Fxz System: Host: Mauro-69 Kernel: 4.15.0-20-generic x86_64 bits: 64 gcc: 7.3.0 Desktop: Gnome 3.28.1 (Gtk 3.22.30-1ubuntu1) Distro: Ubuntu 18.04 LTS Machine: Device: desktop Mobo: Micro-Star model: Z370-A PRO (MS-7B48) v: 1.0 serial: N/A UEFI: American Megatrends v: 2.10 date: 09/05/2017 CPU: Quad core Intel Core i3-8100 (-MCP-) arch: Skylake rev.11 cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28800 clock speeds: max: 3600 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz 4: 800 MHz Graphics: Card: Intel Device 3e91 bus-ID: 00:02.0 Display Server: x11 (X.Org 1.19.6 ) driver: i915 Resolution: 1360x768@60.02hz OpenGL: renderer: Mesa DRI Intel HD Graphics (Coffeelake 3x8 GT2) version: 4.5 Mesa 18.0.0-rc5 Direct Render: Yes Audio: Card Intel 200 Series PCH HD Audio driver: snd_hda_intel bus-ID: 00:1f.3 Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic Network: Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0 IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> Drives: HDD Total Size: 1500.3GB (12.2% used) ID-1: /dev/sda model: TOSHIBA_DT01ACA1 size: 1000.2GB ID-2: /dev/sdb model: SAMSUNG_HD502HI size: 500.1GB Partition: ID-1: / size: 916G used: 171G (20%) fs: ext4 dev: /dev/sda2 RAID: No RAID devices: /proc/mdstat, md_mod kernel module present Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C Fan Speeds (in rpm): cpu: N/A Info: Processes: 219 Uptime: 8:49 Memory: 1684.8/7895.9MB Init: systemd runlevel: 5 Gcc sys: N/A Client: Shell (bash 4.4.191) inxi: 2.3.56

chiesto 11 Giu, 07:48

mb69's gravatar image

mb69
20113

modificato 12 Giu, 12:36

quando aggiorni, cosa aggiorni? anche i driver video?

(11 Giu, 09:21) sacarde sacarde's gravatar image

« precedente123

Ho risolto anche con questo ultimo Kernel, semplicemente andando ad installare da terminale la repository per i miei driver NVdia ed aggiornandoli, infatti ora sto usando proprio quest'ultimo Kernel. ;)

coll. permanente

ha risposto 16 Giu, 19:36

Eren%20Lavigne's gravatar image

Eren Lavigne
2037

Io non ho schede nvidia, ho grafica integrata Intel. Quindi non so come risolvere il problema. Ora ho il kernel 4.15.0-23 (installato tramite aggiornamenti automatici) ed il pc mi funziona ...........

coll. permanente

ha risposto 16 Giu, 22:34

mb69's gravatar image

mb69
20113

Precedentemente avevo aggiunto la repository ppa:oibaf/graphics-drivers

Ora non l'ho aggiunta, ma non so se possa essere in qualche modo coinvolta nel crash (sleep) di sistema

Su web non ho trovato nulla di utile .........

coll. permanente

ha risposto 16 Giu, 22:37

mb69's gravatar image

mb69
20113

Ad oggi, mantenendo l'installazione "leggera" (cioè senza i driver di cui sopra e qualche altra repository che precedentemente avevo aggiunto) ho installato UKUU è aggiornato con successo il kernel al più "moderno" 4.16.16

Il PC funziona, ma mi sono tenuto installato il 4.15.0.23, non si sa mai .....

coll. permanente

ha risposto 17 Giu, 11:10

mb69's gravatar image

mb69
20113

Io non ho "UKUU", ma è l'unico modo per aggiornare il Kernel e conviene?

(17 Giu, 16:38) Eren Lavigne Eren%20Lavigne's gravatar image

Ho finalmente isolato il problema!! In realtà ce l'avevo sotto il naso, ma non lo avevo visto prima ... ero troppo concentrato sul kernel.

Va tutto in crash quando inserisco una repository per ottimizzare i driver grafici :

sudo apt add-apt-repository ppa:oibaf/graphics-drivers

Dando prima update poi upgrade aggiorna varie librerie grafiche (libdrm, libgl1, libwayland, etc.) e al successivo reboot si pianta!

Provando ad eliminare la repositori con :

sudo apt add-apt-repository --remove ppa:oibaf/graphics-drivers

NON FUNZIONA in quanto i pacchetti installati non vengono retrocessi alla versione precedente. Bisogna installare ppa-purge ed utilizzare :

sudo ppa-purge ppa:oibaf/graphics-drivers

A questo punto i pacchetti vengono retrocessi ed al reboot successivo il PC riparte perfettamente funzionante.

Se qualcuno vuole divertirsi a riprodurre il problema per studiarlo e comunicare il bug, siete i benvenuti, tenetemi aggiornato !!

PS : il kernel ora l'ho aggiornato al 4.17.2. E funziona tutto.

coll. permanente

ha risposto 24 Giu, 13:07

mb69's gravatar image

mb69
20113

modificato 24 Giu, 13:09

Aggiornamento :

Ho fatto alcuni tentativi con altri repository, oltre a Oibaf ho provato anche Padoka, che aggiorna un blocco leggermente diverso di pacchetti. Esperimento fallimentare.

Ho provato ad aggiornare solo Mesa tramite le repositories :

ppa:ubuntu-x-swat/updates (stable)

ppa:xorg-edgers/ppa (unstable)

ed in entrambi i casi ha funzionato. Sono passato da Mesa18.0.0-rc5 a Mesa18.1.1 ed ho i DRI abilitati ... non è ancora l'ultimissima versione ma è un passo in avanti ...

Anche se il problema è ben lontano dall'essere stato sistemato, visto che nessuno mi risponde e mi da consigli, suggerirei di mettere "risolto" al post e chiuderla qui ...

Grazie

Mauro

coll. permanente

ha risposto 28 Giu, 09:04

mb69's gravatar image

mb69
20113

modificato 28 Giu, 09:37

In data odierna ho aggiunto la repository Padoka (ppa:paulo-miguel-dias/mesa) senza aver eliminato le repository Mesa citate nel mio post precedente. Update, upgrade e funziona tutto correttamente. L'unico pacchetto che risulta aggiornabile, ma viene mantenuto poi alla versione già installata, è libwayland-egl1-mesa (installato 18.1.3 aggiornabile 18.2)

coll. permanente

ha risposto 08 Lug, 20:35

mb69's gravatar image

mb69
20113

Buona sera a tutti, anche a me da questo problema,con il kernel 4.15.0-24 generic, quando si avvia si blocca nella schermata del logo con i 4 puntini sotto, se avvio il kernel 4.15.0-23 generic, si avvia tranquillamente come posso far avviare il kernel buono senza dover formattare tutto Grazie

coll. permanente
Questa risposta è segnata come "wiki".

ha risposto 13 Lug, 20:20

saibaba's gravatar image

saibaba
102

se riesci a togliere i parametri passati al kernel: quiet splash

almeno vedi i messaggi del kernel e dove si ferma

(13 Lug, 20:31) sacarde sacarde's gravatar image

ciao, se mi spieghi come si fa... Grazie

(15 Lug, 18:40) saibaba saibaba's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×184
×79
×62
×4

domanda posta: 11 Giu, 07:48

domanda visualizzata: 2,259 volte

ultimo aggiornamento: 15 Lug, 18:41

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.