Buongiorno, utilizzo la versione nel titolo, che presenta i seguenti problemi:

  • quando non rimane bloccato con l'immagine di sfondo e non si vede la freccia mouse, posso fare solamente un'operazione, tipo aprire un programma o un file (es. browser, file Libre Office,...)
  • non funziona il dash, posso fare una sola ricerca, dalla seconda ricerca, non trova più niente
  • non vede più gli hd nonostante siano montati ...l'epilogo è sempre che si blocca con l'hd che "frulla" (luce sempre accesa)

Il blocco con hd costantemente utilizzato accadeva anche qualche mese fa (browser con molte finestre e/o programmi aperti) e pensavo di risolvere aumentando la RAM da 4 a 8 GB ( effettivamenteper circa un mese ha funzionato)

Inoltre è impossibile fare gli aggiornamenti, sia da Software center che da terminale con i seguenti errori:

  • problema sincronizzazione file - sync
  • impossibile rinominare il file /var/cache/apt/srcpkgcache.bin.TJ0C8r
  • impossibile rinominare il file /var/cache/apt/pkgcache.bin.7MHA1h (file system in sola lettura)

Ho provato ad utilizzare i kernel precedenti, ma i problemi persistono. Non so cosa fare, non installo niente da almeno due mesi, l'unica anomalia è l'inattività del pc per due settimane, e questa é stata la sorpresa...

Il pc è un Pentium G620 2.60Ghzx2, con scheda integrata Intel SandyBridge, 64bit, 8GB RAM

Grazie in anticipo

chiesto 05 Ago, 17:59

ShinGiTai's gravatar image

ShinGiTai
202

modificato 05 Ago, 18:06

Per il blocco per prima cosa prova a cancellare i dati di navigazione cookies compresi. Per gli aggiornamenti devi fare un'altra domanda; il regolamento di chiedi dice: una domanda ogni problema.

(05 Ago, 18:40) enzoge enzoge's gravatar image

che vedi da: df

(05 Ago, 21:14) sacarde sacarde's gravatar image

@enzoge ...perdonatemi per l'inesperienza, ma non ho capito: devo aprire una domanda diversa per ogni tipo di blocco? -quando non rimane bloccato con l'immagine di sfondo e non si vede la freccia mouse --non funziona il dash, posso fare una sola ricerca, dalla seconda ricerca, non trova più niente ---non vede più gli hd nonostante siano montati ...l'epilogo è sempre che si blocca con l'hd che "frulla" (luce sempre accesa) Ma per cancellazione cookies & co immagino tu intenda il browser, questo influenza anche il blocco da più software in esecuzione, escluso il browser?

(05 Ago, 22:34) ShinGiTai ShinGiTai's gravatar image

@sacarde non capisco cosa intendi per "che vedi da: df" :-(

(05 Ago, 22:36) ShinGiTai ShinGiTai's gravatar image

da terminale esegui questi comandi:

  • top (vedi i processi che usano + cpu e lo stato della memoria)
  • df (vedi le partizioni montate)
  • mount (vedi le opzioni di montaggio)
(05 Ago, 23:33) sacarde sacarde's gravatar image

@ShinGiTai: la release che usi ad aprile 2019 non sarà più supportata, per cui, a mio avviso, se possibile conviene trovare soluzioni che al più consentano di arrivare ad aprile senza affrontare spese, che comunque, è meglio prevedere.
Per quanto riguarda le domande, meglio fare una domanda per problema e cercare di distinguere i problemi, che potrebbero essere più d'uno.

(06 Ago, 07:16) enzoge enzoge's gravatar image
top - 13:08:23 up 3 min,  2 users,  load average: 0,76, 0,87, 0,40

Tasks: 216 total, 1 running, 215 sleeping, 0 stopped, 0 zombie %Cpu(s): 1,3 us, 0,8 sy, 0,0 ni, 97,5 id, 0,3 wa, 0,0 hi, 0,0 si, 0,0 st KiB Mem: 7893332 total, 2197244 used, 5696088 free, 101252 buffers KiB Swap: 7164 total, 0 used, 7164 free. 1019616 cached Mem

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND 1126 root 20 0 364148 42576 33256 S 2,0 0,5 0:04.54 Xorg 2041 m 20 0 1537304 136780 61136 S 1,3 1,7 0:06.66 compiz 2831 m 20 0 673120 30528 24040 S 1,0 0,4 0:00.19 gnome-term+ 2383 m 20 0 1154712 204036 110908 S 0,7 2,6 0:11.81 vivaldi-bin 2664 m 20 0 1167952 153588 75060 S 0,7 1,9 0:10.44 vivaldi-bin 1 root 20 0 33908 4348 2656 S 0,0 0,1 0:01.24 init 2 root 20 0 0 0 0 S 0,0 0,0 0:00.00 kthreadd 3 root 20 0 0 0 0 S 0,0 0,0 0:00.00 ksoftirqd/0 4 root 20 0 0 0 0 S 0,0 0,0 0:00.00 kworker/0:0 5 root 0 -20 0 0 0 S 0,0 0,0 0:00.00 kworker/0:+ 6 root 20 0 0 0 0 S 0,0 0,0 0:00.06 kworker/u4+ 7 root 20 0 0 0 0 S 0,0 0,0 0:00.21 rcu_sched 8 root 20 0 0 0 0 S 0,0 0,0 0:00.00 rcu_bh 9 root rt 0 0 0 0 S 0,0 0,0 0:00.00 migration/0 10 root rt 0 0 0 0 S 0,0 0,0 0:00.00 watchdog/0 11 root rt 0 0 0 0 S 0,0 0,0 0:00.00 watchdog/1 12 root rt 0 0 0 0 S 0,0 0,0 0:00.00 migration/1

df File system 1K-blocchi Usati Disponib. Uso% Montato su udev 3933900 4 3933896 1% /dev tmpfs 789336 1036 788300 1% /run /dev/sdb3 62564300 41105716 18257460 70% / none 4 0 4 0% /sys/fs/cgroup none 5120 0 5120 0% /run/lock none 3946664 30704 3915960 1% /run/shm none 102400 44 102356 1% /run/user /dev/sdb4 418844668 229495032 189349636 55% /mnt/2C161A4A2F3DA70C /dev/sda5 244187968 187195056 56992912 77% /mnt/D234F8E634F8CE8B /dev/sr0 585886 585886 0 100% /media/m/Ubuntu-MRT2

mount /dev/sdb3 on / type ext4 (rw,errors=remount-ro) proc on /proc type proc (rw,noexec,nosuid,nodev) sysfs on /sys type sysfs (rw,noexec,nosuid,nodev) none on /sys/fs/cgroup type tmpfs (rw) none on /sys/fs/fuse/connections type fusectl (rw) none on /sys/kernel/debug type debugfs (rw) none on /sys/kernel/security type securityfs (rw) udev on /dev type devtmpfs (rw,mode=0755) devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620) tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755) none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880) none on /run/shm type tmpfs (rw,nosuid,nodev) none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755) none on /sys/fs/pstore type pstore (rw) /dev/sdb4 on /mnt/2C161A4A2F3DA70C type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096) /dev/sda5 on /mnt/D234F8E634F8CE8B type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096) systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd) gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=m) /dev/sr0 on /media/m/Ubuntu-MRT2 type iso9660 (ro,nosuid,nodev,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500,uhelper=udisks2

(06 Ago, 13:16) ShinGiTai ShinGiTai's gravatar image

Non riesco ad incollare in maniera leggibile utilizzando "codice"...

inoltre é un gran problema perchè si blocca il pc continuamente.

(06 Ago, 13:17) ShinGiTai ShinGiTai's gravatar image

@enzoge Probabilmente ho espresso male il malfunzionamento. Il pc, quando lo consente, permette una sola operazione di quelle che ho elencato come problemi (che sono le sole che ho tentato). Dal secondo tentativo no funziona niente. Per questo credo che servano tutte insieme, per dare un quadro generale. I problemi non sono singoli, ma si verificano contemporaneamente (non si sono mai verificati prima)

(06 Ago, 13:34) ShinGiTai ShinGiTai's gravatar image

@enzoge Cerco di spiegarmi ancora meglio: dopo l'avvio apro un software X e questo funziona... (se il pc non si blocca prima) chiudo il software X e tento di riutilizzarlo, non si avvia. Faccio la ricerca sul dash... non trova niente (nessun sofware). Allora provo a cercare la cartella dall'hd... non si apre. Provo a riavviare il pc dall'icona dell'angolo in alto a destra... l'icona non risponde. Dalla seconda azione in poi, il risultato é il blocco del pc con il led hd sempre acceso.

Ricorda molto i virus di Windows...

(06 Ago, 13:34) ShinGiTai ShinGiTai's gravatar image

provato a pastare su: https://paste.ubuntu.com/ ?

  • non mi sembrano problemi di memoria ram
  • per l'aggiornamento esegui:

sudo apt update

sudo apt upgrade ?

  • quando si blocca accedi alla consolle: ctrl-alt=f1 ?
  • provato a entrare in recoverymode , si blocca anche li?
(06 Ago, 13:44) sacarde sacarde's gravatar image

@sacarde

https://paste.ubuntu.com/p/KrxhT9GHKX/

Per l'aggiornamento ho eseguito (upgrade va in blocco)

sudo apt-get update
sudo apt-get upgrade

In recovery mode, i comandi

  • dpkg
  • failsafex
  • fsck

si bloccano.

Per ctrl-alt+f1 provo mandandolo in blocco, dopo aver postato questa risposta...

(06 Ago, 16:57) ShinGiTai ShinGiTai's gravatar image

Quando il pc é bloccato, con ctrl+alt+f1 appare

[1047.974455] ata4:SRST failed (errno=-16)

[1053.450351] ata4.00: revalidation failed (errno=-5)

[1063.501670] ata4:SRST failed (errno=-16)

[1073.553169] ata4:SRST failed (errno=-16)

(06 Ago, 17:15) ShinGiTai ShinGiTai's gravatar image

Per completezza...

la versione utilizzata è 14.04.5 LTS

kernel 4.4.0-130

(06 Ago, 17:18) ShinGiTai ShinGiTai's gravatar image
  • non riesco a capire cosa e' che scatena il blocco... pensavo fosse "vivaldi", ma se si blocca anche in recovery... (oppure wayland)

  • esegui "top" e guarda cosa esegue quando l'hd si impalla

  • se esegui il livecd, si blocca anche da li'?

(06 Ago, 17:30) sacarde sacarde's gravatar image
  • per vedere i servizi con errori: systemctl --failed

  • per vedere messaggi di errori: journalctl -b -p err

  • hai aggiunto questo HD a mano da te? o in un certo senso, potrebbe essere un problema di cavi dell'HD ?

  • hai anche partizioni windows?

(06 Ago, 17:43) sacarde sacarde's gravatar image

@sacarde

:~$ systemctl --failed

systemctl: comando non trovato

:~$ journalctl -b -p err

journalctl: comando non trovato

oppure funziona solo dopo il blocco? Il problema è che quando si blocca, normalmente è impossibile aprire il Terminale

L'hardware del pc é lo stesso da almeno 4 anni (esclusa la RAM appena aggiunta) Windows abbandonato su altro pc, passato poi a Ubuntu Vengo dal 11.04, 12.04 LTS, poi 14.04 LTS.

18.04 LTS su notebook appena acquistato...

(06 Ago, 20:03) ShinGiTai ShinGiTai's gravatar image

Utilizzo Vivaldi, ma succede con tutti i browser, indifferentemente...

Eseguiró "top", se mi permetterà di aprire il Terminale...

Con il livecd, sembra funzionare

Ma non esiste da livecd la possibilità di riparare il S.O.? So che il recovery mode serve proprio a questo, ma nei casi disperati...

(06 Ago, 20:09) ShinGiTai ShinGiTai's gravatar image

Ulteriore malfunzionamento dopo il blocco:

Durante un blocco mentre utilizzavo il browser, ho atteso un bel po' di tempo e si è sbloccato da solo, permettendomi di utilizzare il browser, con la limitazione della scomparsa delle funzioni del tasto destro e del menu di Ubuntu in alto (quindi per spegnere solo il tasto del pc funziona)

Si bloccano anche eventuali download ed è impossibile continuare o ritentare.

(06 Ago, 20:16) ShinGiTai ShinGiTai's gravatar image

scusa, devi anteporre: sudo

(06 Ago, 20:22) sacarde sacarde's gravatar image

se da live non hai problemi, il problema potrebbe essere l'hard-disk?

o i cavi sata... o la scheda madre?

hai qualche altro sistema su quel PC ?

(06 Ago, 20:24) sacarde sacarde's gravatar image

No, solo Ubuntu

(06 Ago, 23:41) ShinGiTai ShinGiTai's gravatar image

~$ sudo systemctl --failed

sudo: systemctl: command not found

~$ sudo journalctl -b -p err

sudo: journalctl: command not found

(07 Ago, 00:03) ShinGiTai ShinGiTai's gravatar image

Mi sembra che il regolare funzionamento del sistema sia compromesso, e che ci siano probabilità di guasti hardware. A mio avviso si può provare a:
- capire se i problema è costante;
- fare mente locale per capire se i problemi sono apparsi dopo che è stato fatto qualcosa, e agire di conseguenza;
- togliere la spunta dal software center a tutti gli aggiornamenti, lasciando solo quelli ufficiali, e vedere se li esegue;
- fare le copie dei dati e reinstallare il sistema, aggiungendo poi uno alla volta eventuale altri software, provandoli a fondo prima di installare il successivo.

(07 Ago, 07:48) enzoge enzoge's gravatar image

scusami ancora... il 14.04 non aveva ancora systemd

per cui gli errori del kernel li vedi da: dmesg, tipo:

dmesg | grep error

dmesg | grep failed

  • ripeto la domanda: hai aggiunto tu l'HD, o toccato i cavi ?

  • eseguito, da rescue, il controllo della partizione fsck /dev/sdb3

(07 Ago, 08:50) sacarde sacarde's gravatar image

Ecco il risultato dopo dmesg

https://paste.ubuntu.com/p/scDRgg65WQ/

L'hd ha almeno 4 anni ed è passato per varie versioni di Ubuntu senza problemi, i cavi non sono stati toccati.

(07 Ago, 18:07) ShinGiTai ShinGiTai's gravatar image
  • sdb3 ha errori e viene montata in readonly

avvia con recoverymode e esegui un: fsck /dev/sdb3 o da un live

  • hai mai aperto un PC ?
(07 Ago, 21:51) sacarde sacarde's gravatar image

Il miracolo, spero...

fsck /dev/sdb3

non mi dava niente da live e da recovery, allora ho provato da recovery

fsck --help

e poi

fsck -c

mi é uscito un messaggio tipo FILE SYSTEM MODIFICATO, ho riavviato e tutto sembra funzionare (speriamo!) Ha anche rilevato aggiornamenti, scaricati correttamente (compreso kernel 4.4.0-132, in uso). Ora lo tengo acceso il piú possibile per vedere se si ripresentano problemi.

Rimangono gli errori... https://paste.ubuntu.com/p/n4RYHhvQjt/

PC ne ho aperti tanti, per hanni ho fatto assemblaggio, vendita ed assistenza pc in ambiente Windows

(08 Ago, 16:35) ShinGiTai ShinGiTai's gravatar image
  • dall'errore sembrerebbe ancora montato in readonly

per vedere come sono montate le partizioni esegui: mount

  • se te la senti potresti controllare i cavi degli hd
(08 Ago, 16:55) sacarde sacarde's gravatar image

mount

https://paste.ubuntu.com/p/hV2dsGXBcq/

I cavi sono a posto.

Il pc è acceso ancora senza segni di blocco.

Ho rilanciato un upgrade da terminale (operazione che precedentemente mandava tutto in blocco) senza problemi.

Ho effettuato dei download, impossibili in precedenza...

(08 Ago, 17:07) ShinGiTai ShinGiTai's gravatar image

ok, a posto

(08 Ago, 17:14) sacarde sacarde's gravatar image

...considerato che é stato un tentativo, quasi a caso, leggendo dal menu help di fsck, cosa ha modificato quel comando?

(08 Ago, 17:38) ShinGiTai ShinGiTai's gravatar image

dovrebbe aver detto le modifiche agli errori trovati nel filesystem...

l'opzione -c coma da manuale:

-c This option causes e2fsck to use badblocks(8) program to do a read-only scan of the device in order to find any bad blocks

(08 Ago, 17:50) sacarde sacarde's gravatar image

Ho pensato di lanciare anche

fsck -p (Automatic Repair)

ha senso, o rischio di bloccare di nuovo tutto?

(08 Ago, 18:00) ShinGiTai ShinGiTai's gravatar image

secondo me non fa nulla in piu' di quello che ti ha fatto/chiesto il normale fsck

(08 Ago, 20:22) sacarde sacarde's gravatar image

Ok, grazie a tutti per il supporto ed il tempo dedicato. Piuttosto non mi sembra possibile modificare l'oggetto con [Risolto] per chiudere...

(09 Ago, 08:29) ShinGiTai ShinGiTai's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×439
×273
×44

domanda posta: 05 Ago, 17:59

domanda visualizzata: 122 volte

ultimo aggiornamento: 09 Ago, 08:29

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.