Salve,

Ho creato una usb live con ubuntu 18.04 ma quando la avvio parte in automatico in modalità UEFI. Ho necessità di farla partire nella solita modalità BIOS perchè devo installarlo su un vecchio portatile.

Come fare?

chiesto 25 Ago, 14:23

avwindo's gravatar image

avwindo
9

(25 Ago, 14:55) enzoge enzoge's gravatar image

Ho già letto! Il problema è che la live mi si carica in automatico in modalità UEFI, invece ho un vecchio notebook in cui ho bios. Se installo UEFI non parte, va in loop dopo la schermata in cui si può accedere al BIOS. Ho necessità che la live si avvii in modalità BIOS classica altrimenti non posso installare

(25 Ago, 15:30) avwindo avwindo's gravatar image

Per le comunicazioni bisogna usare i commenti. Commuto io la tua risposta.

(25 Ago, 15:51) enzoge enzoge's gravatar image

Grazie, mi scuso. Il problema però è rimasto

(25 Ago, 15:56) avwindo avwindo's gravatar image

@avwindo: per fortuna Ubuntu sa riconoscere se il PC ha firmware UEFI o se ha il vecchio BIOS e comportarsi adeguatamente.

Se il PC è UEFI avvia l'installazione im modalità UEFI, altrimenti BIOS.

coll. permanente

ha risposto 25 Ago, 16:02

enzoge's gravatar image

enzoge
4.7k233987

Purtroppo non sempre è così, c'è scritto anche sul wiki. Ti assicuro che io ho il BIOS e non l'uefi, infatti se entro nel BIOS non esiste il fast boot, UEFI mode non è contemplata e non esiste possibilità di scelta. Per questo ho chiesto qui

(25 Ago, 16:12) avwindo avwindo's gravatar image

Invece è certamente UEFI. Il fatto che tu non veda fast boot non vuol dire. Fra l'altro, se non è un PC particolare, cliccando su UEFI dovrebbe permettere l'installazione Legacy (come il vecchio BIOS).

(25 Ago, 16:25) enzoge enzoge's gravatar image
  • riesci a arrivare all'avvio di grub?

  • quali sistemi hai avuto su quel PC ?

p.s. https://wiki.ubuntu-it.org/Installazione/InstallareUbuntu

(25 Ago, 17:26) sacarde sacarde's gravatar image

Non riesco purtroppo ad arrivare a grub quando avvio da HD, si riavvia in automatico in un loop infinito. Il notebook aveva di serie windows 7 che è stato piallato con l'installazione di Ubuntu Gnome 14.04

(26 Ago, 00:23) avwindo avwindo's gravatar image

@sacarde: avevo capito che la domanda si riferisse alla pendrive che, con un PC "particolare", difettosa o creata con un file scaricato male(vedi verifica MD5), voleva installare sempre in modalità UEFI anche PC dotati del vecchio BIOS.
Quindi fatte le verifiche del download come consigliato nel primo commento (dove consigliavo di attenersi alle guide italiane ufficiali), credo che la prima cosa da fare sia una verifica del firmware per vedere che sia regolarmente funzionante e soprattutto, che non sia stato oggetto di manipolazioni.

(26 Ago, 09:34) enzoge enzoge's gravatar image

potrebbe essere un problema di firmware, quando faccio partire la live mi da sempre questo errore prima di avviarsi:

MODSIGN: Couldn't get UEFI db list

Per questo sostengo che non ha uefi ma bios

(26 Ago, 11:30) avwindo avwindo's gravatar image

qui risolvono con:

I was able to stop the errors simply by changing a setting in the BIOS from [Customized] to [Standard] for Secure Boot Mode.

https://ubuntuforums.org/showthread.php?t=2380700

(26 Ago, 11:41) sacarde sacarde's gravatar image

Niente, non c'è verso. Sto provando a installare 16.04 e aggiornare alla 18.04. Con la 16 mi fa scegliere se usare uefi o bios

(26 Ago, 16:52) avwindo avwindo's gravatar image

quale portatile e'?

(26 Ago, 17:23) sacarde sacarde's gravatar image

Fujitsu lifebook e751

Provato a installare Ubuntu 16.04 in modalità uefi e funziona, fatto aggiornamento a 18.04 e da lo stesso problema. Ne deduco che ho uefi anche se non viene menzionato da nessuna parte, non posso scegliere se attivare o meno il fastboot, deve essere per forza un problema di firmware.

@enzoge avevi ragione, quando ho installato 16.04 mi ha chiesto se volevo usare uefi o BIOS e con uefi ha funzionato subito

(27 Ago, 11:53) avwindo avwindo's gravatar image

quindi la 16.04 la installi uefi

una volta aggiornata, non si riavvia? non parte nemmeno grub?

(27 Ago, 11:58) sacarde sacarde's gravatar image

Esatto, arriva alla schermata dove puoi accedere al menù del firmware e si riavvia in loop

(27 Ago, 17:34) avwindo avwindo's gravatar image
  • senza arrivare al grub... si puo' fare poco...

  • sicuro che non si possa impostare modalita' "legacy" ?

(27 Ago, 17:53) sacarde sacarde's gravatar image

Sicurissimo, quando installò la 16 mi chiede se voglio procedere come uefi o BIOS, con la 18 no

(27 Ago, 19:18) avwindo avwindo's gravatar image

probabilmente la 1804 rileva da se il tipo di firmware ?

(27 Ago, 21:20) sacarde sacarde's gravatar image

@avwindo: il fatto che la 18.04 non funzioni, può dipendere dai driver o anche dalla vetustà del pc. Questo argomento però deve essere sviluppato con un'altra domanda, regolamento, faq e manuale, i cui link trovi sulla destra di questa pagina, dicono chiaramente di fare una domanda èer problema.
È da molto tempo che nella maggior parte dei casi do ragione al computer, e anche stavolta è stato così. Per chiudere la domanda correttamente devi accettare la mia risposta, in modo che altri con lo stesso problema possano avvantaggiarsene.

(28 Ago, 08:24) enzoge enzoge's gravatar image

e il 16.04 provassi a installarlo bios?

(28 Ago, 08:43) sacarde sacarde's gravatar image

@sacarde: in genere sui computer EFI una installazione tipo vecchio BIOS, viene denominata "Legacy". Se non sbaglio la UEFI, a differenza della Legacy, consente la creazione di molte più suddivisioni del disco; oltre a consentire sui pc più aggiornati, l'installazione dei software certificati, come Ubuntu con il Secure boot attivo.

(28 Ago, 09:00) enzoge enzoge's gravatar image
-1

La live di Ubuntu riconosce in automatico il tipo di firmware installato sul PC, non ho risolto il problema al PC ma almeno sappiamo che il riconoscimento è comunque giusto, al contrario di quello che credevo

(28 Ago, 09:39) avwindo avwindo's gravatar image

quindi quello che servirebbe, poter avviare il PC in modalita Legacy

o restare sulla 16.04

(28 Ago, 09:52) sacarde sacarde's gravatar image

Se però la 18.04 non va e si vuole tentare di farla funzionare, è meglio fare una nuova domanda che spieghi come non si riesce ad installarla su un pc UEFI. Domanda possibilmente corredata dalle specifiche hardware del pc.

(28 Ago, 10:53) enzoge enzoge's gravatar image

Certo, possiamo chiudere qui

(28 Ago, 12:31) avwindo avwindo's gravatar image

Accettare una risposta corretta è utile alla comunità e a chi fa domande.

(28 Ago, 13:27) enzoge enzoge's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×100
×60
×20

domanda posta: 25 Ago, 14:23

domanda visualizzata: 99 volte

ultimo aggiornamento: 28 Ago, 13:27

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.