Ho di recente installato Ubuntu 18.04 tramite USB.

Ho prima impostato la USB CDROM come prima nell'ordine prioritario d'avvio del BIOS al fine di installare il SO, ma al termine dell'installazione, quando mi chiede di riavviare il computer, mi ritrovo davanti ad un avviso:

"Default boot device missing or boot failed. Insert recovery media and hit any key Then select 'Boot manager' to choose a new boot device or to boot recovery media"

Pensando che fosse a causa della precedente alterazione dell Boot Priority Order, quindi ho riavviato, sono entrato nel BIOS e ho caricato le impostazioni di default. Ma non è cambiato niente e ogni volta che provo a riavviare mi si ripresenta la stessa finestra.

Cosa devo fare?

Grazie in anticipo

chiesto 31 Ago, 09:34

renzotramaglino998's gravatar image

renzotramagl...
2013

modificato 01 Set, 19:36

dove hai installato grub?

potresti ripristinarlo: https://wiki.ubuntu-it.org/AmministrazioneSistema/Grub/Ripristino

(31 Ago, 10:27) sacarde sacarde's gravatar image

Quando ho installato Ubuntu ho scelto l'opzione "cancella disco e installa", quindi credo di aver eliminato ogni preesistente partizione. Non riesco a superare la schermata del BIOS, come faccio a ripristinare GRUB?

(31 Ago, 13:20) renzotramagl... renzotramaglino998's gravatar image

devi andare oltre la schermata del bios, o dal "menu di boot" selezionare cd/usb

una volta avviata la live, ripristinare/installare grub in /dev/sda (che e' lo standard)

(31 Ago, 14:08) sacarde sacarde's gravatar image

Ok, ho provato, aprendo Ubuntu in live e, nella versione prova (l'unica che mi lascia aprire) seguendo le istruzioni nella pagina da te indicata mi. Tutto liscio, ma al riavvio del computer mi compare la solita schermata (quando tolgo la USB) o la finestra d'installazione di Ubuntu (quando la lascio)

(31 Ago, 16:56) renzotramagl... renzotramaglino998's gravatar image

riesci da bios, premendo f11, menu di boot, selezionando l'HD, a avviare il grub installato su /dev/sda ?

(31 Ago, 17:44) sacarde sacarde's gravatar image

No, premo F11 ma non succede nulla

(01 Set, 09:57) renzotramagl... renzotramaglino998's gravatar image

forse e' un bios vecchio... ci dovrebbe essere una voce.. (una volta entrato nei parametri), dove imposti l'ordine di avvio dei dispositivi (hd, cdrom, usb ...ecc)

(01 Set, 10:08) sacarde sacarde's gravatar image

Sono riuscito ad aprire il menù con F2. L'ordine di priorità è 1 HDD0: ST500LT012-1DG142

2 HDD1:

3 ATAPI CDROM: Sliktype DVD A DA8AESH

4 USB FDD:

5 Network Boot-IPV4

6 USB HDD:

7 USB CDROM:

8 Network Boot-IPV6

9 EFI File Boot 0: y

L'ultimo (y) è anche l'unica opzione disponibile quando, dopo aver risposto ok all'avviso del boot fallito, mi apre la schermata delle opzionj

(01 Set, 10:46) renzotramagl... renzotramaglino998's gravatar image

quindi pc uefi con installazione uefi...

io di uefi non me ne intendo ma la partizione /boot (uefi/vfat) deve essere la prima

p.s. https://wiki.ubuntu-it.org/Installazione/InstallareUbuntu

(01 Set, 11:01) sacarde sacarde's gravatar image

Infatti controllando le partizioni con la Live ho visto che

-> /dev/sda1 = partizione EFI

-> /dev/sda2 = partizione di sistema

Consigli di utilizzare il programma Boot Repair?

(01 Set, 11:10) renzotramagl... renzotramaglino998's gravatar image

e' la prima volta che installi linux-uefi su quel pc?

letto? https://wiki.ubuntu-it.org/AmministrazioneSistema/Grub/Ripristino/Uefi

(01 Set, 11:40) sacarde sacarde's gravatar image

E' di seconda mano, c'era già installato un sistema linux 64bit che ho eliminato quando ho installato Ubuntu 18.

Sì, ho seguito le istruzioni dopo aver aperto il terminale sulla versione prova di Ubuntu da Live, ma non è cambiato niente

(01 Set, 12:01) renzotramagl... renzotramaglino998's gravatar image
  • non capisco come mai non venga detto di lanciare: grub-install /dev/sda (al posto di grub-install)

  • oppure provare un'installazione dopo aver impostato da bios la modalita' legacy (no uefi)

(01 Set, 13:42) sacarde sacarde's gravatar image

Ho trovato la soluzione. Avevi ragione tu, è un problema di "costruzione" degli Acer ed in generale di tutti i pc UEFI. UEFI non riconosce ubuntu come un programma "sicuro" e non mi permetteva di installarlo. Quindi ho dovuto aggiungerlo manualmente all'elenco dei programmi "fidati" dal BIOS. Posto le istruzioni (io ho letto dal punto 35 in avanti): https://askubuntu.com/questions/627416/acer-aspire-e15-will-not-dual-boot

(01 Set, 19:35) renzotramagl... renzotramaglino998's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,728
×790
×185
×62
×21

domanda posta: 31 Ago, 09:34

domanda visualizzata: 140 volte

ultimo aggiornamento: 01 Set, 19:36

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.