Ciao ho da poco installato su un acer aspire E11 windows 8 ubuntu 16.04 sembra andare tutto bene tranne che il pc non si spegne da solo in nessuna maniera ...ho letto tutto quello che ho trovato e provato anche di più ...nulla lo devo spegnere ogni volta col tasto chi può aiutarmi prima che il pc muoia grazie in anticipo a tutti

chiesto 03 Set, 12:51

lunadilan's gravatar image

lunadilan
2013

quali prove hai fatto?

passato al kernel: acpi=off noapic nolapic

p.s. con quale comando spegni? poweroff

halt -p

(03 Set, 14:11) sacarde sacarde's gravatar image

ho provato anche i 2 che hai scritto ma niente nemmeno quelli il risultato è sempre lo stesso

(03 Set, 16:56) lunadilan lunadilan's gravatar image

si provato ma nulla

(03 Set, 17:09) lunadilan lunadilan's gravatar image

123avanti »

ho provato tutti i comandi che ho trovato sull argomento ma niente adesso spengo con il tasto perchè dopo che ho dato lo spegnimento dal pc o dal terminale mi chiude tutto resta schermo nero con cursore fisso in alto a sx

coll. permanente

ha risposto 03 Set, 16:55

lunadilan's gravatar image

lunadilan
2013

passato al kernel: acpi=off noapic nolapic

?

(03 Set, 16:57) sacarde sacarde's gravatar image

si anche quello...ho provato a fare l aggiornamento alla 18.04 e mi dà questo errore Si sono verificati degli errori nell'elaborazione: linux-image-extra-4.13.0-36-generic linux-image-4.13.0-36-generic E: Sub-process /usr/bin/dpkg returned an error code (1)

(03 Set, 17:13) lunadilan lunadilan's gravatar image

possono essere collegati ?

(03 Set, 17:13) lunadilan lunadilan's gravatar image
(03 Set, 17:42) sacarde sacarde's gravatar image

no non si è concluso mi ha dato l errore che ti ho scritto sopra

Si sono verificati degli errori nell'elaborazione: linux-image-extra-4.13.0-36-generic linux-image-4.13.0-36-generic E: Sub-process /usr/bin/dpkg returned an error code (1)

(03 Set, 18:00) lunadilan lunadilan's gravatar image

hai seguito il link?

(03 Set, 18:05) sacarde sacarde's gravatar image

no non si è concluso ..mi dice Si sono verificati degli errori nell'elaborazione: linux-image-extra-4.13.0-36-generic linux-image-4.13.0-36-generic E: Sub-process /usr/bin/dpkg returned an error code (1)

(03 Set, 18:23) lunadilan lunadilan's gravatar image

aggiornamento bionic mi dà lo stesso errore

(03 Set, 18:24) lunadilan lunadilan's gravatar image

per l'aggiornamento di una release:

sudo apt-get update

sudo apt-get upgrade

sudo apt-get dist-upgrade

(03 Set, 18:40) sacarde sacarde's gravatar image

Si sono verificati degli errori nell'elaborazione: linux-image-extra-4.13.0-36-generic linux-image-4.13.0-36-generic E: Sub-process /usr/bin/dpkg returned an error code (1)

(03 Set, 19:20) lunadilan lunadilan's gravatar image

ma quanti kernel hai?

sudo dpkg -l | grep linux-image

p.s. non capisco dove venga fuori il kernel 4.13 hai personalizzato i repo o hai degli ppa?

(03 Set, 20:13) sacarde sacarde's gravatar image

per il repo o il ppa non so ne stò provando di tutte ..... ti posto il risultato del sudo dpkg -l | grep linux-image

(03 Set, 20:50) lunadilan lunadilan's gravatar image

rH linux-image-4.13.0-36-generic 4.13.0-36.40~16.04.1 amd64 Linux kernel image for version 4.13.0 on 64 bit x86 SMP ii linux-image-4.13.0-39-generic 4.13.0-39.44~16.04.1 amd64 Linux kernel image for version 4.13.0 on 64 bit x86 SMP iF linux-image-4.13.0-41-generic 4.13.0-41.46~16.04.1 amd64 Linux kernel image for version 4.13.0 on 64 bit x86 SMP rH linux-image-extra-4.13.0-36-generic 4.13.0-36.40~16.04.1 amd64 Linux kernel extra modules for version 4.13.0 on 64 bit x86 SMP ii linux-image-extra-4.13.0-39-generic 4.13.0-39.44~16.04.1 amd64 Linux kernel extra modules for version 4.13.0 on 64 bit x86 SMP iU linux-image-extra-4.13.0-41-generic 4.13.0-41.46~16.04.1 amd64 Linux kernel extra modules for version 4.13.0 on 64 bit x86 SMP iU linux-image-generic-hwe-16.04 4.13.0.41.60 amd64 Generic Linux kernel image

coll. permanente

ha risposto 03 Set, 20:48

lunadilan's gravatar image

lunadilan
2013

  • dal grub puoi avviare diversi kernel?

  • che vedi dal comando: uname -a

  • prova a eseguire: apt-get -f install

Tenta di di riparare i pacchetti con delle dipendenze non soddisfatte.

(03 Set, 21:24) sacarde sacarde's gravatar image

in uname -a mi dà quEsto -Aspire-ES1-111M 4.13.0-39-generic #44~16.04.1-Ubuntu SMP Thu Apr 5 16:43:10 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

apt-get -f install stesso risultato

Si sono verificati degli errori nell'elaborazione: linux-image-extra-4.13.0-36-generic linux-image-4.13.0-36-generic E: Sub-process /usr/bin/dpkg returned an error code (1)

coll. permanente

ha risposto 04 Set, 12:43

lunadilan's gravatar image

lunadilan
2013

mah...

puoi disinstallare il vecchio kernel 4.13.0-36 cioe' i due pacchetti:

sudo apt purge linux-image-extra-4.13.0-36-generic

sudo apt purge linux-image-4.13.0-36-generic

(04 Set, 13:43) sacarde sacarde's gravatar image

no il primo mi rimanda questo E: Impossibile impostare il blocco /var/lib/dpkg/lock - open (11: Risorsa temporaneamente non disponibile) E: Impossibile acquisire il blocco sulla directory di amministrazione (/var/lib/dpkg/). Un altro processo potrebbe tenerla occupata

il secondo ...solita cosa

Si sono verificati degli errori nell'elaborazione: linux-image-extra-4.13.0-36-generic linux-image-4.13.0-36-generic E: Sub-process /usr/bin/dpkg returned an error code (1)

(04 Set, 18:08) lunadilan lunadilan's gravatar image

vorrei disinstallare e installare la 18.04 almeno per vedere se il pc si spegne da solo,ma ho paura di fare ulteriori casini

(04 Set, 18:12) lunadilan lunadilan's gravatar image

mmm

proviamo... a reinstallarli e cancellarli in seguito:

sudo apt-get install -f linux-image-extra-4.13.0-36-generic

sudo apt-get install -f linux-image-4.13.0-36-generic

(04 Set, 18:15) sacarde sacarde's gravatar image

Nulla di fatto riporta sempre gli stessi errori

Si sono verificati degli errori nell'elaborazione: linux-image-extra-4.13.0-36-generic linux-image-4.13.0-36-generic E: Sub-process /usr/bin/dpkg returned an error code (1)

(04 Set, 19:28) lunadilan lunadilan's gravatar image
  • la prova se si spegne puoi farla con il dvd live di ubuntu-18.04

  • per l'errore su quei 2 pacchetti aspettiamo i suggerimenti di qualcuno "bravo"

  • sudo mv /var/lib/dpkg/info/linux-image-4.13.0-36-generic* /tmp/

sudo mv /var/lib/dpkg/info/linux-image-extra-4.13.0-36-generic* /tmp/

(04 Set, 20:19) sacarde sacarde's gravatar image

riesco solo a fare la chiavetta ...cmq si aspettiamo ...vediamo ma credo che l unica sia disinstallare il tutto....grazie 1000

(04 Set, 21:28) lunadilan lunadilan's gravatar image

giusto per aggiornarti ..da terminale son riuscita a d aggiornare alla versione 18.04...ma i problemi rimangono...il pc non si spegne se non con il tasto e cmq continua a darmi lo stesso errore
Rimuovere tutti i pacchetti di terze parti, quindi riprovare. problema il linux-image 4.13.0.41generic non e possibile segnalare il problema.

coll. permanente

ha risposto 05 Set, 21:22

lunadilan's gravatar image

lunadilan
2013

prima non erano per la versione: 4.13.0-36 ?

  • quanti e quali kernel puoi avviare da grub?
(05 Set, 21:38) sacarde sacarde's gravatar image

° PPA non so non credo cmq seguendo l articolo mi è uscito questo Aspire-ES1-111M:~$ sudo apt install update-manager-core [sudo] password di Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto Alcuni pacchetti non possono essere installati. Questo può voler dire che è stata richiesta una situazione impossibile oppure, se si sta usando una distribuzione in sviluppo, che alcuni pacchetti richiesti non sono ancora stati creati o sono stati rimossi da Incoming. Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte: gnupg : Rompe: software-properties-common (<= 0.96.24.3) ma la versione 0.96.20.7 sta per essere installata E: Errore, pkgProblemResolver::Resolve ha generato delle interruzioni. Questo potrebbe essere causato da pacchetti bloccati.

si giusto prima era la 4.13.0-36

per i kernel non ne ho idea porta pazienza ma sono un pò come dire alle prime armi

coll. permanente

ha risposto 05 Set, 22:46

lunadilan's gravatar image

lunadilan
2013

modificato 05 Set, 22:47

  • per vedere quale kernel stai usando: uname -a

  • per vedere i kernel installati (oltre che dalle entrate in grub) puoi trovarli in: /boot

(05 Set, 23:39) sacarde sacarde's gravatar image

uname-a Aspire-ES1-111M 4.13.0-39-generic #44~16.04.1-Ubuntu SMP Thu Apr 5 16:43:10 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux mentre /boot non so dove devo darlo

coll. permanente

ha risposto 06 Set, 09:53

lunadilan's gravatar image

lunadilan
2013

  • i kernel che hai lo vedi dai relativi file: ls -l /boot o da: dpkg -l | grep linux-image

  • strano che non ti trovi il 4.15. provato a dare: sudo apt update

sudo apt list --upgradable

  • comunque hai provato a aggiungere quei parametri "acpi=off noapic nolapic" al kernel ? ( o da grub o in /etc/default/grub )
(06 Set, 10:12) sacarde sacarde's gravatar image

fatto non tutto però

(06 Set, 12:38) lunadilan lunadilan's gravatar image

ok ma ls -l /boot o da: dpkg -l | grep linux-image dove lo devo digitare ?? sudo apt update sudo apt list --upgradable credo sia andato tutto ok per entrambi ...è uscita una marea di roba vuoi che te la posto ? Ma alla fine non ha dato errori per i parametri "acpi=off noapic nolapic" in /etc/default/grub mi dice permesso negato

coll. permanente

ha risposto 06 Set, 12:37

lunadilan's gravatar image

lunadilan
2013

  • i comandi vanno dati in una consolle

  • il comando "sudo apt list --upgradable" ti visualizza tutti i pacchetti che hanno un aggiornamento, vedi qualche "linux-image..." ? potresti aggiornare il kernel a quella versione

  • per inserire quei parametri devi anteporre "sudo" al comando di editor che vuoi usare, es. sudo nano /etc/default/grub

lettura https://wiki.ubuntu-it.org/AmministrazioneSistema/Grub#Impostazioni

(06 Set, 13:42) sacarde sacarde's gravatar image

letto e trovato grub

(06 Set, 13:55) lunadilan lunadilan's gravatar image

grazie mille per la pazienza gli unici file image sono questi ma niente linux : imagemagick/bionic-updates,bionic-security,bionic-security 8:6.9.7.4+dfsg-16ubuntu6.3 amd64 [aggiornabile da: 8:6.8.9.9-7ubuntu5.9] imagemagick-6.q16/bionic-updates,bionic-security,bionic-security 8:6.9.7.4+dfsg-16ubuntu6.3 amd64 [aggiornabile da: 8:6.8.9.9-7ubuntu5.9] imagemagick-common/bionic-updates,bionic-updates,bionic-security,bionic-security,bionic-security,bionic-security 8:6.9.7.4+dfsg-16ubuntu6.3 all [aggiornabile da: 8:6.8.9.9-7ubuntu5.9]

/boot/grub/grub.cfg.

For full documentation of the options in this file, see:

info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0

GRUB_HIDDEN_TIMEOUT=0

GRUB_HIDDEN_TIMEOUT_QUIET=true GRUB_TIMEOUT=10 GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" GRUB_CMDLINE_LINUX=""

Uncomment to enable BadRAM filtering, modify to suit your needs

This works with Linux (no patch required) and with any kernel that obtains

the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

Uncomment to disable graphical terminal (grub-pc only)

dove esattamente devo aggiungere ??

coll. permanente

ha risposto 06 Set, 13:54

lunadilan's gravatar image

lunadilan
2013

  • strano non ci sono aggiornamenti al kernel

  • devi editare la riga con: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" togliendo "quiet splash" e mettendo "acpi=off noapic nolapic"

poi salvi e esci dall'editor, e esegui sudo update-grub e riavvii

(06 Set, 14:04) sacarde sacarde's gravatar image

niete apro il grub da terminale sempre nel terminale modifico ma poi non riesco a salvare

(06 Set, 17:06) lunadilan lunadilan's gravatar image

ho fatto con sudo gedit /etc/default/grub ma nulla non funziona

(06 Set, 17:17) lunadilan lunadilan's gravatar image
  • riesci a inserire i parametri ma non si spegne?

  • ma da live della 18.04 riesci a spegnere?

  • sei sicura che l'aggiornamento alla 18.04 si sia completato correttamente? dai questi comandi:

lsb_release -a

cat /etc/apt/sources.list

(06 Set, 17:29) sacarde sacarde's gravatar image

si esatto inseriti e non funziona,non si è mai spento da solo sempre con il tasto

Aspire-ES1-111M:~$ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 18.04.1 LTS Release: 18.04 Codename: bionic

(06 Set, 17:33) lunadilan lunadilan's gravatar image

si esatto inserisco ma non si spegne.non si è mai spento solo col tasto

Aspire-ES1-111M:~$ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 18.04.1 LTS Release: 18.04 Codename: bionic

(06 Set, 17:46) lunadilan lunadilan's gravatar image

Aspire-ES1-111M:~$ cat /etc/apt/sources.list

deb cdrom:[Xubuntu 16.04.4 LTS Xenial Xerus - Release amd64 (20180228)]/ xenial main multiverse restricted universe

See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to

newer versions of the distribution.

deb http://archive.ubuntu.com/ubuntu bionic main restricted deb-src http://archive.ubuntu.com/ubuntu bionic multiverse universe restricted main

Major bug fix updates produced after the final release of the

distribution.

deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted deb-src http://archive.ubuntu.com/ubuntu bionic-updates multiverse universe restricted main

N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

team. Also, please note that software in universe WILL NOT receive any

review or updates from the Ubuntu security team.

deb http://archive.ubuntu.com/ubuntu bionic universe

deb-src http://it.archive.ubuntu.com/ubuntu/ xenial universe

deb http://archive.ubuntu.com/ubuntu bionic-updates universe

deb-src http://it.archive.ubuntu.com/ubuntu/ xenial-updates universe

N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

team, and may not be under a free licence. Please satisfy yourself as to

your rights to use the software. Also, please note that software in

multiverse WILL NOT receive any review or updates from the Ubuntu

security team.

deb http://archive.ubuntu.com/ubuntu bionic multiverse

deb-src http://it.archive.ubuntu.com/ubuntu/ xenial multiverse

deb http://archive.ubuntu.com/ubuntu bionic-updates multiverse

deb-src http://it.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

N.B. software from this repository may not have been tested as

extensively as that contained in the main release, although it includes

newer versions of some applications which may provide useful features.

Also, please note that software in backports WILL NOT receive any review

or updates from the Ubuntu security team.

Uncomment the following two lines to add software from Canonical's

'partner' repository.

This software is not part of Ubuntu, but is offered by Canonical and the

respective vendors as a service to Ubuntu users.

deb http://archive.canonical.com/ubuntu bionic partner

deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://archive.ubuntu.com/ubuntu bionic-security main restricted

deb-src http://archive.ubuntu.com/ubuntu bionic-security multiverse universe restricted main

deb http://archive.ubuntu.com/ubuntu bionic-security universe

deb-src http://security.ubuntu.com/ubuntu xenial-security universe

deb http://archive.ubuntu.com/ubuntu bionic-security multiverse

deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse

deb http://archive.ubuntu.com/ubuntu bionic restricted main universe multiverse deb-src http://archive.ubuntu.com/ubuntu bionic restricted main universe multiverse #Added by software-properties deb http://security.ubuntu.com/ubuntu/ bionic-security universe main restricted multiverse deb http://archive.ubuntu.com/ubuntu bionic-updates universe main restricted multiverse

coll. permanente

ha risposto 06 Set, 17:33

lunadilan's gravatar image

lunadilan
2013

Aspire-ES1-111M:~$ cat /etc/apt/sources.list

deb cdrom:[Xubuntu 16.04.4 LTS Xenial Xerus - Release amd64 (20180228)]/ xenial main multiverse restricted universe

See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to

newer versions of the distribution.

deb http://archive.ubuntu.com/ubuntu bionic main restricted deb-src http://archive.ubuntu.com/ubuntu bionic multiverse universe restricted main

Major bug fix updates produced after the final release of the

distribution.

deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted deb-src http://archive.ubuntu.com/ubuntu bionic-updates multiverse universe restricted main

N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

team. Also, please note that software in universe WILL NOT receive any

review or updates from the Ubuntu security team.

deb http://archive.ubuntu.com/ubuntu bionic universe

deb-src http://it.archive.ubuntu.com/ubuntu/ xenial universe

deb http://archive.ubuntu.com/ubuntu bionic-updates universe

deb-src http://it.archive.ubuntu.com/ubuntu/ xenial-updates universe

N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

team, and may not be under a free licence. Please satisfy yourself as to

your rights to use the software. Also, please note that software in

multiverse WILL NOT receive any review or updates from the Ubuntu

security team.

deb http://archive.ubuntu.com/ubuntu bionic multiverse

deb-src http://it.archive.ubuntu.com/ubuntu/ xenial multiverse

deb http://archive.ubuntu.com/ubuntu bionic-updates multiverse

deb-src http://it.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

N.B. software from this repository may not have been tested as

extensively as that contained in the main release, although it includes

newer versions of some applications which may provide useful features.

Also, please note that software in backports WILL NOT receive any review

or updates from the Ubuntu security team.

Uncomment the following two lines to add software from Canonical's

'partner' repository.

This software is not part of Ubuntu, but is offered by Canonical and the

respective vendors as a service to Ubuntu users.

deb http://archive.canonical.com/ubuntu bionic partner

deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://archive.ubuntu.com/ubuntu bionic-security main restricted

deb-src http://archive.ubuntu.com/ubuntu bionic-security multiverse universe restricted main

deb http://archive.ubuntu.com/ubuntu bionic-security universe

deb-src http://security.ubuntu.com/ubuntu xenial-security universe

deb http://archive.ubuntu.com/ubuntu bionic-security multiverse

deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse

deb http://archive.ubuntu.com/ubuntu bionic restricted main universe multiverse deb-src http://archive.ubuntu.com/ubuntu bionic restricted main universe multiverse #Added by software-properties deb http://security.ubuntu.com/ubuntu/ bionic-security universe main restricted multiverse deb http://archive.ubuntu.com/ubuntu bionic-updates universe main restricted multiverse

coll. permanente

ha risposto 06 Set, 17:47

lunadilan's gravatar image

lunadilan
2013

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×1,728
×148

domanda posta: 03 Set, 12:51

domanda visualizzata: 447 volte

ultimo aggiornamento: 27 Ott, 11:04

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.