Salve a tutti,

Utlizzo Ubuntu 14.04 LTS, non riesco ad installare una versione di firefox precedente all'ultima che è la Firefox 60. Io vorrei installare la versione : Firefox 52.9.0 ESR (32 bit) più stabile e funzionante . Ma Non c'è verso!!! Se la lancio da terminale mi installa sempre l'ultima. Poi cosa ho fatto:

Innanzitutto dal sito mozilla : https://ftp.mozilla.org/pub/firefox/releases/52.9.0esr/ dalla lista che appare su questo sito già non so quale scaricare: la linux_i686 in alto (sempre in tar.bz2) oppure quella piu in basso firefox-52.9.0esr.linux-i686.sdk.tar.bz2? che significa sdk? E' la versione piu completa visto che è 150 mega? Come installo un tar.bz2 (mai capito come si installa un pacchetto di questo tipo!!!) ho provato varie procedure online che mi riportavano a scaricare mozilla in formato debian (ma non dal sito originale) ma poi al dunque il mio Ubuntu mi dice che mancano delle dipendenze e mi consiglia di dare dei comandi da terminale per soddisfarle. Appena seguo le indicazioni mi aggiusta tutto ma alla versione 60. Sono un mezzo principiante di Ubuntu per favore chi volesse aiutarmi scriva i comandi da dare tutti di seguito e mi dica come installarla. Ho scaricato dal sito di mozilla indicato sopra entrambe. A questo punto chissà che casino avrò combinato tentando di installarlo e disinstallarlo varie volte pure col purge. Alla fine come la metti la metti mi rimette a posto tutto sempre alla 60. Grazie mille

chiesto 04 Ott, 13:59

agostinom74's gravatar image

agostinom74
10144


Salve,

avevo già seguito questo:

sudo add-apt-repository ppa:mozillateam/ppa sudo apt-get update sudo apt-get install firefox-esr

mi installa firefox 60 ... difatti anche la versione 60 è ESR.... ho riprovato adesso... a seguire tramite repository, entrambe le procedure, mi ha installato Firefox Quantum 60.2.2esr (32bit)... se riuscissi a capire come si installa un pacchetto tar.bz2 su Ubuntu forse facendo il dowload dal sito di mozilla della versione desiderata potrei installarla... grazie a tutti... ho trovato istruzioni in rete per installare i tar.bz2 tipo ./compile configure (copiate nella sintassi corretta) ma non me lo fa installare ... Ubuntu mi da degli errori e non essendo esperto non so cosa vuole.

coll. permanente

ha risposto 05 Ott, 10:47

agostinom74's gravatar image

agostinom74
10144

modificato 05 Ott, 11:12

su questo:

ppa:jonathonf/firefox-esr-52

c'e': firefox-esr 52.9.0esr-1~14.04.york0

(05 Ott, 10:50) sacarde sacarde's gravatar image

hai tolto l'altro ppa:mozilla...

aggiunto il ppa:jonathon...

sudo add-apt-repository ppa:jonathonf/firefox-esr-52 sudo apt-get update sudo apt-get install firefox-esr

(05 Ott, 11:05) sacarde sacarde's gravatar image

sudo add-apt-repository ppa:jonathonf/firefox-esr-52

sudo apt-get update

sudo apt-get install firefox-esr

(05 Ott, 11:07) sacarde sacarde's gravatar image

Grazie Sacarde!!! Ho rimosso il ppa di mozilla e finalmente lo ha installato!!! Senti una ultima domanda come posso evitare che me lo aggiorni al 60 quando faccio sudo apt-get dist-upgrade... c'è un modo per fargli ignorare l'aggiornamento di Firefox? Non so un comando per dirgli ignora gli aggiornamenti di Firefox ... Grazie mille veramente

(05 Ott, 11:41) agostinom74 agostinom74's gravatar image

dovrebbe essere:

sudo echo nomepacchetto hold | dpkg --set-selections

https://www.chimerarevo.com/guide/linux/ubuntu-impedire-installazione-aggiornamento-pacchetti-apt-91094/

(05 Ott, 12:09) sacarde sacarde's gravatar image

Stavo giusto guardando quello!!! Lo avevo trovato e l'ho fatto. Per le dipendenze? Devo far altro? Nell'esempio parla anche di dipendenze.

FF deve rimanere alla versione 52.9.0 anche con "apt-get dist-upgrade", lo deve proprio ignorare per il discorso java e alcune cose che non funzionano piu se lo aggiorna al 60.

Ti faccio notare che ho anche Thunderbird all'ultima versione installato e per questo invece vorrei continuare a fare gli aggiornamenti.. Mi pare siano connessi Firefox e Thunderbird. O è sufficiente mettere firefox-esr? Grazie grazie amico :-)

(05 Ott, 12:46) agostinom74 agostinom74's gravatar image

Grazie!!! le dipendenze invece? è sufficiente mettere nel comando indicato : echo ----- firefox-esr? Ho anche Thunderbird e vorrei che questo invece si continuasse ad aggiornare, mi pare siano collegati.

(05 Ott, 12:53) agostinom74 agostinom74's gravatar image

le dipendenze di un pacchetto le vedi dal comando:

dpkg -I nomepacchetto.deb

nel path dove c'e' il file .deb

p.s. per thunderbird non ti saprei dire

(05 Ott, 14:41) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×92

domanda posta: 04 Ott, 13:59

domanda visualizzata: 48 volte

ultimo aggiornamento: 05 Ott, 14:41

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.