Salve a tutti, ho un problema che proprio non riesco a risolvere con Ubuntu 16.04. Tempo fa cercai di installare la libreria hvec265 per leggere i formati video ad alta risoluzione, evidentemente nel tentativo di aggiungere quella libreria commisi qualche maledetto errore, che non mi permette di installare altri pacchetti. Per esempio adesso ho bisogno che Ubuntu mi legga anche i drive formattati in exFat e per farlo digito da terminale

sudo apt-get install exfat-fuse exfat-utils

questo è il maledetto risultato che si presenta ogni sacrosanta volta: luigi@luigi-pc:~$ sudo apt-get install exfat-fuse exfat-utils Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze Lettura informazioni sullo stato... Fatto È utile eseguire "apt-get -f install" per correggere questi problemi: I seguenti pacchetti hanno dipendenze non soddisfatte: vlc-plugin-libde265 : Dipende: libde265-0 (>= 1.0.2) ma non sta per essere installato E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).

Chiaramente ho provato a dare

sudo apt-get -f install

Ma il risultato è questo:

luigi@luigi-pc:~$ sudo apt-get -f install Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze Lettura informazioni sullo stato... Fatto Correzione delle dipendenze... Fatto I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti: libavcodec56 libavresample2 libavutil54 libfdk-aac0 libjavascriptcoregtk-1.0-0 librhythmbox-core8 libswscale2 libswscale3 libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libx264-142 rhythmbox-mozilla Usare "sudo apt autoremove" per rimuoverli. The following additional packages will be installed: libde265-0 I seguenti pacchetti NUOVI saranno installati: libde265-0 0 aggiornati, 1 installati, 0 da rimuovere e 1 non aggiornati. 2 non completamente installati o rimossi. È necessario scaricare 0 B/264 kB di archivi. Dopo quest'operazione, verranno occupati 752 kB di spazio su disco. Continuare? [S/n] S (Lettura del database... 318772 file e directory attualmente installati.) Preparativi per estrarre .../libde265-0_1.0.3-1~ppa1~ubuntu16.04.1_i386.deb... Estrazione di libde265-0:i386 (1.0.3-1~ppa1~ubuntu16.04.1)... dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libde265-0_1.0.3-1~ppa1~ubuntu16.04.1_i386.deb (--unpack): tentata sovrascrittura di "/usr/lib/i386-linux-gnu/libde265.so.0.0.10" presente anche nel pacchetto libde265:i386 1.0.2-1ppa1~trusty1.1 dpkg-deb: errore: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta) Elaborazione dei trigger per libc-bin (2.23-0ubuntu3)... Si sono verificati degli errori nell'elaborazione: /var/cache/apt/archives/libde265-0_1.0.3-1~ppa1~ubuntu16.04.1_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

Vi ringrazio in anticipo per le risposte!

chiesto 05 Ott, 13:07

xjericho's gravatar image

xjericho
101

modificato 05 Ott, 13:14

domanda stupida... ma hai fatto: sudo apt update

(05 Ott, 17:18) sacarde sacarde's gravatar image

Sisi, il problema resta.

(05 Ott, 18:33) xjericho xjericho's gravatar image
  • non vedo vlc-plugin-libde265 nei repo, hai aggiunto un ppa ?

  • vedo il pacchetto libde265-0 versione 1.0.2-2

boh!

(05 Ott, 20:38) sacarde sacarde's gravatar image

Probabilmente si, non hai suggerimenti?

(05 Ott, 21:19) xjericho xjericho's gravatar image

ma vlc-plugin-libde265 ti serve ?

(05 Ott, 21:23) sacarde sacarde's gravatar image

ok, ho fatto partire il gestore pacchetti e mi rileva che c'è libde265 danneggiato, il messaggio di errore è questo: E: /var/cache/apt/archives/libde265-0_1.0.3-1~ppa1~ubuntu16.04.1_i386.deb: tentata sovrascrittura di "/usr/lib/i386-linux-gnu/libde265.so.0.0.10" presente anche nel pacchetto libde265:i386 1.0.2-1ppa1~trusty1.1

cosa mi consigli di fare?

(05 Ott, 21:28) xjericho xjericho's gravatar image

no, non mi serve, anzi, è proprio lui che mi causa tutti questi problemi.

(05 Ott, 21:50) xjericho xjericho's gravatar image

io proverei:

  • rimuovere il pacchetto

  • spostare il file: /var/cache/apt/archives/libde265-0_1.0.3-1~ppa1~ubuntu16.04.1_i386.deb

  • reinstallare il pacchetto

(05 Ott, 21:53) sacarde sacarde's gravatar image

quindi elimina i pacchetti in questione che non ti servono, e penserei anche il relativo ppa

(05 Ott, 21:56) sacarde sacarde's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×35

domanda posta: 05 Ott, 13:07

domanda visualizzata: 35 volte

ultimo aggiornamento: 05 Ott, 21:56

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.